Nest thermostat not showing up after integration

if you have a nest thermostat, did you restart it?

Yes, I held the Nest button down for 10 seconds. My whole process I removed the three apps, restarted the Nest Thermostat, after it was back up in installed SmartThings, google home, then nest. Went into SmartThings to see if anything changed and nothing for Nest thermostat was there. Not sure if it matter I do have nest temp sensors attached to my nest, I have other smart apps like Wyze, webCoRE, and Kasa. Not sure if any of this helps just trying to put as much info out as possible. My phone is an iPhone 11.

1 Like

Also I’ll add when I go to linked services in SmartThings IOS app and click on google nest it opens a new window and immediately closes the window like it failed and goes back to the linked services page. If I do the same thing with the linked Kasa app/service it shows the Kasa devices. Anyone else have this issue? Anyone else on iOS?

Did you remove Nest from ST before the whole process? If not, I think that’s the only thing I did differently. So I first unlinked Nest from ST app, and then removed all the apps, and then restarted Nest, then installed the apps. This time on the last page my thermostat showed up.

And just FYI, I’m on Android.

I tried again same way you did it and still not able to add or see anything. I’m thinking it might be an iOS thing right now. I have an old kindle fire I’ll see if there’s a SmartThings app for and try that next.

1 Like

This morning I took a look at the SmartThings app and the thermostat was there. So maybe it’s just time?

1 Like

Hi guys, having trouble adding my Nest Doorbell into Smartthings.
I’m not even seeing Nest under device brands.

Did you need to do anything else to get that to show up in the Smartthings app besides what was discussed above?

what region are you in?

Im in Canada.

Possibly a region thing, I just checked my app and it’s listed under doorbell brands.

you in the U.S.A?

same behavior here… after it fails Nest wouldn’t appear again on the app. Had to reinstall, shows it again but was unable to add devices. probably one of their many bugs.

Most of my Nest devices showed up, except for the Nest Temperature Sensors which I have a bunch of. I was hoping to automate switching the thermostat to run off the bedroom temp sensor at night.

sj

Hi all, great to see Nest integration at last.

I must admit was very excited until I tried to add it to a smartapp. For some reason, the Nest Thermostat does not appear in the options when selecting devices for the smartapp.

My Nest thermostat is showing nicely in ST app and works fine. However it simply does not show as a selected option in any smartapp you create. Any ideas or anyone confirm?

Many thanks,

with the official nest integration… nest devices do not show in IDE nor do they work with any custom 3rd party apps such as webcore, sharptools or actiontiles.

1 Like

Thanks for your reply

Ah that’s disappointing. Silly question perhaps but is there any way around this? An unofficial integration perhaps?

tagging @yvesracine

If you want to enjoy your Nest Tstat in all your preferred automation & smartapps, refer to this thread:

There are more commands & capabilities available, no throttling, and it’s feature-complete. It’s groovy-based solution, so, it’s compatible with all smartapps and automations.

And, there is also a version for the Hubitat platform if you want to switch hub later…

Regards

I’m not sure if there was a solution for this but I was able to get this resolved by doing the following.

If you tried to add a NEST Thermostate in Smartthings and got all the way to the Successfully connected to NEST. I tried re-installing NEST app and restart the Thermostate but didn’t do anything. Also unlinked Smartthings from my google account.

What did work immediately was the following:

  1. open Smartthings app
  2. open settings
  3. Linked Services
  4. NEST should be one of the services
  5. press on NEST and delete Device
  6. Go back to the Smartthings app home screen and add a device
  7. Locate NEST and attempt to link your thermostat again

This allowed me to link it to sign into my Samsung account and it was added immediately.

Here why I think that works, when NEST adds itself as a service during the setup, it must be using Google auto-login feature to log into Smartthings. since most of us have a dedicated Samsung account it isn’t able to find your smart things home, therefore never appearing in ST at all. I was able to determine this by going into the Logs for ST and not once I saw the NEST/GOOGLE service reach ST. I should have seen some logs indicating NEST was accessing my ST unless the wrong account was being used.

I do that and my Gnest app still doesn’t show up in smartthings app list