Need to reset Aeon outlet almost daily

It sounds like a defective device. It can happen even with good brands. :disappointed_relieved: I would return it or request warranty service.

[quote=“tobycth3, post:1, topic:54590”]
replaced the outlet (both with an identical unit and a different version)
[/quote] Yup, tried that already :wink:

That sounds like a non responsive device that kills your mesh. I am surprised that the repair finishes successfully. Are you sure you are not missing the zwave errors while running the repair? I’ve had that happened to me once or twice. It may be the zwave radio on the hub too…

Mine acts same way. It works for a little bit, then it stops communicating and I have to unplug it and plug it back in. Works again immediately, but then eventually stops working.
One thing I noticed is that my Aeon SmartSwitch6 initially registered as a Z-Wave Metering Dimmer. I’m going to try changing the device type to a Z-Wave Metering Switch and see if that helps. If not maybe just change it to Z-Wave Switch.

Sorry, just noticed that you said you’d already tried a replacement. That’s really weird then. Is this the only secure device that you have on your Zwave network? And what happens when you run the Zwave repair utility?

It’s possible that there’s occasionally local interference blocking zwave communication (this is almost always a baby monitor or an old cordless phone) and that all the other Zwave devices are able to reattach to the network but the Aeon pocket socket fails because it requires a secure Join.

1 Like

Repair finishes perfectly with no errors

Then I’m guessing this has to do with the reason why these devices are such a bear to pair to begin with. They use secure pairing, which very few zwave devices use. Consequently, they are more fragile when there is a glitch on the network.

Well poop. Any way to disable secure pairing? :yum:

Look in the manual. My guess is that one push durin inclusion process is non secure.l, two pushes within one second is secure, or that’s at least how their motion sensor works. Honestly, I wasn’t successful at including the motion with mon secure, and support was, well unsupportive…

@Robert_Vandervoort might know what’s possible.

Which Device type handler are you using?

1 Like

SmartThings Aeon Outlet device type

@duncan are there any issues with Aeon secure devices that you know of? This incident seems awful similar to the issue I had with my Aeon motion sensors.

@tobycth3 , based on my motion sensor experience, try switching the handler to a community one and see if that fixes your issues. Since I changed the handler on my motion sensor, I had no more issues.

1 Like

I wrote a device type for the smart switch 6. Someone recently told me it didn’t find his switch properly because the fingerprint apparently has changed in later firmware. Also he is on a gem 2 hub and I’m staying gen 1 after all the crap I read about it. To top it off my switch had a very short life operating an air cleaner. There is another thread about it on here. Would link but I’m going to bed.

My handler should work fine if you switch it out. As far as Aaron goes they generally have pretty good support but like many automation companies, lean on the community. I’ve written several handlers for them that SmartThings dev or the community have polished up over time. The doorbell handler is a perfect example. Anyway secure and non they will do both. Single tap for non double tap for secure just as you supposed. I always do secure. There is a lot more noise on the network with secure because of certificate exchange and the more secure stuff you have well it adds up. I’ve listened to it with an RTL-SDR. The issue you report with the zwave repair and power cycling etc can be so many different things. If taking one device out of the mesh fixes all the problems then safe to say that is the issue. All the plug in the wall stuff should be a routing slave that is signals are passed along from and through them. In theory it extends the mesh. It could be the power mode has gone low and transmit power is sucking but receive is good. That’s like playing telephone with someone wearing a ball gag. The gen 6 smart switch and dimmers from Aaron do support the power command class. I’ve found some hidden functionality in there actually at least on the original firmware. If you hold the action button for 6 seconds it would blip and send out some transmit power reports. I’d have to check but I think I included that in my handler. I always try to make really complete handlers so everything gets parsed, useful or not.

Have you done the factory reset on the switch itself yet? One of the bad parts j guess is if ST recognizes your device as X and it is Y, it can send some bogus configuration parameters over. Not sure if that’s your issue but I’d say give my device type a try, might work for you. If you’re on gen 2 hub and a newer smart switch the other guys modified handler mah work better for you.

If you can’t find the thread let me know I can. Bedtime for now.


Yeah, the six model is not actually on the official SmartThings compatibility list. So I’m guessing that the stock device and it pairs with is for the older model. That in itself might be causing the disconnects. So I would definitely try it with one of the community-created device type handlers made specifically for this model and see if that helps.

If you haven’t used custom code before, here’s the FAQ for that,

Thanks everyone! I added @Robert_Vandervoort custom device handler to the outlet last night. Now time to play the waiting game and see if it helps. :slight_smile:


And the verdict?

1 Like

I lost power a couple of times over the weekend (love south Florida) but early testing seams positive


Hmm. Dirty power can wreak havoc on any electrical device. I’d be curious to see what your supply mains look like voltage wise over the course of a week. I know when I lived in Hobe Sound we got brownouts regularly. Mostly people’s ACs kicking in I believe.

1 Like

Well, I spoke too soon. The new device handler works for a short while but then things start to slow down to a crawl. It got so bad to the point that I couldn’t even do a z-wave repair. Last night I change the device type to ‘Z-Wave Switch’ and ran a repair. Almost instantly devices were responding super quick. Unfortunately I lost a ton of functionality such as power reporting, LED control, etc. I’m going to try running like this for a few days to see how it goes but worse case I’ll remove these and just install a hardwired GE outlet. Anyone looking to purchase some second hand Aeon outlets? :yum:

1 Like

Still no go. Using even the default device handler (Z-Wave Switch) still locks up after frequent use. I say frequent because doing anything intensive (turn on all lights, turn off all lights, etc) reproduces the issue almost every time. Otherwise it just appears normal usage over a couple of days causes it. I removed them last night and installed a hardware GE outlet. Since the handler was already set to Z-Wave Switch and that’s the same type of handler for the GE, I was able to do a replace function without any issues. I ran 3 repairs (15 min apart) and each one completed successful.