Need Help. - You are not authorized to perform the requested operation

It’s been a while but we all left the house this evening and my goodbye routine didn’t trigger, even though the automation showed we were away, which should have triggered Goodbye. I tried to check the setting and I get this error message

“ You are not authorized to perform the requested operation”

This happens when I tap the gear icon on any automation. I also get errors on the main settings page saying “Error saving location” by just trying to back out and not save a location.

Also when I check on any of my Smart Lighting setups, the screen just spins.

Lots of issues here and I am not sure what’s going on. Too late to call as ST is closed.

try signing out of the app and signing back in

I should have mentioned that. I did try it and it didn’t change anything. I did not try uninstalling and reinstalling it.

We are seeing degraded performance. I’d expect a status page update soon.

Some of the main impacts we’ve seen so far include editing locations (Classic app), creating/editing rooms (Classic), saving Groovy SmartApps such as Smart Lighting (both apps), adding devices which use a Groovy SmartApp such as Arlo (both apps), creating/editing Routines (Classic), and automated execution of Routines.

1 Like

I’ve seen similar behavior with my setup. I set a webcore rule to trigger the goodbye routine if everyone leaves and the goodbye routine didnt trigger for 3 minutes as a backup and it has fired numerous times over the past week.

Today I got the same error when trying to edit any routines.

Glad it’s not just me here. Thanks for the replies. Tried the WiFi/cellular and no change there.

Same here. I need to update a routine because of a faulty device and I get the error. Also I noticed in the past few days that one of my evening routines takes about 10 seconds to run which normally takes about 3 secs

EDIT: looks like ST is showing degraded performance on devices: