Need help to let me change driver

Hi there, 100% brand new in here - but have used Smartthings for the last 5 years. But havent had the need to move stuff around or add devices, for a hvile. Actually, last time was on the “Groovy ide”

for the last years i have had som “Aqara door/Windows magnets T1” but they have been online/offline (well more off than online)

But now we bought the new “Parasoll” from ikea and when connecting them was easy, but getting them to stay online is not possible (Just like the aqara units)

And im not able to thange the driver (they are a “Zigbee Thing” right now, and no possibility to change it to “Zigbee switch”) The Aqara T1 has both “Zigbee thing” and Zigbee Switch" as driver to choose from

The Aqara drivers

The Ikea Driver

Drivers downloaded to hub:

So all in all… how do i get my hub to understand that it has to keep the Aqara and the IKEA Parasoll units online - constantly

and how do i get the possibility to change the driver for the IKEA Parasoll??

Thanks so much in advance… i havent got much hair left, its all torn out the last couple of days :wink:

In the new architecture, a device can only use an edge driver if the “fingerprint“ of that device is in a driver which has been downloaded to your hub.

When you can add a device to your Account but it only shows up as a “thing“ that means no drivers on your hub have that fingerprint.

IF you can find a custom driver that does have that fingerprint, you can download that to your hub, and then you will be able to change to that driver in the SmartThings app.

How do you find a custom driver with that fingerprint? You can try the quick browse lists:

FAQ: Using the quick browse lists without the community wiki

Or you can search the forum for that device name.

If you can’t find one, then you can request that a community developer create one. There’s a thread for that. Make sure you read the first post carefully, because there is some information that you need to post with your request. No guarantees, but if it’s A popular device or uses commands similar to another device, you may get a response.

Post Requests for Zigbee Edge Drivers Here (community-created)

So once you have a matching edge driver on your hub, it’s pretty easy to switch. The hard part is the research you have to do to find one or get someone to create one. :thinking:

1 Like

As far as frequently going off-line, that’s a defect of the SmartThings platform, and happens with all kinds of devices for multiple reasons. In most cases, the device isn’t actually off-line: SmartThings is incorrectly marking it as being “off-line”.

Sometimes a different edge driver will fix that, sometimes there are other things you can do to fix it, and sometimes it’s just an annoyance caused by smartthings. :rage:

Usually, if you can find an edge driver with your Devices fingerprint, there will be discussion in the thread about that edge driver as to whether it fixes the off-line issue or not.

Separately, it sounds like you might also find the first part of the following FAQ helpful:

https://community.smartthings.com/t/faq-i-have-no-idea-what-edge-is-is-that-a-new-developer-tool-2022/

2 Likes

BTW: Aqara does offer a new option which might help the off-line issue.

Get their M2 hub or another one of their hubs that also works as a “matter bridge“, add the sensors to that hub, then add the hub to your SmartThings account as a “matter bridge“ and it will bring in many devices with it, although not all models are all features.

https://www.amazon.com/Aqara-Control-Automation-Supports-Assistant/dp/B08Y1PJZZH/

(The aqara e1 stick is an even less expensive option, but I haven’t tried that one myself.)

Since that doesn’t let SmartThings do its usual “off-line” calculations for the individual sensors, they are much less likely to get incorrectly marked off-line

I use this method myself with an Aqara Button, and it’s way more reliable. So just another possibility

The matter connection is still local, which is good.

Here’s aqara’s list of which of their devices can get to another platform (like smart things) through their matter bridge

If you do go that way, of course, you would need to re-create any automations using the device you switch over to the aqara hub so that might be too much effort. But I did just want to mention the option.

And IKEA does not yet have any matter bridges, so this option would only help with your aqara devices.

1 Like

Zigbee Switch driver is not supporting Aqara Door/Window sensor.

@Mariano_Colmenarejo has added this device to his driver

  • id: “LUMI/sensor_magnet.aq2”
    deviceLabel: Aqara Door and Window Sensor E1
    manufacturer: LUMI
    model: lumi.sensor_magnet.aq2

You have to enroll to Mariano’s Edge drivers Channel and install his Zigbee Contact Mc driver.

Follow these steps:

  1. Sign into your Samsung Account and select Accept the Channel invite.
  2. Choose the target hub and select Enroll.
  3. Navigate to Available Drivers and install the one that matches your device.
  4. From the mobile app, onboard your device using the Scan Nearby option.

This is the link to Mariano’s Edge drivers Shared Channel
https://api.smartthings.com/invitation-web/accept?id=6b68563b-1905-4654-8d2b-e677a2997424

3 Likes

As far as I know there is no driver for this Ikea Parasoll.

@Mariano_Colmenarejo Is it possible for you to add Ikea Parasoll to Zigbee Contact Mc driver?

Fingerprints are in this Groovy driver:

hubitat/ikea-zigbee-drivers/E2013.groovy at main · dan-danache/hubitat · GitHub

3 Likes

Hi,

This device exit some time ago

- id: "Ikea/PARASOLL"
    deviceLabel: Ikea Door Sensor
    manufacturer: IKEA of Sweden
    model: PARASOLL Door/Window Sensor
    deviceProfileName: contact-battery-profile
5 Likes

Thanks a lot for your suggestions and help!!

Actually i do have the E1 stick, but when i tried to connect the T1 switches, they dissapeared after a while - so it was pur back in its box… maybe i should try once again.

Thanks for the links, i will take a closer look

1 Like

Thanks to yo too… i did DL that driver, and gave the T1 switch that driver, then it immediately looked different on the ST app… but it says it are waiting to update the status" - and is gone offline again…

Sorry, but i don get this…

Is it possible to dovnload that driver, or isnt it available?

in case it is possible to download, where do i get it then??

thanks in advance

@Steen_Larsen

In this post is the link

1 Like

okay, i missed that, or at least, now i found it…

i the get a code - but how do i download the code to my hub?

Sorry im asking stupid, but im really lost here… :exploding_head:

Open the link
Acept the smartthings use conditions
Enroll your hub in the channel
search the zigbee Contact Mc driver and click in install.
Put your device in pairing mode
With App, add new device and use search nearby option.
New device will appears after some seconds or 1 minute

It sounds like the following community FAQ might help:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

All custom edge drivers are installed in the same way.

  1. follow the invitation link that you will get from the forum thread about the edge driver or maybe from the authors GitHub

  2. subscribe to the channel

  3. select the specific edge driver that you want downloaded to your hub. It will usually download in a few minutes, but there have been some reports that it’s taken up to a few hours

  4. once it is on your hub, if you add a new device that matches that fingerprint, it will use it. Or you may be able to switch from one edge driver to another using the device details page in the SmartThings app, but that doesn’t always set the configuration correctly. so sometimes you just have to try it to see if it works.

——
Again, see the community FAQ for more details on the process. :sunglasses:

4 Likes

Big thanks to everyone helped me…

This morning the Ikea Parasoll stays online, and the function shows On/Off - and works in a scene. The Batt status isnt there yet - but… i dont care… as long as the work :grinning:

I have been soooo frustrated about this, and tried so many things. So on top of this, i didnt think of rebooting the hub after installing the driver.

I did that in the morning, and repaired (Reset, then connect) and bingo… they worked…

THANKS!!! :star_struck:

3 Likes