Need help setting up testing for my cloud connector

Hi, I’m trying to create a cloud connector project (or at least I think that’s what it’s called). My goal is to provide my own devices, so my end goal is to show up in the “add device” section and to be able to add one of my own devices. It’s just a personal project so it’s just going to be my devices and I’ll be the only user.

I’ve gotten pretty far in implementing the whole thing and I want to start testing, however that’s not going very smoothly. I’ve already created a project (a schema app/cloud connector) and deployed it to testing. I’ve also enabled developer mode on my phone. However, I can’t find my own app in my “add device” screen, there’s also no “add device manually” or “my testing devices” like the documentation says there should be. The documentation also says something about needing to add device IDs to the cloud through the test->test devices panel, but that doesn’t exist on the dashboard. The testing tab just contains the “developer mode” panel.

Does anyone have any idea how I can find my own cloud-connector in the app?

Hi @SanderRonde,

Your saying that you try to connect using a cloud connector, and are working with your own device.

Just to understand, is your device connected to the internet via an other cloud or only locally available within your network?

If you can only connect to the device in your local network, have a look at building a ZigBee, Z-Wave or Lan driver.

Please let me know if you need more assistance?

It’s connected to the internet using a sort of local cloud I built myself. You can think of it as a home assistant project. This is also the same project that should talk to the SmartThings cloud and should act as a sort of bridge between the two. Where SmartThings can ask it for available devices and it will list those devices that I have locally.

tagging @TAustin - I think you were doing some work around this inside EDGE?

What are you using to host your app? AWS Lambda?

It’s been a long time since I’ve done this, but if I recall, as long as you have developer mode enabled in the app, you should be able to do an Add device, then make sure it is displaying ‘By device type’, then scroll ALL the way down to the bottom, and that’s where you should see an icon for your test device. If it’s not showing up there, there may be something wrong with your project definition in Developer Workspace.

Yup that was it. I had to sort by device type and it was at the bottom. I expected it to be in the “by brand” section since I didn’t define any device types yet. Thanks!