Need Help Hikvision Camera Please!

devicetype

#1

I have 4 Hikvision camera’s that support going to a URL to get a live picture and trying to get it to work with ST. I am using the Generic Camera Device Handler and created a device and using these settings below:

Preferences (edit)
Name Type Value
CameraAuth bool true
CameraIP string 192.168.175.176
CameraPassword string *********
CameraPath string /Streaming/channels/1/picture
CameraPort string 80
CameraPostGet string GET
CameraUser string admin

If I go to this URL I have to authenticate then I get the picture so going through the browser works but I cannot get the device to work as it just gets stuck on “Taking” when I press that button.

095135d3-1550-46fa-90f9-47ca5ffb5ef0 12:24:34 PM: debug GET /Streaming/channels/1/picture HTTP/1.1
Accept: /
User-Agent: Linux UPnP/1.0 SmartThings
HOST: 192.168.175.176:80
Authorization: Basic *************************==

095135d3-1550-46fa-90f9-47ca5ffb5ef0 12:24:34 PM: debug The method is GET
095135d3-1550-46fa-90f9-47ca5ffb5ef0 12:24:34 PM: debug The Header is [HOST:192.168.175.176:80, Authorization:Basic YWRtaW46SXRpc21lMTk3NQ==]
095135d3-1550-46fa-90f9-47ca5ffb5ef0 12:24:34 PM: debug Uses which method: GET
095135d3-1550-46fa-90f9-47ca5ffb5ef0 12:24:34 PM: debug Requires Auth: true
095135d3-1550-46fa-90f9-47ca5ffb5ef0 12:24:34 PM: debug path is: /Streaming/channels/1/picture
095135d3-1550-46fa-90f9-47ca5ffb5ef0 12:24:34 PM: debug The device id configured is: C0A8AFB0:0050
095135d3-1550-46fa-90f9-47ca5ffb5ef0 12:24:34 PM: debug 0050
095135d3-1550-46fa-90f9-47ca5ffb5ef0 12:24:34 PM: debug IP address entered is 192.168.175.176 and the converted hex code is c0a8afb0


(Different Computers. So happy with Indigo.) #3

I’m not using that camera, but I’m having trouble getting that device driver to work with IP Cam from the iOS App Store.

it appears to be configurable to work, but it just stalls forever at TAKING.

List Events says “take command was sent to PondCam” but nothing is returned.


(Ray) #4

This is just from memory so it’s just a guess but there is something about the picture size and ST server. Possible it’s too big and causing it to stuck on “taking”. Can you go into your camera setting and set it to lower resolution for picture?


#5

I tried to change the resolution but I can only find video resolution the pictures seems to be all at the same. I even tried:

http://192.168.175.176/Streaming/channels/1/picture?snapShotImageType=JPEG?resolution=640x480

But it does not change the picture resolution.


(Patrick Stuart [@pstuart]) #6

As I stated in the main thread. Hikvision cameras will not work. I have one and have tried practically everything.


#7

Thanks Patrick I appreciate your help. Bad news for me but that’s how it goes :slight_smile: have you tried with a Hikvision NVR?


(Patrick Stuart [@pstuart]) #8

No, haven’t tried the nvr, but unless it outputs an image much smaller in bytes then the camera, it simply won’t work.


(Different Computers. So happy with Indigo.) #9

any tips for making the generic camera device type work with what appears to be a properly formed, low resolution MJPEG output? logging shows the ST device sending a request, but nothing happens after that–no error, no result.


(Patrick Stuart [@pstuart]) #10

check the NDI make sure its the MAC address or the IP:PORT in hex. keep in mine it must return “image/jpg” and not a html page or other docType.


(Different Computers. So happy with Indigo.) #11

The what?

And where would the IP:PORT be in hex? I looked in the Device and they’re shown as text.


(Patrick Stuart [@pstuart]) #12

Sorry, typo, DNI Device Network Id

In IDE, devices, choose the device, click edit, enter Device Network Id.

My deviceType should automatically set it, but SmartThings is known to break that many times over.

Also, make sure there isn’t any other devices trying to use the same DNI.

The IP:PORT should be in HEX notation, which would be a string / text, for example: c0a865f9:0050


(Different Computers. So happy with Indigo.) #13

Had good hex, but on 1 of the cams I found a typo in the IP address.

Really basic question that might be the problem: If the proper address for the image is
http://192.168.0.99:8888/video

is the path to image
video
or
/video
?


(Patrick Stuart [@pstuart]) #14

/video

(20 characterss)


(Different Computers. So happy with Indigo.) #15

Checked the DNI, it’s in hex.

double checked the addresses, they’re good.

made sure the image is small, they are.

Still getting a long “TAKING” delay, with nothing ultimately returned. Looks like there’s just some plain incompatibility, though I can’t imagine what. The raw stream is a simple image, not imbedded on a page.


(Patrick Stuart [@pstuart]) #16

And sometimes SmartThings just doesn’t work. The s3image function is unsupported and fundamentally broken. So the fact that it works occasionally is more of a bug than a feature.


(Dj Anu) #17

Patrick, Since you mentioned you have a Hikvision Camera Can you look at the Drew’s code. I am using his code and take image works fine however I can’t make use of camera’s motion detection.


(Patrick Stuart [@pstuart]) #18

What code?


(Dj Anu) #19

This one mentioned here. I can take images from hikvision with this code however motion doesn’t work…


(Patrick Stuart [@pstuart]) #20

I cannot support or endorse code that requires you to port forward your camera.


(Tim) #21

@nmelanson @pstuart @DjAnu

Hi guys, so is the consensus here that HIKVision cameras DO NOT work with SmartThings?
I’m trying to accomplish this also… any luck? Any tips?