Nanoleaf Essentials won't connect to Smartthings

I’ve had a gut full of Smartthings. I’m about to cease using my Smartthing hub because I spend countless hours doing the same thing, expecting a different outcome.
It’s a V3 hub and I’m on version 1.7.09.16.
I have two Ikea lights and an Ikea switch. Both have been working intermittently for a couple of years, but in the last week, I have had to reset the globes three times, and as I type this the lights are offline.
But the most annoying thing is trying to connect a new Matter compatible Nanoleaf Essentials globe. I have wasted hours and hours and hours on this, but I have now given up and will now unplug my Smartthings. The hours I spend on it are outrageous.
For those who want to know, my Essentials globe is operating under the Nanoleaf app, and Apple HomeKit. Setting those up was easy, but when I tried it with Smartthings, no dice. I see the dreaded “Something went wrong” message with the explanation that the globe wasn’t discoverable. When setting it up, I didn’t use the QR code that came with the globe because it was used in the Nanoleaf/Homekit setup. Instead I opened the settings behind the globe in HomeKit and clicked on “Turn on pairing mode” and noted the set-up code which I used in Smartthings. Shortly after it responds with Something went wrong, and that the device wasn’t discoverable, which contradicts HomeKit which said my device is in pairing mode.

Bah to Smartthings

A lot of people, including myself, have been having trouble onboarding Matter devices in the ST app lately.

1 Like

Interoperability of Matter over Thread devices is hampered by the lack of a standard for how to share security keys. I can’t find it right now, but @JDRoberts did a big writeup on it several months ago. Hopefully he can share it here.

I think this is the post you were thinking of:

Basically right now where you start, can make a big difference, and in particular, if you add a device using an android phone, you need to continue to use android to add it to a different matter controller, and the same is true for iOS. Otherwise, they have a hard time sharing the security key. I don’t know if that applies in this case, though. :thinking:

1 Like

When I get rid of ST I won’t have the hassle. From the outset, my Smartthings experience has been poor. I have Lifx and Nanoleaf smart lights (Not panels or strips) and the Lifx devices reside happily in ST, but Nanoleaf Essentials (pre Matter) won’t connect.

Thanks

Ah— that’s a different question. I don’t believe either company ever said those models worked with smartthings. The matter models do.

To be fair, there are also a bunch of devices that work with smartthings, like Z wave devices, that won’t work with the Apple home app. That was exactly the problem that matter was designed to solve: the tediousness of trying to figure out what works with what. :thinking:

If you open the smartthings app and go to add a device and drill down, you should be able to see exactly which nanoleaf models Do work with smartthings.

All of this is why we have the first rule of home automation: “the model number matters.“

I guess I took the waffle published about Matter for granted, assuming that my V3 Matter-enabled SmartThings hub would automatically connect to a Matter-enabled Nanoleaf Essentials globe. Instead I get “Something went wrong” and an error message saying that my globe was unreachable, despite it being in pairing mode.

Regards

Brandon Cheshire

cheshbr@gmail.com

049 007 0577

Nano leaf makes some “essential” models that are matter compatible and some identical, looking “essential” models that are not matter compatible. So, which one do you have?

If it’s the early pre-matter model, it’s not going to work with smartthings.

If it’s the one that has the matter logo on the box and has matter in the product description, it should work, so, if it isn’t, you’ve run into one of the matter glitches. :thinking:

Thanks for replying.
I have four pre-matter Nanoleaf Essentials, and a Matter-enable new Nanoleaf Essentials globe with “Matter”on the box.
It’s the latter device I’m having trouble with.
Would you believe that I got it working by installing it on ST first, then Homekit and the Nanoleaf app.
Unfortunately I had to move it and it hasn’t connected to ST since.

It connected to Homekit and the Nanoleaf app easily, but not ST.

Here’s something I noticed. It’s connected to Homekit, and on a couple of attempts ST advised that it was trying to connect with iCloud, but via Homekit it was already connected to iCloud. Note that I use the pairing code when I try connecting ST

Regards

Brandon Cheshire

cheshbr@gmail.com

049 007 0577

I’m having almost identical experiences with three Nanoleaf matter capable essentials bulbs. They all pair instantly in the Nanoleaf app, but beyond that is a comedy of random failures.

I was able to get all three mostly working in SmartThings but I had to replace my home router and all three went offline, never to be seen by SmartThings again. One kept working in Apple Home, the other two were ‘unreachable’. The Nanoleaf app saw all three. I finally deleted all three from every app, iCloud, and did factory resets to start from scratch.

Now I can get all three working in the Nanoleaf app, but maybe a random one into Home after enough tries. SmartThings never works, failing usually at the ‘add to iCloud’ step but sometimes when registering with SmartThings. The error is always some flavor of not being able to access the device. Been around the block on this merry go round at least 20 times.

I’ve tried every combination of which app to add to first but no luck.

I have noticed that the Nanoleaf app shows the bulbs as connected via thread or Bluetooth, bouncing back and forth randomly every few minutes. This doesn’t seem like proper behavior and I’m suspicious of the issue being related to unstable connectivity. The bulbs are about as close to the router and border devices as physically possible, so I’m hoping it’s not a distance thing. The fact they all connected before and nothing has moved makes me think this is more about poor software.

1 Like

Thanks.
I have unplugged my Smartthings hub and replaced all my lights that connected to ST, namely Ikea and Osram. No more ST.
Now I have Lifx where those lights were.
Lifx are not (yet?) Matter compatible but when adopting Lix globes into the Lifx app, they auto-connect seamlessly to Apple Home, Google home and Amazon Alexa, something the Matter fraternity could pay attention to.

I also have five Nanoleaf Essentials globes, one of which is Matter-enabled. All the Nanoleafs, when adopted into the Nanoleaf app, auto connect with Apple Home, but not with Alexa. The Matter-enabled Nanoleaf globe was bought to experience Matter, which I think is very underwhelming at the moment. I have Apple border routers (Apple TVs and HomePod Minis) and Thread works between Apple and Nanoleaf but nothing else. Amazon makes it sound as though integrating Matter with Alexa is a foregone conclusion, but when attempting to implement Matter, something goes wrong (Memories of Smartthings, eh?). Amazon’s response is to move the Matter enabled device closer to my Echo. What? Now it seems to integrate Matter with Amazon devices you need a Matter-enabled hub from the Alexa ecosystem. That’s not my understanding of how Matter is supposed to work.

Oh well, it’s in its infancy. In the meantime I’m enjoying my Lifx experience and the absence of Smartthings

Regards
Brandon Cheshire
Ph: 049 007 0577
Email: cheshbr@gmail.com

You may want to edit three of your posts and remove personal info… email, phone number and name. Be careful when replying by email that attaches a signature file containing that info. :wink:

3 Likes

Technically there’s no such thing as a “matter hub.” That’s because matter exists at a level above the network communication level. So you have “matter over Wi-Fi“, “matter over thread,” and “matter via bridge.”

What matter does have are the following:

A) “Matter commissioner.” Almost always an app. This is what you use to add a matter device to an account. The smartthings app is a matter commissioner. So is the Apple home app. So is the Alexa app, although at the time of this writing, it didn’t have as many features as the others. There are several others, including LG’s THINQ app used with their televisions and smart appliances.

B) “Matter Controller.” This is probably what you were thinking of as a “matter hub“. This handles the message traffic between matter devices. So far most home automation platforms have been adding the Matter controller functionality to their hubs. smartthings V2, smartthings V3, the Aeotec “works as a Smartthings Hub, “ the SmartThings Station are all matter controllers. So is the apple HomePod mini and Apple TV box, some Amazon echo devices, and some Google home devices.

You have to have a matter controller to use matter devices with any platform. You can’t use the smartthings hub to act as a matter controller for the Alexa app, which may be where you got confused. Each platform has to have its own matter controller or it can’t use matter.

In smartthings, for example, the vast majority of smartthings customers at the time of this writing did not have a standalone hub. If they have a smart appliance like the refrigerator, they may be able to add a dongle which can act as a matter controller. And some of the Samsung smart TV models have a built-in hub, which can also act as a matter controller. But if you had, say, just a galaxy phone and a Samsung robot vacuum, you would be using the smartthings app, but you wouldn’t have any SmartThings matter controller, so you wouldn’t be able to use matter devices in a smartthings app. Even if you had a Matter controller from a different brand, like a HomePod mini, or a Google Home model that was a Matter Controller for Google.

C) “Matter bridge.” This is a device specifically made to allow one platform to connect devices joined to its matter controller to a different platform using that platform’s own matter controller. There are only a few of these right now.

None of the smartthings hubs act as a Matter bridge. The switchbot 2 hub and a number of the Aqara hub models are matter Bridges. You can add the bridge to your smartthings account, and it will bring along with it some of its connected devices (but not all models or all features.).

For example, I have added my Aqara Hub M2 hub to smartthings as a matter bridge and it brought in an aqara smart button with it.

Matter bridges work in a very similar way to the way the Phillips hue bridge worked before matter. You connect individual devices to the bridge. Then you add the bridge to your home automation account and it brings those devices with it. And just like the Philips hue bridge, a Matter bridge can be connected to multiple home automation platforms at the same time.

D) “Matter binding.” the independent third-party standard developing matter also intended for it to be possible to bind two Matter Devices together, like a Sensor and a smart bulb, without needing a Matter controller. However, as far as I know, nobody has actually implemented this yet. :thinking:

———-
So, at the time of this writing, to use a matter over thread smart bulb with Apple Home, SmartThings, Alexa, and Google Home simultaneously you would still need a separate Matter commissioner and matter controller for each of those four individual platforms. Four platforms: four matter commissioners, four matter controllers.

But each of those platforms would be able to control the same smart bulb, so for your everyday use in terms of device control and creating automations, you could use any of the four apps that you wanted (and any or all of the four voice assistants) after the device has been set up.

Matter doesn’t actually change anything at the network protocol level. Wi-Fi is still Wi-Fi, Thread is Still Thread, zigbee is still Zigbee. So it doesn’t change the number of hubs you need. That’s the underlying architecture of how messages are sent back-and-forth electronically.

What it changes is the next layer up where app control and voice assistants work. (This is called the “application layer” in network engineering.) what’s new is being able to use any or all of the participating user interfaces with the same device at the same time, again, once the device has been set up.

@nathancu @jkp @Automated_House @HalD

10 Likes

I’m having similar issues with my Nanoleaf Essentials Matter bulbs.

Regret buying them, they’re flakier than my late grandmother’s pie crusts.

2 Likes