My Third Reality Smart Button doesn't work

I just purchased the Third Reality Smart Button from Amazon and tried to connect it to my SmartThings hub v2. It connects but none of the button presses are working. They don’t register at all with the hub. Is anyone else having this problem or have any advice? Thank you.

1 Like

It requires a custom Edge driver.

@csstup created one for it.
Let me see if I can locate the link to it.

See if this works: zigbee button CS


Which model? I got two of these on Black Friday and they connected fine without me using anything special and an able to use the 3 different button settings. Connected as an IKEA button in my V2 hub.

1 Like

What driver are they using?

Yep, this is the exact same one I purchased but it isn’t working for me.

The driver I wrote seems to work for most people.


How did you set up the button presses? I didn’t use a routine, but the built in automation in the device control screen instead. I assumed that was the same as building a routine, but maybe it’s not not.

If the driver suggested in this thread works, I’d just try that. I’ve been wondering if these would migrate given they didn’t pair with edge so have been thinking of migrating to a custom driver anyway.

It is using the IKEA button.

@csstup this worked!! However, I am only able to get the single button push to work, not the double press or the long press.

Thank you so much.

Double and long press you gotta hold your mouth right for it to work.

(Kidding, but there’s some pretty tight timings for double to register)

With mine, using the Ikea Button dth, I found I just had to slow down. Mouse double click speed didn’t work but . . . not sure how to describe the pace. . . maybe door knock?

How about the long press? How long do I need to press for it to register? I feel like I have tried many different timings for both the double and long press and neither seem to work at all.

The timings are controlled by the device, not by the driver. The driver just sends what type of “click” it decided was made. During testing I found that I often missed the double and hold press.

Geese, bought mine in November and its been flawless, but stopped working a few days ago. I deleted the Button from SmartThings and re-added. However, now it only sees it as a “Zigbee Thing” using a generic SmartThings driver not as a button.

1 Like

SmartThings never migrated the fingerprint from the Ikea Button DTH to an Edge driver. So when the migration to Edge moved it it FUBARd the device. There’s a community edge driver in here somewhere you can install and move it to.

thanks! Found the Edge driver and its all working again!

I was experiencing the same issue, but was able to resolve by using the driver that @csstup created. Here is the link I used:

1 Like