My First Automation -- Didn't work as planned

I set up a simple automation last night that only half worked. Here’s what I did:

Every day 5 minutes before Sunset, I have my Foyer Lamp and my Family Room Lamp turn on and send me a notification. Both Lamps are currently using Cree LEDs. This automation worked perfectly.

Every day at Midnight, I have my Foyer Lamp and my Family Room Lamp turn off and send me a notification. For whatever reason, the Foyer Lamp turned off at midnight, but the Family Room Lamp did not turn off at all. Again, these lamps are both using the same Cree LEDs.

I checked my automation to ensure that I had both lamps turning off and it looks like I did everything correctly, yet my Family Room Lamp failed to turn off at midnight.

Anyone have similar issues? Are automations generally reliable? Or is this a hit-or-miss thing with the ST hub? It’s not very encouraging that my first night using an automation failed to turn off a light as scheduled.

Are you using ZigBee or ZWave switches to control them or are these WiFi bulbs? If one turned off and the other didn’t it sounds like a packet loss situation.

1 Like

If they’re Cree, they should be zigbee, unless Cree has a new line out.

1 Like

I’m sure that’s very frustrating. :disappointed_relieved:

Can you post a screenshot of your automation? Was it in smartlighting or just a custom automation?

Not sure…they are probably about two or three years old and they are just Cree LEDs that screw into a regular lamp. Got them for free and put them into those two lamps and they always worked great with my Wink Hub.

Not sure why one turned off and the other one failed to turn off.

So the next question has to do with the physical layout of your network. That’s where the packet loss that @RBoy mentioned could come in.

  1. Is your smartthings hub in the same physical location As your wink hub was, and is your wink hub turned off power?

  2. have you moved all of your old devices over to smartthings, or just some of them so far? (Looking for the possibility that you had a repeater device that worked with Wink that hasn’t been moved over yet.)

  3. have you physically relocated any of your other devices?

  4. have you changed anything on your Wi-Fi network, such as getting a new router, adding additional access points, changing the Wi-Fi channel, etc.

  5. While we’re at it, it may be that your smartthings hub is operating on a different Zigbee channel then your wink hub did. We’ll put a pin in that that for now, because it would require some investigation, but it is another possibility for why things are different. :sunglasses:

To answer your questions, no I had both my Wink hub and my new ST hub both in different locations because I was in the process of switching everything over last night and thought it would be a good idea to physically separate them. I did unplug the Wink hub after I finished removing all of my devices. My plan is to move the ST hub to the same place as I had the Wink hub. I’ll do that tonight.

All of my devices are now on my ST hub and all are working. Nothing has been phsyically relocated other than the actual hub as I mentioned already. Nothing has changed on my WiFi network or router.

1 Like

Should I be using Smart Lighting or should I just use my own automation? Is one preferred over the other?

If the devices themselves are eligible to run locally, then smart lighting automations can run locally, which the other automations cannot at this time.

It’s hard to say how much difference that actually makes in practice, a lot of people say they don’t see any difference, but it does mean that if the smartthings cloud becomes unavailable your local automations can still run.

Okay, so I’ll probably just keep everything as is for now. Any idea what could have caused that one light to stay on? I ran home at lunch and moved the ST hub into the spot that my old Wink hub sat for the last three years, so I’ll have to see if the error happens again.

Everything else is otherwise identical to the way I had it set up on the Win hub.

As @Rboy said, The most likely thing is that the message to turn off didn’t reach that particular bulb.

Mesh Strength

There are several reasons that might happen. One is just that there wasn’t a good path to that particular bulb, which is why the physical location of the hub makes a difference.

I’ve previously told the story of the final exam I had in one network engineering course where we were given pictures of a home where everything worked perfectly when first set up before the family moved in. But once the family moved in, a lot of things stopped working, and we were supposed to circle everything on the pictures that might be a problem.

Some were obvious, like cars in the garage and the garage was empty previously. :red_car: But one that almost everybody missed had to do with a cast iron frying pan on a shelf in the kitchen. :fried_egg:

Kitchens are always problematic because there are lots of big metal objects in them. But in this case, the scenario was that when one family member did the cleanup, they would put the cast-iron pan on the left side of the shelf and when a different family member did the cleanup, they would put it on the right. And just that change in position was enough in that case to block some signal getting into the kitchen. :scream:

That’s just a hypothetical, but it made the point: if you don’t build a strong mesh to begin with, even very small things can cause messages to get lost.

Anyway, that’s one possibility.

WiFi Interference

Another common issue is that Wi-Fi will drown out Zigbee. They are in the same frequency band and Wi-Fi is a much stronger signal.

Both Zigbee and Wi-Fi offer multiple “channels“ and you can often avoid interference by shifting the channels so that you don’t have two overlapping. So it’s entirely possible that your wink hub was on a Zigbee channel that didn’t get drowned out by your Wi-Fi, but your smartthings hub just happens to be on a different channel where there is more interference.

See the community FAQ:

FAQ: What WiFi Channel is least likely to interfere with SmartThings?

And since you’ve had your Wink system for a while, you probably already know all of the following, but just in case you are interested in more details on repeaters. Start with post 11 in that thread, read it, then go up to the top of the thread and read the whole thing.

2 Likes

Thanks for the tips. I’m hoping that the fact that I moved my ST hub into the position of the old Wink hub will help make everything work properly again.

1 Like

If it doesn’t, then we can look at the Zigbee channel.

I didn’t see you mention it… are you still able to use the app to turn the family room lamp on and off?

1 Like

Hi Tony,

Yes, the app will turn the Family Room Lamp on and off.

Okay, so it happened again. Same scenario as last time. My automation turned both lights (Foyer and Family room Lamps) on as scheduled. But at midnight, my automation turned off the Foyer Lamp and again failed to turn off the Family Room Lamp.

The only difference in my set up this time was that I moved the ST hub to the same spot that my old Wink Hub occupied for the last few years to see if the hub location is a factor or not. Here’s the interesting part—the hub is in the Family Room, which is obviously the same location as the Family Lamp that fails to turn off at midnight using the automation.

I think what I’ll try tonight is swapping the Cree bulbs between the Family Room and Foyer Lamps to see if the problem follows the bulb. I suspect it will. But I have no idea why this is happening.

1 Like

If you open the device in the app, what does the activity show for midnight?

No activity at midnight. I went into the app at 12:07am and turned off the light manually, so that’s what appears in the history.

I would suspect something went wrong when the automation was created.
You can try to go in and edit (the pencil by the name), click next, then done, and it will save it again. (You might also try changing the time to something like 5 minutes from now and see if it continues to have problems.)

1 Like