My CT30 Thermostat


(Carl Aydelotte) #1

I installed my new CT30 thermostat yesterday. I had a few little glitches and thought that maybe my experience will benefit someone else so here I am.

Read the instructions. Dont be the macho “Oh I know what I am doing” guy because there can be a few tricks. When I took the unit out of the box the first thing I did was install the batteries to power it up. Dont. Since the touch screen becomes active its easy to press and activate features by mistake. I know, I somehow paired the unit accidentally to my hub and had issues right off the bat because I was not ready for that, or trying to do it.

Mounting the unit was easy. I have the required “C” power line and hooking everything up went well. I even used a small level to make sure it didnt look slanted on the wall.

Once mounted its easy to insert the batteries. But since it was already paired I had nothing but trouble trying to get it to work. The solution was to unpair it and start from scratch. I had to use the Exclude feature from the web site development tools (I assume we all know what that is) but it was a little tricky in that once you activate it you have about ten seconds to unpair your device. Clicking Exclude and then running across the house from my desktop to the thermostat was probably not the smartest move, considering that I have a wireles laptop but I didnt think about that until later…

After it was successfully unpaired I tried to join it again and it jumped right on the first time. The new icon appeared in my android app fine as well. Dont be impatient, give the new tile a few moments to sync. It was soon displaying the current temp and everything. No problems with anything since then, I can turn the fan on and off, set the mode to Cool, Heat or even turn it Off. So far, I am pleased.


(Chrisb) #2
Dont be impatient, give the new tile a few moments to sync. It was soon displaying the current temp and everything. No problems with anything since then,

I think that’s very important advice! I believe when I first paired my Honeywell it looked really weird. Some big number stream on the tile instead of temp. I assumed it was paired wrong and immediately started trying to pick it a part to figure out what was going on. Then a few minutes later looked back at it and everything was fine. Just takes a bit to sync everything up.


(Jennifer S) #3

My CT30 was installed by Comcast as part of their home security + automation system. I cancelled the service during the trial period, and the tech came back to get the touchscreen controller (= a Comcast-branded Android tablet) and he left all the other hardware. I used the IDE to exclude the CT30 thermostat – thanks to your writeup @carlaydelotte – and then tried to add it to my Smartthings hub. That’s where I’m having problems.

The Android app detects the new device right away (Other devices" lights up green) and then I waited and waited for “Join in process…” to complete. It never completes - I waited a few seconds, a few minutes, even an hour. It never completes. If I interrupt it and click the back button, I have an “Unknown” tile in the app. I can remove that tile and re-add it a dozen times if I want, following the steps above. I just can’t get it to recognize this CT30 Thing.

What am I missing?

Jen


(Chrisb) #4

@doublehelix,

I’d try these steps:

Exclude from the network:

  • You know the first step, hit exclude in the IDE.
  • The second step: There is usually a procedure you have to run on the device itself to exclude. It might be as simple as pushing a button or it might be more complex. Check the device manual. If you already know how to do this, ignore me here of course!! Don’t want to insult your intelligence but wanted to cover all the bases.

Run the procedure to add the device again. Once you see the part light up green, it has been added. You don’t have to wait beyond that. Just hit back now.

If it’s still showing up as an unknown device, you can try a couple of things:

  1. Wait. It may be that it just takes a bit for SmartThings to figure out what this device is.
  2. Change the device type in the IDE.
    My Devices -> Click on device in question -> Edit button (at bottom of screen) -> Type: Select Zwave Thermostat -> Update button (at bottom of screen).

See if that helps.


(Matt Hubbard) #5

I hate to wake up an old thread, but I could really use some guidance.
I’m setting up Smart Things in a new house we purchased and it has a CT30 put in by Comcast.

I tried to link it all weekend, with mixed results - I was able to connect it as a Unknown device.
Hit exclude,
Menu > Mate: it shows the right zwave radio, and starts blinking.
some 5-10 minutes later It will say Link under the radio. (BTW there is no documentation to tell me if this is right or not. I’ve read both the install and Operations manual an nothing even mentions Link)

I was able to add an unknown Thing (It told me it wasn’t a thermostat though).Changing the settings to thermostat in the IDE didn’t help, I’m still getting blank numbers.

Can any one give me some advice? How can I help these things see each other?


(Chris Sanner) #6

ever get any luck with this? I did this today and I have no idea what I’m doing - even the “you know the first step - just hit exclude in the IDE” - er…no, I don’t have a clue what they’re talking about…


(Matt Hubbard) #7

Chris, I feel your frustration. Let’s see if I can help with a few things that I have learned.

  1. IDE - is your web management tool. It’s where the real power in in managing your Smart hub / hubs (because they don’t have that kind of power available in the app)
    You can find it her: https://graph.api.smartthings.com/
    you will have create a separate name / password but now you have a full dashboard.
    Why they don’t start you off with this access makes no sense to me.

  2. Exclude: You set your hub to “disconnect” from certain items. You set the hub to exclude, then you set the device to exclude, and they separate. It’s located in the Developer section, although right now I can’t find it.

Best place to start is the documentation. http://docs.smartthings.com/en/latest/
Fight through the frustration, and you have a seriously powerful tool to automate your home. But this is not (yet) a plug and play system.

For example: I could never get my CT30 to connect. It would recognize as an unknown device, and it never showed temp, or change or anything. I ended up replacing it with a CT100.

Best of luck


(Chris Sanner) #8

Thanks for the response!
I’m mostly frustrated right now with the (apparent) lack of engagement from the community - I had been under the impression that there were lots of people working on all sorts of things to make all sorts of hardware work.

after some back-and-forth with support it appears that my problem is that I ended up with a zigbee SNAP module instead of a z-wave SNAP module - this perplexes me as a problem as I thought zigbee was better supported.

I’ve got access to the IDE but I can’t find half of the things people refer to…so I’m guessing it’s been updated - but I have no idea whether functionality was removed or renamed or what.


(Chris Sanner) #9

I guess what I’m saying is I’m okay with non-“plug-and-play” as long as I’ve got a good set of instructions on what I can do to make things work but I’m currently not seeing that and I don’t know where to start.

(btw - just read through the documentation - looks useful but I’d love an example to start from?)


(Carl Aydelotte) #10

I just had an issue with my hub and the rest of the home network. Long story short, I had to re-pair everything. Once I figured out what was wrong everything jumped back on fine except for my CT-30 thermostat.

I got on the internet and looked everything up… I found this interesting article…

I didn’t go as far as unhooking the power and all that but I did pop the top cover and found the reset button. I reset the thermostat and let it reboot. Once it came up I managed to exclude and add my thermostat without any issue. Just thought that someone else may be able to benefit from this little trick.


(Matt Hubbard) #11

Thanks for the info. I tried the reset, the exclude, and it never came around. Part of my problem is the lack of a “C” wire. I’m all battery all the time.

Anyway I upgraded to a c100, and now we are working perfectly.


(Matt Hubbard) #12

Best example I can give is start simple. And try not to get frustrated. They make it sound like you can build a Jetsons house, but they aren’t there yet.

First I set a garage door sensor. Easy.
Then, Multi Seonsors on the 3 other doors-- Less easy, but still done in an hour.
— Make sure you do them 1 at a time.
— Make sure your labels are clear, Front Door / Back Door, not sensor 1 sensor 2. etc
---- Make sure the alerts are setup right. "For example I get a text if a door opens when I’m not home."
Then, I started working on the thermostats. This is a mountain house with radiant floor heating, and no AC (not really needed at 9160 Ft.) But we have 6 thermostats so each room can be controlled. That took a lot more work, but I had the system down before really got into it.
BTW I’m not a developer - I run a software company, so I’m tech savvy, but I don’t know how to code anything.

Maybe next I’ll go with locks… something I can control the codes on remotely.

YES SmartThings could really use some UI/UX help. The app is pretty, but the interface is clunky at best. Oh and there are plenty or articles that refer only to IOS and not android.

If they want to get to the larger non techie market, they are going to have to really do some clean up.


(Andrew Sugg) #13

For those attempting to use the CT-30 thermostat supplied from Comcast, that version of the thermostat is ZigBee only. From what I have been reading, you need the Z-wave module instead of the ZigBee module.
Amazon.com


(Luis B Gonzalez) #14

Thanks @wvaj for the plain explanation with Amazon link. My brother gave me a Radio Thermostat CT-30 from their Xfinity Home collection and replace the ZigBee module with the ZWave Module and worked perfectly. Some issues I faced at first when I got this module were that I only had success joining the thermostat to the ZWave network with an Aeon Minimote. I’m not saying that it’s the only way I just wasn’t able to pair it with the ST Hub. Once I joined the thermostat to the ZWave network it automatically showed up on the ST Things Panel as a Zwave Thermostat. I renamed it, and a key step is to wait. It doesn’t show the temperature right away and control features. I had to wait a couple of minutes then all was fine. Hope this helps anyone else.


(Amanda Kempf) #15

Hi there! I’m a total newbie and am having trouble getting my CT30 recognized as anything other than “unknown”. I’ve read as many posts on this forum as I can find about this and here are the things I’ve tried:

Go to the web API, click "Z-Wave Exclude"
Run to the CT30, click “Menu” and then click the “Mate” button until it flashes
Verify no Mate/Link showing on the CT30
Use my cellphone, choose “Add Thing”, choose thermostat type and CT30
Click the “connect now” on my phone and click Menu/Mate on the CT30
Verify that “Link” is flashing on the CT30, phone stays on "Identifying…"
Phone continues to stay on “Identifying”, app says “Unknown” device

I’m not exactly sure what else to try… I will unmount the thermostat and make sure that it’s a Z-Wave module and not a Zigbee that’s installed, because apparently there were different models/types and that could be the problem?? Any help at all would be wonderful!!


(Jordan Richardson) #16

Well this explains everything! I’ve been assuming this was Z-wave the entire time! What I don’t understand is why ST can’t just support both profiles.


(Andy) #17

I am currently experiencing a similar issue with my CT30. I am running on batteries only. No C-wire. The X-Wave appears to be working properly for the first hours or two but then it seems to go to sleep and never waked back up. I have to reset the CT30 or toggle it to OFF and back ON and then it starts working for for a few hours. I wonder if this is just a limitation of the CT30 without the C-wire.

-andy


(Mathieu Dubois) #18

I’m having an issue where I can’t seem to switch my CT30 to Cool from the app. It doesn’t give me an option, I just see heat or a leaf. Any help?


(Robert Hayes) #19

This article helped me. https://support.smartthings.com/hc/en-us/articles/202088864-2Gig-CT30-Programmable-Thermostat


(Chad Bailey) #20

I know I’m late to the party, but give the guide I just wrote a try