Celsius is the only option while creating an automation

All of my sensors are Displaying Fahrenheit. When I go to start an add an automation and select on the sensor, the only option I have is to input the temperature in Celsius. Why is that? I looked everywhere, at least the obvious places, like settings, to find a way to change this. I really need your help because I’m completely clueless as to why this is showing Celsius. Your help is greatly appreciated

Hey there! @jsf1970 sorry to hear that you are having trouble changing the Temperature Scale for your Location.

Can you please confirm that you have checked your location in the IDE tool (ide.smartthings.com) and verified that the Temperature Scale for your Location is set to ‘F’ for Fahrenheit as shown on the screen capture below?

The pathway once logged into the IDE is Locations>Location Name>Select Edit>Temperature Scale option will then be exposed for editing, If set to ‘C’ change to ‘F’.


I hope this message finds you well!


1 Like

Yes the location is set to F. All my sensors show F. It’s only when you go to do an automation it shows C. All of my old F automations now show C and show an error because 73 which was 73F is higher than 50C. I deleted all my automations. Uninstalled the app and reinstalled it both on the iPhone and iPad. I restarted the hub. Still I go to start an automation and the dam temp is in C.

Jorge Ferreira

Seen this bug before, it’s a bug with the platform + device handler combo. Delete your affected device and pair it again it should resolve the issue.

1 Like

Are you saying to go into my device tab, find the hub, delete it, then add it again? What happens to everything I have set up???

Jorge Ferreira

Yup, find the device in the mobile app and delete it. And, yes you will have to rebuild any routine, scene, and smartapp the device is a part of. I’ve just learned to to live with it until I can get around to doing this. Luckily it’s only happening to just two devices that are using a custom device handler.

Are you using any customer device handlers? What sensors are you using?

I have aeon, Samsung and centralite ( not sure the spelling

Jorge Ferreira

No worries! Are you using any custom DTH’s with those? Last night after I posted I removed and readded my Centralite Pearl thermostats, and they went back to Fahrenheit. It was super annoying to have to rebuild, but I’m glad I did.

John what is dth?

Jorge Ferreira

As a point of clarification, the F/C option in the IDE is essentially meaningless at this point. The temperature scale F or C is determined by your Samsung account region and there isn’t a way to change the scale at this time.

As RBoy mentioned, it is a bug but it can occur even without custom device type handlers. I am guessing Jorge isn’t using any.

Yup, I was replying and got side tracked. Thanks for the reply @Brad_ST

1 Like

Thanks to both of you for shedding light to this. So it can happen randomly. There is not a specific thing that I’m doing to trigger this? But resetting the whole hub tends to solve the issue? I’m traveling right now but I will try this on the weekend.

Jorge Ferreira



No! Don’t do that at all. Resetting your hub does not help, and all that does is cause you to rebuild everything. If you do anything, just remove and rejoin the device.

Safe travels home, but please don’t reset your hub.

1 Like

John, just making sure I’m following your instructions.
Am I supposed to see this message when I go to delete the hub?

Don’t proceed. You definitely do not need to delete the hub.

Do NOT delete the hub!

John, I apologize, I truly don’t understand then how to remove the hub and then reinstall it. Could you guide me step-by-step?

Jorge Ferreira

You do not want to remove the hub. You want to remove and rejoin the device causing you the C/F issue. Again, you want to remove a device (which is one of your sensors), not a hub. Do not delete the hub.

Hi John, thx for the clarification. I will try this when i get home tomorrow. Good thing I checked. I will report back with my findings.

I had this problem setting up an automation with a Nest thermostat when setting a Cooling action. The default is supposed to be set by your region but seems to get horked up sometimes. My Cooling UOM switched from F to C with no warning. I was given this suggestion to correct it and it worked.

“Try switching to “Cool” mode briefly (with a high enough setpoint that the Thermostat will not actually run). That should trigger a report of the temperature scale for that mode, which should correct what you’re seeing within Routines and Scenes.”