Multipurpose sensor not updating

What is everyone experience with the multi purpose sensor? Mine would update the status and temperature and then just stop. And I have to pull the battery out and and reinsert it and the sensor would start updating and then stop again. My arrival sensors work fine.

Mine only did what you described when I had zigbee (osram) bulbs connected directly to smartthings. After removal it stopped happening and has been solid. This was due to routing bugs in the zigbee stack used by the devices.
If you’re getting this without the bulbs you either have signal quality issues or other devices not repeating properly in the zigbee mesh.

A couple days ago I installed a couple zigbee bulbs (wemo) connected directly to smartthings and now my multi sensor occasionally won’t update and set off the siren. Right now I have to go to the app and manually refresh to get it updated.

Is there any way to resolve this? or zigbee light bulbs simply a no go?

Please see this thread if you haven’t already

My advice is to log a ticket. The more people who do this the more engineering effort is put into resolving such issues.

Until this is resolved my only work around right now is to put all zigbee bulbs into the hue bridge which is not ideal as philips seem to be trying to break them with every firmware update.

Thanks. I opened a ticket hopefully it’d be resolved.

The situation is getting worse today. Updating from the app no longer works. The multi sensor status got stuck open for hours until I got home and physically open/close the door several times.

I have a hue bridge but wemo light bulbs supposedly cannot connect to hue bridge for some reasons. I bought those wemo bulbs solely because direct integration to ST is supported. But with the current situation look like I have to discard them.

ST should either fix this or they should remove the direct integration claims of these light bulbs.

I agree, hopefully the more people complain the sooner we get a fix.

Got a reply on my ticket saying firmware updates are coming, but no ETA was provided.

My multi sensor was stuck again today, totally drove me crazy. I am going to have to replace all the bulbs with hue tomorrow until this is fixed.

I know exactly what you mean. I was getting 2 or 3 sensors getting stuck every day for months.

It doesn’t sound like a widespread issue, I wish someone could isolate what exactly in the setup is causing it.

Mine stopped sending open/ closed notifications while continuing to send battery level and temperature. Looking through the device log activity I found by accident that this was the case for past 15 days. RR battery seemed to fix but for how long. I have no ziigbee bulbs Hue or Wemo as mentioned.

I’ve had the same number of devices in play for most of the year now, I’ve been having these bizarre issues for the past month or so…
So from my POV it’s not a customer related setup issue…
It is however becoming a more common place issue.


I had this issue with a single multisensor in my basement, I just kept restarting the device every time it happened. Recently I moved my v2 hub closer to the sensor due to internal network changes, and the issue seems to have gone away… Which makes me think its a zigbee signal issue…

All of my ST multi sensor / multipurpose sensors started flaking / freezing a few weeks ago. Same issue as above. They continued to report Active / Inactive and temp for a while, but no Open / Close events:

Battery Levels range from 66% to 88%
All of mine appear to be stuck in the “closed” status (although this may simply be the state they were in when they froze)
All “Recently” history seems to now be gone for many of them.
No updates appear to be occurring now (temp, battery, etc)
Battery replacement & reset does not resolve the issue.

Of note is the fact that ST Motion Sensors, and GE Smart switches & Dimmers all seem to be unaffected - even at the same distances as the Multi Sensors.

Hi guys - I’m having the same issue here. Although its only affecting one of my two multisensors. How can I “unfreeze” it? I tried removing it from SmartThings and following these reset instructions: . However SmartThings does not find the multipurpose sensor when scanning for new devices. I tried to browse the catalog so I could more specifically point it at it, but I couldn’t find it in the catalog (?). So I follow those instructions and hold the button while I put the battery in. The light turns amber after 1 second then blue for a split second then green for about a second then goes out and nothing further happens. ST just continues to look for the device but it is never found. Any info would be greatly appreciated. Thanks! Oh, as for lighting - I have many LIFX bulbs but nothing other than that.