Mobile app says "Incorrect Username or Password" but graph.api is ok

I’ve searched the community and found some previous occurrences of a similar symptom for folks, but they resolved their issue by deleting / reinstalling the app. My experience was different.

All was well until a couple of days ago, then the iOS SmartThings app logged me out, and when I attempted to login the app responded with “Incorrect Username or Password”. I tried restarting my iPhone. I tried deleting the app from my iPhone and re-downloading it. No luck.

So I tried logging in to, and it worked just fine! Login successful. And I can see my hub, all my devices, etc.

Since I was successfully logged in to, I used that interface to change my password. That solved my problem, and I am now able to login in the iOS app. ( When logged in to graph.api, your username in the “Welcome back, [username]” in the upper right corner of your browser window is a clickable link… click it, and you will see your account info, with a “change” link next to your password box. )

Being curious, I used the graph.api interface to change my password back to the one that caused me problems, and again I could not login from the iOS app. Used the graph.api interface to change to my successful password again, and I can login from the iOS app again.

Both of the two passwords were exactly 32 characters. But the one that fails is a random one with lots of special characters in it. The one that works only uses letters and numbers and a couple of simple special characters. So, making a guess based on just this little bit of experimentation, it seems that maybe SmartThings made a change in their allowed characters for passwords? Just a guess. But hopefully this helps if other users out there experience something similar.

I’d say it depend on the special characters that you used, some time application / firewall block certain characters or combination.

Random thought, but could it be the keyboard on your phone changing a series of the special characters to a emoticon ? You enter !:o) and it inserts :open_mouth:

I did a little more investigation, and found that the ‘&’ character is currently NOT accepted by the iOS app. If I use the graph.api interface to change my password to something containing an ampersand, then I can no longer login using the iOS app.
mytestpass1! <-- works ok
mytestp&ss1! <-- fails in app with “Incorrect Username or Password” message