Minimote with new app?

I have been looking to start using the new ap now that most of my 100+ things seem to be supported.
The one confusing issue is the Aeon Minimote.
First off, I moved to the ST DTH from Keye’s custom DTH and it now shows online but it doesn’t show up as an available device when trying to add a button to a scene essentially making it useless to trigger the pistons attached to the remote buttons.
Secondly, I don’t see the proper method of selecting either pushed or held when in the app remote display. One gets a circle button saying “Standby”; doesn’t do anything when you touch the button or hold it.
I just want it to create events for the virtual button pushes/helds like it used to.
Obviously I’m missing someting here or is the implementaion incomplete?

You may need to exclude it and rejoin it. They recently updated it to a multi component device, so the UI in the new app should look like this:

1 Like

Might try that then.
My UI looks like that but touching does nothing to the programmed devices and the logs in WebCore show no events :frowning:

I don’t think the button tile is actionable. it only briefly updates the status of the appropriate button # with pushed or held when the physical device is used. If that’s what you meant?

Yeah if you’re used to Kyse’s DTH-enabled actionable app buttons you do not get that with the stock handler.

I’m in the process myself of moving from my own version of Kyse’s DTH to the stock so it’s of some use in the new app.

Got it, info only. That probably explains why you can’t use it in a scene.
Too bad as you can have a widget of scenes on your cell phone and the remote would have been ideal to integrate to scene buttons.

1 Like

i’m not sure what you mean? In my pic above, you can assign a scene to a button for pressed or held. Then you can assign the same scene to the widget.

Yes you can assign actions to the buttons but I would like the button event (a la Keyes) so WebCore can run the pistons attached to that remotes button. I can’t recreate the complexity of the piston with the ST scene script - set globals and interact with the other pistons.
Porbably not explaining it that well

Still not sure what you mean there. My remote using the standard handler shows fine in webCoRE

Yeah sorry for confusing you, I know the WebCore mapping works.
My goal was to be able to use the minimote pistons in Scenes which isn’t directly possible from the way the ST DTH and UI work. It would be gerat if the scene creation script asked you which button you would like to press/hold on a remote as part of it’s device inventory.
What I have to do is create a virtual button device with it’s event linked to the piston and use that as the actionable item in the Scene I create. Maybe there is a more elegant way?
I just want to replicate remote button pushes to WebCore on a tablet without doing a crazy amount of work-arounds. I have 3 remotes all with different functionality.
This is the one I want to re-map to Scene buttons for the TV/Rec room.

Good catch. I just did that to one of mine and it looks like yours now. For my other minimotes I changed the dth to something else, and then back, and than seemed to also do the trick.

The issue I’m now having is the Android app crashes every time I go to assign a button a pressed or held action by tapping on “+” . No matter what I do, the app crashes every single time.

EDIT. I can only assign a pressed/held action for the “Main” button, not any of the 4.

Just changing the DTH back and forth caused issues for me. It left the 4 single buttons as Separate devices that couldn’t be deleted. Only a full exclude and include worked for me.

It did that for me too on the ones I just switched DTH, but going to properties and selecting edit and then taping back in the mobile app added the actions for pushed and held. Regardless if it was a newly added minimote or one I manipulated the DTH, I still can’t assign anything without the app crashing on my phone, wife’s phone, or my tablet.

boo! :-1: Working fine for me on iOS.

1 Like

Hey @prjct92eh2, just noticed on my daughter’s iphone that she doesn’t have a button titled “Main”, but on all my Android devices the button “Main” is there; AND I can add button press actions on her iphone AND they will show up on the Android devices.

Interesting. Sounds like an Android app bug.

1 Like

I opened a ticket with ST and we’re communicating already.

Another interesting difference between the two is that on Android I get the option to “turn on or off” vs just on or just off. I don’t see this option on my daughter’s iPhone, do you?

EDIT: I can change the actions on Android once I create them via iOS. So weird…

The button automation creator is strange. The default is switch power state, but there is no way to manually choose that if you tap the device and choose to go with on or off.

1 Like

Yeah. I decided to hold off converting my Minimotes to stock handlers for now. Yet another mess.

2 Likes

I’m going to try a different tack. My goal was to have a tablet interface instead of a hard remote on the table. As a staunch user of Actiontiles @tgauchat I am inquiring as to the possibility of creating ActionTiles tiles for this purpose instead of using ST.
AT doesn’t seem to support remote buttons as a tile but maybe this can be implemented in the future and solve my UI dilemma.