Minimote setup


#1

Hello. So I am fairly new to ST and just purchased two Minimotes. The original version. I tried to just connect them as a thing but they are just not acting right. What do I need to do to get them connected and working?


(Richy) #2

Read this link.


(Jason Cannon) #3

Use the following for your device type. Solved 100% of my problems.


#4

Jason, As i said before, I am pretty new. So I just need to add the device handler and then add a thing in the app? then it should work? or am i really off?


#5

Hi @jasondcannon,

I used the same one and it worked great for me. I made a copy of @Kyse’s DH, and changed it for look and feel on how I wanted it: (functionality is exactly the same)

Hi @bdavison2011, welcome!

You’re not off at all. I would recommend first creating the DH and then add the minimote(s) via the app. I did that for all 6 of mine. I found pairing them close to the hub helps.

I ran into a few that would just not pair correctly. If (when) that happens to you, just exclude the device and reinclude it back to the hub. Also, be sure to tap on the Configure tile. You know the device was included properly if you go and look at it in the IDE. Reference the image below. When you see “numButtons” equal to 4 and all push/hold numbers listed, you’re ready to give names to each button. Remember, you’ll still need a SmartApp to link the Minimote buttons to your actual devices. That SmartApp is called Button Controller, and it can be found in the Marketplace within the More section. There are also Community developed one you can try.

Good luck with yours. You should have no problem getting these to work, but if you need help or have more questions, just post back here.


#6

So I got them both added. Now I can’t seem to figure out how to tell it what to do per button. I click configure and it does nothing. The recommended smart app thinks there is only one button.


#7

That’s the problem I ran into:

I won’t do anything in the app, it does work in the background.

Tap on the gear in the upper right corner and give each of your buttons a name. First you need to exclude and reinclude the minimote and get it to join correctly. I literally was a foot away from the hub when I was joining mine, and I had to do it a few times with a couple of them.


#8

I have added and removed them like 20 times and still keep getting the same button 1. Grrrrr!!


#9

In that view you will just see the text Button 1 because of how the DH is written. Re-reviewing your post for earlier this afternoon (~5 hours ago), it does look like you have all 4 buttons. Can you please go to the IDE and look at that device and see if the parameter “numButtons” says 4? If it does, you’re good and the SmartApp should work for you and take you through all 4 buttons to configure.


(Don) #10

Hey @johnconstantelo would you be willing to share what you changed in the DTH to clean up the display. Looking at the code I am assuming you changed this Icon from the remote to the smartthings logo:

state(“default”, label: “Button ${btn}”, defaultState: true, backgroundColor: “#ffffff”, icon: “st.unknown.zwave.remote-controller”, decoration: “flat”, canChangeIcon: true, canChangeBackground: true)

Would using the logo “st-sprite logo-smartthings” work?

And for the actual buttons green and blue you just changed the background color to match the rest? #ffffff

I was going to just attempt it but was hoping you provide how you direct addressed the smartthings icons in the first field.

Thanks


#11

Sure can @TN_Oldman. I didn’t want to provide the link right away so as not to confuse the person I was trying to help. Here it is:

https://raw.githubusercontent.com/constjs/jcdevhandlers/master/devicetypes/jscgs350/my-aeon-minimote.src/my-aeon-minimote.groovy


(Don) #12

Thank you very much. Installed and looking MUCH better!!!

I also now have a reference to see how you edited it.


(Barton.) #13

I like that look better. Do you mind sharing what you changed in the code?


#14

Sure! The original DH did something cool with creating a list that created the tiles, but I needed to break that apart because I wanted more flexibility to change/tweak tiles. I also added decoration: “flat” because the round look cut off the device description.


(Don) #15

Thanks for the reply.