MimoLite - Change Parameters


#1

Hello All,

I am fairly new to Smartthings, and really new to any custom projects and haven’t done any coding in many years. I have a MimoLite device that I want to use to open an existing gate lock on an intercom system. I have the MimoLite installed and working, however the momentary relay time to too short to unlock the gate. After doing research, I know that I need to change Parameter 11 on the MimoLite, however I have no idea how to do that. Every reference I can find is for much more complex projects, all I want to do is change the one parameter. Any advice would be appreciated. If anyone was willing to post step by step instructions, or the code for a generic MimoLite device type (I think this is what is needed?) would be incredibly helpful. Thank you.


(DavidK) #2

Hello, I have an idea. If someone else knows more please jump in. I have used the mimolite for input, but never output.

But I have used other relays as a momentary contact and the momentary part is controlled by the hub.

The hub sends the on and off commands to the relay to simulate a momentary contact.

It looks like from the mimolite manual that either the mimolite relay is controlled by zwave and in that case internal setting do not matter;

Or it is controlled by the digital input; when controlled by the digital input the mimolite parameters are used but zwave commands are ignored.

Can you hear the mimolite relay turning on and off when the zwave command is sent?

Again I have not used the relay on the mimolite, but my other relays make an audible click when turned on/off for momentary contact switches.

I can try tonight if/when I am home to see/hear if the mimolite makes an audible click. But I am assuming it does.


(DavidK) #3

I just checked, toggling the mimolite relay makes an audible click and the delay between on and off is like 2 seconds


#4

Thanks for the help. According to the MimoLite User Manual, the default setting for the momentary option is 500ms. I would like to change theirs to somewhere between 2 and 5 seconds. This can be done by changing parameter 11 on the MimoLite, however I cannot figure out how to do that.


(DavidK) #5

@Thadniak
Wait, how do you want to trigger the relay?

  1. through zwave
  2. digital input?

I have the mimolite manual, the built in default may not matter depending on how you are triggering the relay.


#6

I would like to trigger the MimoLite using ZWave.


(DavidK) #7

Below I found the code to set the parameter 11 as you requested.

Also, I think that if you leave in the P5 jumper this parameter may not be needed.

Did you remove the P5 jumper yourself? Or is the P5 jumper not installed by default?

I did NOT remove my P5 jumper and I think smarttthings is sending the on and off command to simulate momentary switch.

But in the source code there is some comments about sending down the delay to the mimolite which is what you asked for. Changing Parameter 11
** This device type implements a “Configure” action tile which will set the momentary switch timeout to 25ms
** and turn on the powerout alarm.

Here is the code, the 25 in brackets is the 25 milliseconds I think
def configure() {
log.debug “Configuring…” //setting up to monitor power alarm and actuator duration
delayBetween([
zwave.associationV1.associationSet(groupingIdentifier:3, nodeId:[zwaveHubNodeId]).format(),
zwave.configurationV1.configurationSet(configurationValue: [25], parameterNumber: 11, size: 1).format(),
zwave.configurationV1.configurationGet(parameterNumber: 11).format()
])
}

You are going to want to install this device handler:

And change the timeout value from 25ms to whatever you need.

In the documentation it states that the momentary delay in the mimolite is only used if the P5 jumper is removed.

But I do not know.