MIMOlite Momentary Delay


(Britt Selvitelle) #1

I’m trying to use a MIMOLite gate control. I got the momentary setting to work by removing the jumper, but I haven’t figured out how to set it to more than 100ms. Any tips or pointers towards code?

It looks like the zwave parameter 11 sets it in increments of 100ms. Do I need to send this each time I send the on signal, or just once during the configuration? If during the config, how long does that setting last? Is that written to the board until the power cycles?

Using the built-in momentary seems like it would be more reliable than sending on and off via 2 separate network requests in a custom app. I’ll resort to that if I have to, but I’d like to be able to figure this out!


(Mike Maxwell) #2

You just set it the one time, those settings survive power cycles.


#3

@brittspace, like Mike_Maxwell said, once configured it stays until you fully reset the mimolite. Here are all the configurable setting I’ve found so far:

http://fortrezz.com/index.php/component/jdownloads/finish/4/16?Itemid=0

zwave.configurationV1.configurationSet(parameterNumber: 2, size: 1, configurationValue: [1]).format(), // clear pulse meter counts
zwave.configurationV1.configurationSet(parameterNumber: 3, size: 1, configurationValue: [1]).format(), // sig 1 triggers relay
zwave.configurationV1.configurationSet(parameterNumber: 4, size: 1, configurationValue: [100]).format(), // lower threshold, high
zwave.configurationV1.configurationSet(parameterNumber: 5, size: 1, configurationValue: [39]).format(), // lower threshold, low
zwave.configurationV1.configurationSet(parameterNumber: 6, size: 1, configurationValue: [232]).format(), // upper threshold, high
zwave.configurationV1.configurationSet(parameterNumber: 7, size: 1, configurationValue: [231]).format(), // upper threshold, low
zwave.configurationV1.configurationSet(parameterNumber: 8, size: 1, configurationValue: [1]).format(), // set to analog, below bounds
zwave.configurationV1.configurationSet(parameterNumber: 9, size: 1, configurationValue: [255]).format(), // disable periodic reports
zwave.configurationV1.configurationSet(parameterNumber: 11, size: 1, configurationValue: [0]).format(), // momentary relay
zwave.associationV1.associationSet(groupingIdentifier:1, nodeId:zwaveHubNodeId).format(), //subscribe to basic sets on sig1
zwave.associationV1.associationSet(groupingIdentifier:2, nodeId:zwaveHubNodeId).format(), //subscribe to basic multisensorreports
zwave.associationV1.associationSet(groupingIdentifier:3, nodeId:zwaveHubNodeId).format(), //subscribe to power alarm
zwave.associationV1.associationRemove(groupingIdentifier:4, nodeId:zwaveHubNodeId).format(), //unsubscribe from binary sensor reports
zwave.associationV1.associationRemove(groupingIdentifier:5, nodeId:zwaveHubNodeId).format() //unsubscribe from pulse meter events


(Britt Selvitelle) #4

Hrm, in my attempts last night I could not get it to trigger for more than the default 100ms.

My understanding then is that sending:
zwave.configurationV1.configurationSet(parameterNumber: 11, size: 1, configurationValue: [255]).format()
would open the gate for 25.5 seconds?

If I want this to be the default for a custom device type, would I send this in the init function?

Also, @johnconstantelo, are those the default settings? I feel like I stomped on some in playing around and need to reset things. Do I just have to pass them back over or are the defaults stored in the firmware, and I can trigger a reset?


(Ben Hicks) #5

Did you ever happen to find a resolution to this issue? I’m dealing with the exact same problem at the moment and it is driving me absolutely insane.


(Snarshad) #6

Also wanting exactly this functionality. Britt! Any luck?


(Snarshad) #7

I got it working - I didn’t have brackets around the number. I think you could have it call that just once during configuration; it remembers the setting.

However, I’m not that well versed with the rest of smartthings, even thought I got this device type working in the IDE and used the simulator to send the command to the MimoLite, I did not see the new device type I created when I tried to add the mimo again, I only saw “Z-Wave Switch.” However, it honored the setting I had set earlier (70), and now I have it connected to my gate switch, and it opens it for 7 seconds. WIth Do Button from IFTTT, I now am able to do it easily from my phone or watch.


(Jeff H) #9

In IDE click on the Mimolite. Next to Preferences click edit, there is only one preference to edit, that is RelaySwitchDelay. Enter from 0 to 3.0