Meross native Integration

I simply linked my ST account through the official integration within the new app. If it doesn’t work the first time, try going through the process again.

I’ve done it like five times. From home screen I tap + then “device” then by brand, then Meross, tap outlet, then link to Meross account, enter ID and pw, then authorize, then next. Get a message “End of Configuration”, tap done. See ST logo and Meross logo. When I tap dropdown for Install your Device Profiles, it just shows “All device profiles”. I can’t change anything there so I tap “Allow”. Goes back to Meross device screen. Go to home screen. No Meross outlets showing. Not in IDE either (though it did show up there the first time, but not since). I’ve now replicated this last scenario by deleting the smartapp and running through the authorization process. Shows up in IDE but not app. Hub was not showing so edited in IDE, but no change. Device type shows as “placeholder” which I changed to “Outlet Capability” but no change.

Update: I can see the outlet in the classic app but not the new one. I also see the meross smartapp in the classic but not new. Any thoughts?

Running into the same situation here with their garage door device. I had it in the new app once, but while playing around in Webcore, accidentally deleted the Placeholder and now can’t get it to appear in the new ST app at all and never had it show up in Classic.

Same steps at Martin above and same sort of results minus seeing it in the Classic app.

I replied to your other post.

1 Like

Does anyone use Meross light switch here?
Does the native integration work well on Smartthings? I’m currently using newer version Smartthings

On Meross website it does say that it supports Smartthings, but when directed to Amazon it does not indicate that on the description.

Otherwise, would TP-Link Kasa be a better choice?
I have a couple 3 way location and Meross only require 1 end to be used, while Kasa requires both end…

Any other recommendation?

Thanks,

I had to add it (smart garage control) a few times to get it to work after it stopped updating (both real-time and historically) in the Smart Things app.

Running it in the Classic App was iffy at best, but the New App was typically good. A few days ago it stopped logging the open/close status so I decided to re-add it. I ran into the same issues as you. I had to add it a few times to get it to ‘stick’ in the New App.

** update ** I removed and added it back yet again. It now appears to be updating the status in the app and i can see the change in the IDE logging as well. We’ll see how long that lasts…

1 Like

Anyone have any updates on this?

I have re-run through the add device until I was blue in the face, it’s a no go.
Same issue on my wife’s phone.
The SmartApp is listed in the Classic ST app, however I can’t remove it or run it, it simple says “Something has gone wrong!” and presents a Retry button.

Support has been very slow to respond. Their initial response was to run thru the re-register process like we’ve been doing, I responded that I already have a dozen times and I’m still waiting for them to respond. I’m about ready to just switch to using the MyQ. Granted I’ll have to buy a second sensor for my second door and two additional tile sensors because MyQ’s sensor is proprietary and doesn’t allow you to see it in Webcore. At least they have support.

You need to try (add/remove) it in the New App. Trying to do anything with it in the Classic App (aside from assigning it an icon/tile in the Classic App via the IDE) is pointless.

Remove it via the IDE and then start over if you get stuck. Also, remove the service as well (in the New App).

This all started on Friday, my buttons In the new ST app stopped working. I re-authorized Meross and it started working again.

I initially forgot they were setup in the new app and that’s when I discovered the SmartApp listed in the Classic App. There is no way to remove it from the Classic App as it
goes right to the message “Something has gone wrong!” when you click on it. There is no option to uninstall.

Yesterday the buttons in the new app stopped working again so I tried, and tried, and tried to re-authorize Meross but it just will not work. My devices don’t show up, it only
asks for permission to “Install your device profiles” which doesn’t match the FAQ Meross sent me.
https://www.meross.com/faq/201.html

It’s missing “See your locations”, although it does ask me were to put my devices (location/room), and it doesn’t show the “Control your devices” permission.

Then it just loops and loops, and loops.

I have a ticket open with both Samsung, they had me reboot my hub which I have done several times.

I have a ticket open with Meross, they are slow as all get out and have only sent me the FAQ so far.

As for IDE, nothing referencing Meross is listed.

Thanks for the response,

Dave

I’ve NEVER received that confirmation for the permissions shown in the Meross FAQ link, if that helps. You need to make sure that you delete the service under settings in the New App and then start over.

1 Like

My hero! I was looking for something like that, didn’t know they had a services section buried in there. The devices showed back up and it’s working again.

Yes, the FAQ does not reflect reality.

The Classic still has the SmartApp installed with the same response, still not sure how to get rid of it. Maybe it’s there just because it’s installed in the new app?

I’d dump the Classic app however I’m using Webcore and it still requires you to install it from the Classic app.

Thanks for the save. Still no response from support.

Dave

1 Like

You can do everything with webcore in the new app that you could with the Classic app as far as setup goes. If you need to add new instances of webcore, click the + and choose Smartapps and scroll to the bottom of the list. If you need to add available devices to an existing instance of webcore, choose menu and select Smartapps where you can find your installed instances of webcore.

Thanks for the info. I’ll get to it another day. I just got every back up and running so I don’t want to spend another day down trying to fix it if I break it again :grin:

Having issues myself with some Meross MSS310 outlets.

Over time the status of these will stop updating/time out and fall out of sync with SmartThings. Turning something on will action the command but the status will try to update, time out and stay off in the app, even when physically on. Pressing again to turn them off won’t control the device in ST as the status is out of sync.

Have removed and added, even reset my ST hub for another issue and the problem persists.

The only resolution I have found is to re-authenticate my Meross account in Options>Connected Services in ST – the devices in the app after a few seconds will then update with the correct status and behave normally for a while (a few hours) and then the issue reoccurs. Same issue across both apps.

The Meross app works every time and reflects the status and actions commands, so I’m certain there is no issue with the physical sockets or WiFi signal, and the firmware is up to date.

Not sure what else there is left to try here, apart from returning them and getting something else, perhaps Zigbee based that can be controlled a bit better.

All the same problems you guys are having, I’m having too, with my Meross smart switches in SmartThings. The key thing for me has also been removing my Meross account from SmartThing’s connected services, then re-adding the device in SmartThings. I’ve had to do this a few times per device in a 1 week period. It has affected both my 2-way and 3-way switches and one of my smart bulbs.

I wanted to also mention that during these episodes the devices have continued to work fine in Google Home. So, it seems to be a problem with the integration of the Meross service in SmartThings itself. All my TP-Link devices have worked near flawlessly, in comparison, FYI. Obviously, I’m considering replacing all the Meross devices for TP-Link equivalents even though some are considerably more expensive. Had I know this up front I would have saved hours of troubles.

Hope this helps, and good luck!

There is a HUGE problem with the Meross garage door’s SmartThings integrations. It does not work for more than two days in a row on SmartThings app.
I have to keep deleting the Meross service from SmartThings for the Meross app to be able provide door “open” and “closed” status.
This means recreating any automation using the door as trigger, input or output.
It is annoying (NOT sustainable = insanity) to do this every two to three days.
How long has it lasted you?
I bought the latest device on December 12 2019 and now I cannot return it.
I have been in touch with their customer support and I am not that sure if they take this SmartThings integration seriously.
Just the steps to add it are confusing and incomplete.
They don’t really have an icon in the SmartThings app to show the garage door as an option.
It is hack via one of those sockets or switch icons.
After that you have to go back to home screen and hope it is added.
Otherwise you will go in circles once you see those two switch and socket icons.

I have the same problem with their garage door module. It works for about 2 days, maybe less, and then no longer reports. In order to make it work again in either app (temporarily), I have to go into the New App and re-authenticate the service (name/password), next next next…and then it works.

I installed the garage door device this week, worked great for several days, then disappeared today. Now I cannot authorize it in the SmartThings app to save my life. I’ve logged in 20 or more times and keep getting kicked back to step one, authorize meross. The device is not present in the IDE either, so I am clueless. I can still login to the meross app and see my device.