Meross MSS620 WiFi Smart Outdoor Plug, either Smartthings nor Merros find it

I have an outside waterfall that is no matter what I do I cannot reach it with the Zwave device, so I decided to try Meross outdoor plug since it is WiFi connected and I have enough wifi reach at the waterfall.

First I tried installing it directly through Smartthings, without Meross ap via usual click on/off and smartthings did not find it.
than I downloaded Meross app, registered and tried finding it through the Meross app. Even Meross app cannot find the plug. I tried clicking on the on/off button to have just the blinking red light, I also tried turning the switch on and having green light on with the blinking red on top, still Meross app cannot find device.
What am I doing wrong?

First off, any WiFi device doesn’t work natively in SmartThings. Some devices do have integrations, such as iHome and WeMo. Next as far as finding it with the Meross app move the outlet inside closer to the WiFi and try following the companies directions.

Got it, this plug can only be installed with the Meross app. However, I moved the plug right next to my Google WiFi router (the main unit) and still same issue - device not found.

That device only works on 2.4 GHz Wi-Fi – – is your router using 5 GHz? Also, you will probably have to have your phone on that same 2.4 Wi-Fi while you are connecting the device to its own app. That can be tricky with a google router, which uses its own algorithm to decide which band to connect you to.

Thank you and dam they are not making it easy.


Sadly, I just purchased this as well for use during the holidays to have Smartthings control the lights. Just re-read the Amazon features and it said Support for Smartthings coming… Oh well, should have bought the GE that I KNOW works well. Hopefully, they get the smartthings integration working quickly. I could use IFTT, but i really dont want yet another automation app

I was emailing Meross’s support and also the technical team. they confirmed that they’ve had a meeting with Samsung in October and will be implementing a new secure connection to Smartthings come December. Now its just a case of waiting or selling the equipment and buying one that actually works with Smartthings.

I’ve moved a lot over to Home Assistant ( however as Meross confirmed they don’t have any API so even this doesn’t connect.

IFTTT is the only option just now.

1 Like

Thanks for the update @Melfice
I put mine on the shelf and went with the GE plug. if/when they add support, I have another use in the back for it

It seems there is a Meross API and some work done already in Python for these plugs, at:

If someone can port from python to groovy, we might be able to get these working in Smartthings!

These came up on Amazon sale today… just wanted to put in this little description:

  • Voice Control: You can control your devices hands free, just make a voice commands to turn on/off the connected devices. This plug-in heavy duty outlet compatible with the , Google Assistant and IFTTT. Samsung SmartThings and NEST compatibility will be supported soon.

So… at least we have soon (?)

Well, it’s been saying soon for 18 months or so. I’ve been in touch with Meross and they still have nothing to beta. At least the above code can be made to work in Smartthings if someone can port it.

It does work OK with IFTTT.

Indeed yes, but not for reporting power usage. Also the code above can also work for their bulbs (colour, dimming, on/off etc).

Unfortunately, i can’t get it to work with IFTTT either. The meross applet opens but it doesn’t see my meross wifi garage door opener. the door opener works fine from meross app, and from within google home hub but it is NOT being recognized within the applet in IFTTT. Under “device”, it says there are no devices available. any ideas?