Map not showing for trackers on Android

I have 3 cellular Smartthing trackers to track my pets as they roam the neighbourhood. Over the past few weeks, the app no longer shows the map. The locations update are being captured. I can initiate a location request as well as live tracking. I can also see the travel path. The background map however no longer shows up on the screen so although the data is being sent, I can’t actually determine the location on the map whether it’s the map or satellite view. I loaded the app on my wife’s iPhone and everything works well. It’s not working on my Galaxy S20. I’ve validated that I have the latest Smartthings app as well as all the Android updates on my phone have already been installed. I sent screenshots to Samsung through the app as well as info on the latest app version I have installed. I have yet to hear anything.

Anyone encounter this problem?

1 Like

Hey there! @nrodrig, Welcome to the Community! :slight_smile: I’m so sorry to hear that you are having troubles with the Smart Things Find Map not showing in the ST App on your Galaxy S20.

As you mentioned functionality is working on your wife’s phone, your Smart Things Find may need to be deleted, and re-setup on the Galaxy S20.

Give these steps a try to resolve the symptom:

  1. Navigate to the Life tab in the Smart Things App.
  2. Long press the Smart Things Find Service and select Delete.
  3. Select the (+) Add Service option located in the top right corner of the ST App Life tab.
  4. Select the Smart Things Find Service and follow the prompts to re-setup Smart Things Find.

This should refresh the service, and allow for the map to appear on your Smart Things application now. If any users are having issues with a service, I always recommend removing the service from the ST App and attempting to re-add the service to see if that resolves the symptom.

Are you now able to see the trackers and map in the ST app?

Just to confirm you are speaking of the Galaxy Smart Tags?: Samsung Galaxy SmartTag, 1-Pack, Black Mobile Accessories - EI-T5300BBEGUS | Samsung US

If the symptom persists, I would recommend creating a Support ticket and providing these steps that you have already attempted so we can look into your concerns further. You can reach out directly to a support team in your area using the below information:

US: 1-866-813-2404
UK support 0333 0000333

I hope this message finds you well!


I’m having the same issue
Using a Smartthings Tracker - Software Version V110WVLU1ARL3 - Controller Version 2.7.2
and 1st gen Samsung Flip

Deleted and re-added the Smart Things Find Service too

1 Like

Thank you very much for taking the time to respond. I was excited to see your recommended solution. I followed the steps to remove and re-add the Smart Things Find Service. After re-adding the service, it is still not working. Ironically, all my Samsung devices (other smartphones, watch and tablets, show up in the ‘Find’ app and the map does show up in the ‘Find’ section. My three trackers however, are not listed in ‘Find’. I even removed one of the trackers and re-added it. When I go back to my home screen and access the trackers from there, the device comes up but no background map. I had a ticket open with Samsung on Jan 3 (sent to They asked for screen shots and confirmation of the app version. I sent it to them same day but haven’t heard back yet. To confirm, the devices are not the SmartTags, but the Trackers: I’ll follow up with Samsung Support again.

Thanks for trying. If you (or anyone else) has any further thoughts, I’m open to anything. I hate the fact that I’m paying for cellular service on these trackers and can’t actually locate these trackers on the map.

Still no resolution from Samsung. I also tried the option of ‘leaving’ Smartthings where all my Smartthings data gets wiped. I then re-added the the trackers and same thing…locations are being updated but the map is not showing up.

This is happening for me too. I’ve cleared all data for the app and re-added my account to SmartThings twice now to no avail.

I doubt this issue will ever get resolved. Despite the tracker being one of a kind in what it can do - at least thus far I haven’t been able to find anything with its price point and features - it seems that Samsung and its partners have abandoned this product. No one ever knows anything about how to address issues with it. I suspect that the mapping partnership expired or whatever API Samsung used to create the map changed and no one cares/bothered to update it.

I have another Samsung S20 5G and tried it on that phone as well. I did a factory reset on that phone, added all the updates and configured the phone. I get the same result - no map. I’m thinking this must have something to do with the last Samsung phone update. It still works on my wife’s iPhone. I have never seriously thought about moving to iPhone. Seems ironic that I would have to switch to an iPhone to get the full functionality of the Samsung SmartThings app and the Samsung Trackers.

1 Like

I’m having the same problem on Android 12 on a Pixel 4a. It started with the latest update to the app. The maps were working with the prior version. When I updated versions (to fix another problem I was having) all the maps for the trackers stopped showing up.

I went through the process of fully deleting the app and erasing storage and cache, reinstalling, but that did not fix the problem.

FYI - my ticket number is 1307330. If anyone else reports the issue you might want to reference this ticket too.

@tracker @tshpub, it looks like the issue is resolved. As of today, I can see the maps. Samsung advised me a couple days ago that the Android issue was recently discovered and was being addressed by their developers. Appears they have now fixed it.

@6342141, it looks like the issue is resolved. As of today, I can see the maps. Samsung advised me a couple days ago that the Android issue was recently discovered and was being addressed by their developers. Appears they have now fixed it.

It is fixed! Thanks. Of course I haven’t heard anything regarding my ticket.

I have Samsung galaxy S20 Ultra and I have the same problem with my smart tag i try everything but the problem still remains any solution?

"Error with SmartThings Find Map
After updating to SmartThings app version, some users may no longer see the SmartThings Find map. In this case, please go to the “Life” tab (towards the bottom), and tap the Find service card to update the map.

We sincerely apologize for any inconvenience, and will strive to improve in our next update.

Thank you."

It is from the notice inside the app

This way can’t solve the solution, but it allows me to tag my smart tag.

I m just now getting smarttags and have it all set up on my sam s20 5g and everything works except the detail on the map only shows a few streets. no details very hard to determin where they are.

For me it clicks through to a Google map with the 3-D view enabled, but without any controls to change the angle, and a restricted zoom that doesn’t go in close enough to show house numbers. What other details there are on the map, such as bus stops, are not active and there are the usual unhelpful random places marked with ‘pins’. It could be a lot better.

Worse still is the map, as that has less detail and although you can zoom in much closer you still don’t actually get any more information.

I still don’t really understand why they can’t just give a latitude and longitude instead of only displaying locations visually on poor quality mapping.

Thanks for the feedback I appreciate it

Also i just called customer service for smart things app and was told the map you see is what you get. i explained on the top left of the map it sayes google so why not give us the tabs to change the terrain. she said she will pass it on to the developers.

I have the same problem using Samsung S20-FE with the original Samsung Galaxy SmartTag. Maps with the SmartTag location do not appear. It appeared until a week ago but after adding new SmartTags to my ‘Smart Things’ App no map is available. I will appreciate any advice for resolution

I’m having a similar problem with seeing my smart tags on “view map” in Smarthings app.
when I click on “view map”, the map opens and then immediately disappears.
SmartThings app version
Galaxy A53 with latest OS version.