SmartThings Community

Make SmartPower Outlet turn off after 2 secs?


(Ricky Heffron) #1

How can I change the device handler of a SmartPower Outlet so that when I turn it on it turns back off after 1 or 2 secs? Is that possible?


(Jimmy) #2

It’s possible, but it wouldn’t be reliable. Zigbee and z-wave protocols aren’t really made for quickly timed communication like that.


(Ricky Heffron) #3

I can set the power allowance for 0 mins to turn off after turning on but that turns it off real fast I need another sec I think


(Jimmy) #4

You can try with webcore


(Nathan Curtis) #5

You won’t be able to get resolution less than 60 seconds reliably because of cloud processing. And with the smartlighting smartapp to get local processing - assuming it’s a locally processed device, I think the smallest resolution is one minute.

What are you actuality trying to do, Ricky? (what’s the end result you’re looking for)


(Ricky Heffron) #6

Im trying to make a momentary closed circuit for 1 sec but it can be up to 5 seconds. If I use the smart power outlet and add a power allowance rule for 0 mins I can make the smart outlet shut right off and I think its going to work just fine, Im testing it now. The other way of doing this was going to be with a 12v timed relay plugged into the smart switch.

So what I have is a smart outlet that turns on then right off and that triggers a 12v power adapter that feeds a 12v relay :slight_smile: to give me a momentary switch.

So if it wasn’t for the Power Allowance under smart apps I couldn’t pull this off unless I found a way to change the handler.


(Simon) #7

I had this very conundrum when automating some curtains. I found that anything under 10-15 seconds was not reliable using a smart outlet.

I have solved this using a Fibaro single relay (FGS-212) which has an option of auto off after a defined number of seconds. That way you only need to trigger the ‘on’ part. It has a dry contact so you can switch any voltage you want and also runs as a generic Z-wave device allowing local execution. You just have to set the auto off function using the correct DTH or Z-wave tweaker first and then change to the generic if you want local execution.

Been working now for over a year without issue.