Leviton (DZS15) and SmartPower Outlet Slow Control Time


(Ben Johnsen) #1

I have just started using SmartThings.

The first project I did was to install a Leviton switch to controller a lamp in the same room that is plugged into the SmartPower Outlet. Links to the products are provided below.

I used the “Smart Lighting” App to setup the control so that when the switch is turned on the SmartPower Outlet should turn on and when the switch is turned off the SmartPower Outlet should turn off.

When the switch is turned on or off it takes anywhere from 5 to 10 seconds for the SmartPower Outlet to follow the state of the switch.

Is this lag time an expected? Are there ways to reduce the lag?

Thanks,
Ben

Here are the products I am using:
https://shop.smartthings.com/#!/products/smartpower-outlet
http://www.leviton.com/OA_HTML/ProductDetail.jsp?partnumber=DZS15-1LZ


#2

5 to 10 seconds is excessive. Start with a zwave repair. This is just a utility you run, you won’t have to do anything with the individual devices. You may not see improvements until the next day.


(Ben Johnsen) #3

Thank you for the tip. I did the repair late last night. It didn’t seem to solve the problem immediately. I will check it over the next couple of days and see if it fixes it.

For another data point I connected up the SmartThings Motion Sensor and had it control the lamp and the control loop is much tighter. It has a delay I would expect, somewhere under 1 second.

Looking at the protocols of the two devices, the Leviton is using Z-Wave (900MHz) and the SmartThings Outlet and Montion Sensor are using Zigbee (2.4GHz).

The SmartThings Hub is right next to my wireless router so I would expect the Zigbee interface to have more interference than the Z-Wave. I am not aware of anything in my home that would cause noise on the 900 MHz range. The wireless phones I have are on 1.9GHz.

In this article (http://blog.smartthings.com/iot101/a-guide-to-wireless-range-repeaters/), linked from the previous article posted, shows a picture of the V1 Hub and Zigbee and Z-Wave Max Power Direction. Is this still the same for the V2 Hub?

Now that I know that a 5 to 10 second delay is not expected and other devices can control it faster. I will start playing with a number of things, like placement of the Hub, orientation of the hub, different light switch with Zigbee protocol, etc.


(Ben Johnsen) #4

The switch still has a 5-10 second lag. I have repaired the Z-Wave network and wait a day. There was no improvement.

I have removed the switch from the SmartThings Hub and factory reset the switch. I re-added the switch to the SmartThings Hub ans still it has a 5-10 second delay.

I have moved the location of the Smartthings Hub to be very close to the switch and there was no improvement in the delay.

I am out of ideas to try other than getting a different switch. I would like to get a Zigbee switch but it doesn’t look like there are very many on the market. I could try and other manufactures’ Z-Wave switch and see if it behaves better.

Any other suggestions of things to try would be helpful.


(Ben Johnsen) #5

I changed out the Leviton switch for a GE switch and it works correctly now. The delay between toggling the switch and the light changing states is barely noticeable. I am not sure if all Leviton switches act this way or if it is an issue with this specific one.


(Dave) #6

@bjohnsen,

dredging this up. :slight_smile: What Model GE switches did you purchase? I currently have the same issue with my Leviton switches. I started with the DZS15 and the delay was about 6-10 seconds from when I pressed the switch to actually switching on the lamp. Have done the Z-wave Network repair, moved hub closer etc. I then bought the Leviton VRS15-1LZ switch per some previous posters recommendations here in the community.

But even with the newer switch and after running Z-wave Network repair, waiting till the next day, moving hub, etc. The delay is better than the DZS15, but not by much. The delay turning on or off is about 2-5 still…

Not sure if I’ve missed any other troubleshooting procedure to get these to respond quicker.

Any help would be appreciated.


(Ben Johnsen) #7

@suprdave04,

Sorry to hear about your troubles.

This is the one I bought:

There is a slight delay but it seems to be around 1 second and seems to be pretty consistent.

Reading what you have tried I think you tried more things than I did.

Hope that helps.


(Dave) #8

Thanks for the info!


(Dave) #9

Was gonna finally get around to buying the GE switch mentioned above and see if that was going to solve my lag time on my current Leviton switch.

But, With a Z-wave Plus switches out from Dragon Tech and Also GE, I wonder if those would help with my lagginess?

I was thinking about getting this…

or

also, what’s the technical reason that my current leviton switch is so laggy? Somebody answered this in another post, possible JDRoberts :), but my search foo was not werking… :slight_smile:

thanks !


(Dave) #10

@JDRoberts

Wonder if you, or anyone has any insight?

thanks!


#11

Are they running locally or through the cloud? Weirdly, some people have been reporting over the last two or three months that devices running locally have an added lag relative to the cloud.

You can tell what you have running locally on your own account from the following links:

http://thingsthataresmart.wiki/index.php?title=FAQ


(Dave) #12

looks like my switch’s that are laggy are running locally… :frowning:

I’ve done the z wave repair, etc. It’s just laggy when I physically press the switch, not if i press from either within the smartthings app, or from smarttiles…

Now… to give you a picture of what I have setup…:slight_smile:

leviton dzs15 switch to a GE Outlet (12721), switched outlet to ext. cord with two lamps plugged in.

I originally had the above setup without the GE outlet, but it was still laggy with a physical press of the switch.
so I thought maybe the outlet would help with laggyness. Another reason that I got the outlet was that the LED bulbs I was using, TCP LED dumb bulbs, had that faint glow which would not completely turn off. Even though the switch was off. So, at least now the TCP bulbs turn off completely. Albeit with a bit of Lag from a physical press of the Leviton switch.

thanks again for any insight… :smile:


#13

When you use the mobile app, you’re going through the cloud. That’s because your phone does not talk to the hub directly, it talks to the cloud which then talks to the hub.

When you press on the switch, if it’s set up to run locally, the switch talks to the hub, the hub thinks and figures out what it’s supposed to do, then the hub talks back to the switch.

It sounds like you may have run into the issue that others have reported where the hub is a very slow thinker relative to the cloud.

You could test this by making a copy of the standard device type handler for the switch, renaming it and saving it to your own account. This copy would not be eligible to run locally. You could then assign the switch to it and if that fixes the lag, then you know what you’ve run into.

It’s a very odd problem, because normally local operation should be faster than cloud-based operation, but other people have been reporting this issue for a couple of months now.

@slagle might know more.


(Dave) #15

@slagle

Wonder if you have any insight on why my switch(s) seem to be so laggy with a physical press?

thank you!