Magic Home Led WiFi controller issue (to be connected to SmartThings)


I have 3 Magic Home Led WiFi controllers with PSUs and 90 RGWW deck lights. (30 each)
I bought them on ebay in september and I can’t get the wifi set up on any of them.
I have tried Android and IOS.

The controllers show up on my android phone or ipad for about 10 seconds or so and then disappear.
If I try to connect on my phone it disconnects quickly.
If i try on my Ipad it say Unable to join.
It doesnt ask for a password.
The SSID is LEDnetxxxxx

Because I can’t connect to the wifi on it, I can’t configure it to connect to my router using Magic Home Pro.
All 3 of my WIFI controllers do this.
I have tried 2 android phones and an old IPAD that is wifi only.

I have tried resetting by the on off on off on off method, it then shows the SSID on the phone but same problem connecting. Then it disappears again.
I don’t know if it is actually resetting as I don’t get strobing lights or anything unusual.

Any ideas how to sort this anyone? My supplier is ignoring me.

Hi @paultheother1, this community/forum is for users of Samsung’s SmartThings hubs, devices, and services, as well as supported devices connecting to their hub and/or cloud.

Are you trying to get these to eventually connect to SmartThings?

Of course I am.

I updated your post’s title so others don’t have to try and guess, make assumptions, or read your mind…

Did you get this figured out? I am having the same problem.