SmartThings Community

Lowes Iris Thermostat

afteriris
#21

The GoControl thermostat (GC-TBZ48) seems to be a rebranded Linear thermostat. Since Iris is no longer working, you will need to verify that the thermostat is not set as a device on the Iris zWave network. Then pair it as outlined in the manual. Mine showed up as a Linear ZWave thermostat, and works fine.

0 Likes

(Bill Ho) #22

I got the same thermostat from Lowes that also gave me the Iris hub for free. I have switched to Smartthings a couple years ago using a customerized IDE without problem. However, I have already retired that thermostat a few months ago long before the termination of Iris service.

0 Likes

(Henry Holthof) #23

My Iris Thermostat refuses to connect. I can’t unlink it from Iris since Iris is dead. Therefore the link shows in the Menu. I’ve totally removed the power and reset thinking this would help. NOPE! I also tried some of the other suggestions I’ve read and none of them work. After 4 hours of trying all of my Iris Devices that are suppose to work, NONE DO, the smart hub is going back for a refund. Very Frustrating.

0 Likes

(Jeff) #24

In my transition from IRIS to Smartthings, the IRIS Thermostat was the hardest to connect. You don’t need the IRIS hub to unlink any of the devices from IRIS however. The thermostat is Z-wave, so in the smartthings app you want to first exclude it using the z-wave utilities. In the classic app you find those utilities when you click on the icon for the Hub. It doesn’t pair easily and I had to have the hub close to mine to pair it.

Most of the other IRIS items are zigbee. If you do a google search you can find intructions or videos showing how to do a factory re-set on them, then they pair easily. If you have IRIS version 1 items they won’t pair with Smartthings, but most of them will now pair with a Hubitat hub.

0 Likes

(Tammy Nogare) #25

I have a Lowes Iris CT-101 according to Lowes and now Sansung says it is CT-100…called Samsung before the shutdown of Iris and was told it would work. It worked for three weeks. Update for the hub came out this week and now the app mode will no longer allow me to change the mode on the application to turn therm to off. Samsung told me to remove the app and reinstall. Next call they said to clear the cache on my phone. Did that and still doesn’t work…now Samsung said they don’t support the thermostat. So disappointed. I live three hours away from my cabin and so this must work as I have it rented out on Airbnb. Any ideas

0 Likes

(Tammy Nogare) #26

I just posted a message Nick…any ideas.

0 Likes

(Sam) #27

I think it was the latest update to the new app that disabled the ability to change the mode on the CT-101, as I see the same behavior on my ADT hub. You can get around it by downloading the old app, where you can still change it. (At least my experience.)

0 Likes