Lock Unlocking Every Morning

locks
kwikset
routines

(Matt) #1

I have a Kwikset Smart Lock that reliably unlocks every morning at around 5:55/5:56 AM, which happens to be our sunrise time around here. When I look at the device logs, its clear the lock is unlocking because ST is running the “I’m Back” routine every morning at around that time. I have no routines tied to sunrise, and a phone isn’t suddenly being turned on or anything that would trigger “I’m Back” to run. In addition, I have my “Good Morning” routine run every morning at 5:45 AM during which the mode is changed from “Night” to “Home”. Under advanced options, for “I’m Back”, I have set it to run automatically when someone arrives (our phones or presence sensors), but not when it is already in “Home” mode (which it would be since “Good Morning” runs about 10 minutes earlier). Nevertheless, every morning the “I’m Back” routine runs at 5:55/5:56 AM, and triggers the front door to unlock.

Any ideas as to why the routine keeps running with no apparent trigger?


(Bill S.) #2

Are you using any third party rules engine like webCoRE, Stringify, SmartRules or IFTTT?


(Matt) #3

Nope, nothing 3rd party.


(Bill S.) #4

Try removing the Home mode requirement from the I’m Back routine. I wonder if Good Morning switching from Night mode to Home mode might be triggering it.

Also, you might want to try removing your phone as a presence sensor and see if that helps. Phones can be fickle in their GPS reporting (iPhones, for instance, have been reported to not report GPS if in DnD mode). On Android, Doze mode could also be triggering it as it comes out of a deep sleep state and suddenly firing location triggers. AFAIK, ST doesn’t maintain a wake lock in Android, so location reporting might be “sleeping” as well.

Beyond that, I’m stumped. :frowning: Sorry.


(jkp) #5

Try creating a new routine - perhaps name it “coming home” or whatever you want. Set it up with the same settings as “I’m Back!”. Then remove all the settings for “I’m Back!” - don’t remove the routine, only the settings and save. See if the unlocking issue is resolved.


#6

I would definitely report it to support, they may be able to see some things from their side which are not available to us as customers. When you write them, tell them in your first email that you give them permission to look at your account, that will save one round of email exchanges. Or you can use phone or chat if the times are convenient for you.

https://support.smartthings.com/hc/en-us


(Matt) #7

Thanks, I’ve put in a help ticket. Hopefully I don’t just get the stock “Do a hard reboot”, because I’ve already tried that.


(Matt) #8

OK per jkp’s advice above as well as tech support’s I’ve deleted and re-created the routine. ST tech support stated that they can see that the “I’m Back” routine was once tied to sunrise (I don’t recall this) and that when it was deleted and changed it likely got corrupted in some way so that sunrise was still triggering the routine. My guess is that when I first got my hub and set up the routine, I was playing around to see the various triggering actions you could use, and corrupted it. The app and IDE don’t relay that it should run at sunrise, but something is still there telling it to. Just took this long to notice because I’m not usually standing near the front door right at sunrise. Fingers crossed that the replacement routine works correctly tomorrow, but with no unlocked front door at sunrise.


(Matt) #9

Hmm, looks like I need to retitle the thread to “…Unlocking Every Morning and Evening”. So after deleting and rebuilding the routine from scratch, I’m sitting here watching TV with my kids and the front door unlocks for no reason. I check the logs…the replacement “I’m Back” routine has just been run, precisely at the sundown time listed in the IDE. I look further back in the logs to discover it has been doing it at sunset too all along. Now, I know I didn’t fiddle with any 'automatically run at sunrise/sunset" settings when I just rebuilt it. I’ve seen some posts by other folks with smart locks who’ve discovered an unexplained unlocked door. I wonder if this same sunrise/sunset issue is happening for them and they are just discovering it later?


(jkp) #10

Have you checked the Lock to see if it is associated with any other smart Apps? If you go to the lock, click on smart apps in the upper left. I still suggest creating a new routine and naming it anything ther than I’m back and see if you still experience the same issue. My guess is the I’m back has problems somewhere, even when recreating it.


#11

I had lock problems but they occurred at different times of day, none of them at either sunrise or sunset. :disappointed_relieved:


(Matt) #12

OK…ST Support helped me finally find a solution that has worked. What I needed to do was delete the automations and allow the system to complete at least one sunrise/sunset cycle before re-creating them. They stated that form their end they could definitely see some “weird logs” being generated at sunrise and sunset. It worked! No more spontaneously unlocking doors.

Thanks for the help everyone,
Matt M.


(Ron Talley) #13

I was convinced you had done a Boo Boo somewhere. I stand corrected. Glad you got it worked out.


#14

So, the one-cycle sunrise/sunset exorcism got rid of the lockgeist … that’s good to know :smile: