Location missing from the smartthings app ios or android


Since 2 weeks i can not use my phone for interacting with my devices.
The location disappeared from phone app and i can not control anything.
I checked on internet link and there everything looks good, i have location i have devices and all ok. I tried to log off log in , delete app new and old , install new app and log in , reboot hub from smartthings www. Nothing until now.
What can i do to have location with all devices back to phone. ? Pls help

I open manually the door for my car for 2 weeks :slight_smile:

Thank you

All of my phones stopped reporting their locations and my virtual presence sensors all stopped working as soon as I deleted the old app.

Thank you.

I did that also
I delete both apps and i installed only the new app.
The new app now showing only the loading image in the middle of the screen and no location available

But on SmartThings site i see location and all devices.

are you referring to geolocation?


Any malware blocking, vpn or pi-hole on your home network?

Hub is assigned to a room?

Last question - if you login to account.Samsung.com what region is your account assigned to in your profile?

Have you reported the issue to ST support?

And also i do not see the possibility to select location

Location in account is Romania.

What do you mean by hub assigned to a room? Where?
Everything worked perfectly for more than 1,5 years. And also in the new app. Not only in classic app.

Yes i open a ticket

change the language on your mobile device to English (US) and see if the ST app loads

Did that

Still loading and no location
I delete now app and also reinstall

Tagging @Brad_ST

Where to assign hub to a room? On st site?

If you are able to see devices in menu > devices… then click on your hub, go to three dots in the upper right of screen and choose edit. Assign it to a room

No chance

If i click on Devices it comes back to the loading page. And nothing happens

But strange is that is no more the filter location button

Am i the only one with this issue?

You will need ST support at this point.

1 Like

Thank you

One more thing
The notification are still working but in app i see no devices, no scene, no nothing

Probably everything is tied to the same issue.

I changed the phone and now is working everything.

I re-synced your location. If you are still seeing issues please notify ST support.


Thank you

Life saver :grin:

1 Like