Linear Z-wave Siren device type needed

I am also using the v3 version of code but the battery status does not seem to be working. Do I need to do something first? Any help is appreciated

Hello Miketx, been using your version 3 code and everything works except the Battery Status.
I tried the tools command and when I select refresh I got this on the log

dd21f516-6a8b-4ffb-9d4e-52e038d9a546 8:08:42 AM: error groovy.lang.MissingPropertyException: Exception evaluating property ‘descriptionText’ for java.util.ArrayList, Reason: groovy.lang.MissingPropertyException: No such property: descriptionText for class: physicalgraph.device.HubAction @ line 143
dd21f516-6a8b-4ffb-9d4e-52e038d9a546 8:08:42 AM: debug parse(zw device: 12, command: 8003, payload: 64 ) - command is BatteryReport(batteryLevel: 100)

Any idea on whats causing it. Thanks

Ok I am newbie in programming, not sure where to get documentation, but I found out which line is causing the issue. Here is the event

def createEvents(physicalgraph.zwave.commands.batteryv1.BatteryReport cmd)

I found that this last line is causing the error.
[createEvent(map), response(zwave.wakeUpV1.wakeUpNoMoreInformation())]

Within this line its this part is causing the error


If I replace with the line with just


I get the battery status, however I am not sure what effect would skipping wakeUpNoMoreInformation.

Anybody know why this line won’t work? response(zwave.wakeUpV1.wakeUpNoMoreInformation()) I have a ver 2 hub. Thanks

Just tried this with the Siren Staples has on sale for $25. Thanks for the handler. It works as expected.

Same here. Thanks.
I bot 2 from Staples

I got from staples (Model WA105DBZ-1). It do not seems to work when on battery power. I charged for a day. Any experience? It works as expected on Power adapter. Thanks for the code.

Very Loud than I expected :slightly_smiling:

I believe there is some type of jumper you have to flip for it to work on battery. You may be able to google search and figure out where the jumper is.

I unscrewed 2 screws at the back of the unit where power cable go in, and found a jumper, jumper set to one leg, I jumped it to two legs, and put it back to charge, I believe that could be the jumper for battery, which was next to a small battery. I think it may have not been set in the correct place. I will update. If it work after overnight charging.

If you had it charging you can probably try it immediately. Thanks because even though mine is on power I want it to still work without. Going to change mine when you report back.

Tried & it is working on battery without power adapter. It was the jumper after all. No indication on the Battery % on the Tile yet.

Mine was not working on Battery either. Thanks for the tip. I’ll try this tomorrow.

Note - when I paired my Siren to ST the Fingerprint for the device did not report the Battery status/capability in the inClusters description (0x80) so I don’t think that this device (mine is model WA105DBZ-2) will report battery. I think this makes sense since the Battery is just for backup in case of power failure. I’m still playing around with the device and will let you know if I find something else about the battery status report.

Sorry for the NOOB question how do I install this device driver into my SmartThings? Bought this Siren from staples on sale recently - I can get the siren to activate by switching TYPE to SmartAlert Siren however SMH won’t turn OFF the Siren. Would like to try this solution. Thank you.

You need to log into the IDE.

Once registered and in, go to “My Device Handlers.” Think of this section as where the device drivers live. Once there click on “Create New Device Handler” to the right. You will get another screen with a lot on it. Select “From Code” and then copy the code for the device into the area. After you have done so towards the bottom hit “create.”

Now go under “My Devices” and select the siren (mine showed up as a switch initially). Click edit and then go down to “Type.” Use the drop down box to select the device handler you just installed. Click “update” and your siren should show up in a couple of minutes in the smart app.

I’ve started playing around with this, and get some of the basics to work, but I am not successfully changing the duration setting.

I found this line

preferences {
input “autoStopTime”, “enum”, title: “Disarm Time”,required:true,displayDuringSetup:true, options: [“30”,“60”,“120”,“Infinite”],default:‘30’

and changed ‘30’ to ‘Infinite’, then refreshed my device, but it still stops at 30 seconds. Am I missing something?

After posting that, I also found the setting in the Android SmartThings app (select device, top right menu, and set DISARM TIME), but that setting doesn’t seem to actually affect the device

@marc8lange I wonder if this would be a way to do what you want by using @krlaframboise technique in Rule Machine talking to the @miketx device type instead of the Aeon?
Show your Rule Machine automations

Any fix to keep this from turning off after 30 sec?

Edit: If you replace the last line of the update method, in version 3 it appears to be line 83, with the code below, it should fix the problem, but since I don’t have the device, I can’t be sure.

After you replace that line of code and publish the new version, you will need to go into the device settings and save to apply the change.

Old Line:
zwave.configurationV1.configurationSet(parameterNumber: 1, size: 1, configurationValue: [autoStopTimeParameter])

New Line:
response([zwave.configurationV1.configurationSet(parameterNumber: 1, size: 1, scaledConfigurationValue: autoStopTimeParameter.toInteger()).format()])

Thanks the fix works

Thanks for the new device handler. I was interested in disabling the strobe light (I have my siren hidden) so that it could not be easily found on the off chance someone did break into the house. This did the trick.