Linear GD00Z-4 Z-Wave - Stays as "Unknown"

Trying to integrate a Linear GD00Z-4 Z-Wave with Smartthings Hub and I can have it added it, which shows up as “Z-Wave Garage Door Opener” but the Actions “Open \ Close” seem to be Greyed Out (While the Unknown Status is highlighted). See the image at

The unit is connected to a Marantec 4500e Opener but I doubt that is the problem, since pushing the Open\Close on the App doesn’t even generate any Log events ?

Did you install both pieces? There’s a big control box and a small tilt sensor

This is an officially supported device so you can write to and they can help you out. But it sounds like the tilt sensor just might not be connected.


Yes …Ofcourse I did “Not”…!! I just somehow thought that it wasn’t needed just for initial test…Will do that right now…:slight_smile:

1 Like

Also, once you have the system installed… run the door through a full cycle via the wall button. Once you have done that the status should change on the app and will be ready to go.

This is what the instructions that came with mine said to do and it worked great.

1 Like

Keep in mind that you might actually need to pair the tilt sensor with the garage door opener itself under some circumstances. After fiddling with my units for days I was able to piece together this info from a few different sites and comments from people who purchased the unit on Amazon.

The tilt sensor uses some kind of proprietary communication protocol and talks directly with the main unit and not through the Z-Wave network, so ST doesn’t know anything about it. This is important because the sensor talks to the unit to let it know the garage door state…

If you send the controller a command to open / close the door, it waits to hear from the tilt sensor about the door state (closing / closed, opening / open). If it doesn’t get that message for whatever reason, you get one more change to operate the door after 30 seconds. If that attempt doesn’t get a response either, the unit goes into “lockout” until a the door is operated “locally” (you use your remote, button, whatever).

If THAT doesn’t reset the unit, then you’ll need to re-pair the controller with the tilt sensor. This sucks a lot because it requires you climbing on a ladder to go press the button…

To re-pair the tilt sensor with the unit you have to press and hold the side button for about 7 seconds (until you hear a beep).

Then you take your tilt sensor and change the position (vertical to horizontal or vice versa). You can take it off the door and flip it manually, as long as you press the little contact inside that lets the sensor know it’s mounted, or you can open / close the door if you don’t want to unmount it.

You should hear a short beep from the unit to let you know it’s “found” the sensor and paired with it.

I think they do this in case you have to replace a damage sensor or something, that way you can just replace it and pair it and you’re good to go without having to mess with the main unit too much.


Also make sure your tilt sensor is put back together correctly. I opened my tilt sensor to look at the battery and internal components. I then put it back together “upside down”. It snapped together just find upside down, but did not work. After an hour or so of troubleshooting, opened the tilt sensor to reset it and discovered my mistake. There is a small button on the inside that get pressed when the case is snapped close, but only if its put together correctly. Ha Ha. Easy fix, pain to find.

1 Like

This controller will not work without the Linear sensor???

Viguera, are you convinced the tilting of the sensor is what solved it for you? I’ve tried this 3 times now - I get the acknowledgement beep. Plug it back in, cycle the garage manually up and down 3 times… still showing unknown. Keep doing it… no change. Shows unknown. I’ve hard reset the unit, repaired, etc. and not having any luck.

Thanks for the suggestions.

That’s what solved it “for me” but your mileage may vary. :slight_smile:

Keep in mind that there’s a contact inside the tilt sensor itself that tells the system that the sensor is mounted and the lid is closed – when you open the thing you can see the cover has a little knob that pushes in the contact itself.

If the contact is not pressed in properly then that can give you problems too, or if you try to do the whole reset with the cover off. Usually it’s the battery that causes the cover to push out slightly, or just the cover doesn’t close tightly because of the stupid tabs that they use.

You can use a piece of tape or paper over the contact to make sure it’s pressed when you close the lid. Or find some way to make sure the thing is closed tightly and the battery itself is not pressing everything out and keeping the knob from pressing it.

1 Like

Sorry, I haven’t read the entire thread, but I thought I’d ask…

are you using the tilt sensor that came with the unit?

OP initially was not but sounds like that got resolved.

I am using it, and still struggling. If i hold down the contact or keep the back on the sensor and do the ‘reset’ and connect for the sensor, it doesn’t beep at all if I tilt, etc. If i let go of the switch on the sensor it will beep though.

1 Like

This is the same behavior I am getting on mine. The controller pairs up to the ST hub just fine, but shows as “Unknown”. I attempted to “reset” the sensor with it in my hand and the confirmation beep only happens if I let go of the little button on the tilt sensor.

I take it back…mine is working now. I followed the “Paring” instructions on this page:

Just as that person stated, no idea if pairing it with the sensor installed vertically was key or not…doesn’t matter, it works now.

1.) Reset the controller to factory

  • press the pairing button 5 times
    2.) Pair the Tilt Sensor if in doubt
  • install tilt sensor
  • hold controller button for 7’ish seconds until it beeps
  • open garage door and unit should beep/flash as door opens
    3.) Close garage door
    4.) Pair Controller with ST hub
    5.) Open garage
    6.) Close garage
    7.) Status in dashboard should show up

I have no idea why it worked this time, but not the 11 times before…but it worked finally.


For the life of me I cannot get it to work. Followed all those steps like 10 times and still shows “unknown”. Any other options?

Thank you for this! I was about to give up on a used unit I bought when I saw this. 10 seconds later it’s working!

Could you please guide me to find the push button terminals for M4500 model?

I’m new to this thread but having the same “Unknown” status problem many people seem to have. I’ve gone through all of the steps and everything works as expected up until it’s supposed to show the door status, The tilt sensor pairs fine according to the beeps. The unit pairs with the ST hub with no issues. I’ve tried the above steps twice, opened and closed the door several times manually, but still “unknown”. This is very frustrating.

The first thing you need to see if the garage door controller is communicating with your hub. The antenna on this device is directional and can have issues if not pointing in the right direction or if you have a weak mesh network.

Open your IDE Live Logging, open and close the door. Do you see anything posted on your IDE live logging? If not then it’s a communication issue. I’ve posted about how to fix in a few other threads you can see this here, but essentially realign your unit direction on the mount and/or move it closer to your hub

Thanks for the reply. That could be it. The live logging shows no action at
all when I try to interact with it. I honestly didn’t think it was a
communication issue because the 3-4 times I tried resetting the opener, i
was always able to add it back to the hub with no problems, even while it
was mounted to the garage door opener. I’ll see what I can do about working
on that. Thanks again.

Try adding more repeaters around the house to create a strong mesh otherwise try to adjust the mounting angle (in all 3 axis) through trial and error. Just note its should be more than 15ft from the closest active repeater/hub.