Limit to # devices in a scene?

For some time now I have had two scenes (new app) that I use at bedtime or when leaving the house. One is “All inside lights off” and one is “All outside lights off”. I’ve got an Alexa Routine that is triggered by the phrase “Lights out”

This has worked great for the last couple of months as I slowly added additional smart switches and dimmers. It would sometimes take up to maybe 90 seconds to work thru everything but was 100% solid.

Two days ago I added a Peanut Plug to control the Christmas tree lights.

Since then, I’m getting one or two lights left on, so far always inside lights.

The “outside lights off” scene has 9 real switches and dimmers and 4 virtuals. The “inside lights off” scene has 12 real devices and 2 virtuals. The recently added plug is part of the inside lights scene. All devices are on stock DTHs so are locally controlled by my V2 hub.

Ok, all that description done…

Have I hit some limit to the number of devices that will work with a scene? Or could Alexa be triggering the inside scene too quickly after the outside scene?

Appreciate any thoughts or suggestions.

Similar problem for me. Trying to transition to new app and in moving routines from old app to Scenes/automations in new app. Old app had two similar routines one for going to sleep and one for empty house both of which would lock doors close garage doors and turn off all lights inside and out and all harmony activities and other devices. All in about 120 devices. Worked just fine in old app but new app kept saying “network error” when I tried doing all in one scene or automation. Crazy frustrating. Not process in ST end - old system great new system can’t take it. Ridiculous. To make it work I ultimately had to break the scene into three (!) scenes and have automation run all three scenes when triggered. Wonder if your issue has anything to do with what I ran into.


There are limits, but it’s unclear to me what they are. And they seem to be changing.

FAQ: Limits and Guardrails (max # of automations, devices, etc)

Tagging @jody.albritton

My own rule of thumb going back a long time, and not ST-specific, is never to put more than 30 zwave/zigbee home automation devices in a single group/scene/rule. I daisychain groups/zones if needed. (Easy to do in ST with virtual switches as proxies for a group.) Mesh networks just weren’t designed for massive traffic.


Tell it to Philips, their Hue ambilight solutions or custom light changes, like candle light or fireworks, changing lights for music, etc. are really massive traffic. :wink:

It would be nice if Smartthings would finally tell us what are the limits. Every time someone brings up a limit related question, it always has the magic “network error” message.


Thanks. I’ll reread the thread on limits. My larger scene is only at 12 devices. The virtuals are all used to make groups of devices that are counted, and separately switched off, in my numbers of real devices.

I wanted to make sure the virtuals were all “synced up” so the scene switches off both the virtual (group) and each device that is mirroring the virtual. That may be causing some extra commands, 5 for the inside scene and 4 for the outside scene.

Fair enough, that’s using ZLL with groupcasting. But that’s a very specific use case. And Philips has engineered for that. :sunglasses:


If the “network error” message comes up in the app, then I’m not seeing it. Just some command or commands never arriving. My total number of mesh devices is about 30, with 26 of them Z-wave. All the Z-wave devices are smart switches and dimmers. There’s an assortment of WiFi thermostats, Sonos components, Harmony activities, and virtual devices that brings my complete device count on the IDE to 52

Last night when I told Alexa Lights Out, there were probably 9 inside and 5 outside lights that needed to be switched off. After I figured out it wasn’t getting everything, I repeated the Alexa trigger and the last two turned off.

If I remember, I’ll open live logging tonight when I trigger the scenes.

1 Like

Two nights watching live log when shutting things off, two nights where it all worked successfully.

There has always been one or two lights that lagged 30 or 40 seconds behind even though they are all using stock DTHs and execute locally.

I decided to run a Z-wave repair, perhaps hadn’t done one since the most recent devices got added.

It’s a mess! All my lights work but I’m getting “could not assign new route” errors for 18 of my devices. I’ll let it churn for a day and try again.

If they are battery operated devices, that just means they were asleep when the request came in. No big deal.

If they are Main’s operated devices, you’ve probably got a bad repeater somewhere.

FAQ: Zwave repair not working (how to fix error messages)

1 Like

All are mains powered. I was wondering about repeaters. The first hop for all the problem devices is an Aeotec repeater. I unplugged it and plugged it back in after my first messy Z-wave repair. It shows online in the IDE and Connected in the V3 app.

I’m thinking of replacing it with a Z-wave outlet.

There’s one other repeater. It shows up with the route error and should not be in the path for most of the devices giving errors

By “repeater,” I meant any device acting as a repeater, including light switches, pocket sockets, relays etc. Not the single purpose devices. It could be one of those, but not necessarily one of those.

1 Like

Ok, thanks for the clarification. For Z-wave, all I have are switches, dimmers, and two Aeotec Range Extenders.

All my switches and dimmers are working.

Seventeen of the twenty switches plus one of the repeaters are in the great room (kitchen, dining, bar, living room and front entrance) and show the route error.

I’m pretty sure the first hop to get from the hub to the great room is via the other repeater. So I am suspicious of it.

1 Like

I’m stumped for now. Did health check on the Aeotec repeaters. They’re supposed to flash green when they relay something. I saw some flashes from both when doing a repair but now nothing. It’s possible the switch density in the room is now high enough the repeaters aren’t needed.

I tried excluding a couple of switches that are closest to the hub. Repair was the same, error for every remaining switch in this room.

Will try some more fiddling tomorrow. That $200 Z-wave toolkit is looking more attractive!! :face_with_raised_eyebrow:

1 Like

I’m kind of talking to myself here. Sometimes the act of writing things out clearly enough to explain to someone else triggers the grey cells.

I added three more Zooz dimmers to the great room today, all in a single 3-gang box. No issues at all.

That brought me to 21 switches in the room, plus one that’s further away from the hub, plus 2 range extenders. Total of 24 Z-wave devices in this end of the house.

Z-wave repair, 20 of them got the “could not assign new route” error.

Based on the Aeotec REs not indicating they were relaying, I decided to remove them. Unplugged and deleted the one farthest from the hub. This time Z-wave repair only gave error on 10 devices. So I thought I was on the track of something. Got rid of the other repeater.

Up to this point all the Z-wave repair runs would go about 4 minutes before the errors started popping.

After removing the final repeater, repair ran for 8 minutes, then I got errors on 20 devices. Took the repair roughly 16 minutes, about twice as long as before.

I’m still stumped. All my devices still work perfectly well. Nearly all of them show a route update error.

I probably wouldn’t have bothered with running Z-wave repair if it weren’t for the problem that caused my to start this thread.

Regarding that, I’ve spread my lights across three scenes in the SmartThings app, letting Alexa run all three of them for the “Lights Out” command. I’ll find out how well that works in a bit.

If I get some free time to sit on the phone, I may give Samsung support a call on Monday.

One last thing…

I tried factory reset on one of the Aeotec repeaters, then added it using the new SmartThings app. That worked but the first event after the inclusion completed was zwSwitchStatusLockout Err 113 not responding to polls.

I excluded the repeater, tried another one for good measure with same results.

The repeaters were absolutely necessary when I first installed them. I’ve now got so many switches in this part of the house, they seem to be unnecessary.

Model numbers on, well, anything? :wink:

But to start with, the aeotec repeaters.

  • Aeotec Range Extender 6. I had three online to begin with, removed one about a week ago. Removed other two today, as mentioned above.
  • Leviton DZ6HD dimmer. One of these in the room
  • Zooz ZEN27 dimmers. Ten of these.
  • GE 46201 Enbrighten 2nd Gen. One of these
  • Zooz ZEN26 switches. Nine of these in the great room. One more in a different room father from hub, dependent on a great room device for repeating.

This room is nearly all of my Z-wave build out. There are two Leviton DZS15 switches at the opposite end of the house, they have not been showing up in the route errors.


  • all the dimmers use “Z-wave Dimmer Switch Generic” DTH
  • all the switches except the one GE user “Z-wave Switch Generic” DTH
  • the GE switch uses “Z-wave Switch” DTH

Have you looked at the Z-Wave issue with the new Hub FW? You might have not excluded some devices or tackle with the z-wave network.

Good thought but everything I have is Z-wave Plus. I started on this less than a year ago so no legacy devices.

All my devices work perfectly including state showing correctly. I only started looking at Z-wave repair because my “lights out” scenes started not catching every device.

Status of my original problem: I have now divided the interior lights into two scenes.

  • Kitchen lights has 5 Z-wave devices, one virtual device
  • Living room lights has 9 Z-wave, 1 Zigbee, 1 virtual

Third scene turns off the outside lights:

  • Outside lights has 9 Z-wave, 4 virtuals

An Alexa Routine triggers all three scenes. Last night when I ran it the outside lights were all already off. Most inside lights went off quickly. There was about a 15 second pause for one and two lights didn’t turn off after waiting 2 minutes.

I’ve changed the Alexa Routine to include a 10 second wait between each scene. May do some testing later.

Is there any way to reorder things in a scene?