SmartThings Community

Lights Turn On After Loss of Connectivity


(Ryan) #1

I’ve had this happen a few times now. My comcast connection goes down (typical) causing my SmartThings hub to disconnect. When the connection comes back up, my hub reconnects and then immediately my living room lights turn on for no apparent reason. They’re connected to a GE (Jasco) z-wave switch and I have an integration that triggers a couple of independent z-wave plugs when the switch is turned on or off. It would appear that the switch turns on after reconnect which also then turns on the outlets.

Nothing else in my house triggers or does anything weird like this. Is this a known issue at all? I haven’t been able to find any other information about it. Is there anything I can do to work around this? I don’t much care for my living room lights turning on in the middle of the night and staying on until I wake up and turn them off.


(Bill S.) #2

There is a smartapp that handles this sort of thing, but I don’t know if it is still maintained or not though: [RELEASE] SmartBulb Power Outage handler

The other option is to use something like webCoRE to trap events from hub power source and set the lights to their previous values when the hub goes from battery back to mains power.


(Ryan) #3

It’s not a power outage though, power is on the whole time. It’s being caused by loss of internet connectivity.


(Bill S.) #4

Ohhhh!!! Duh… Yeah, you did say that (sorry, first cup of coffee lol).

What is the integration? Routine? SmartApp? webCoRE?


(Ryan) #5

No worries, I know that feeling all too well :wink:

It’s the Smart Lighting SmartApp. A very simple one, z-wave switch flipped on, turn on these z-wave outlets as well. z-wave switch flipped off, turn off these z-wave outlets (my house has some really weird wiring, the switch in question was physically wired to only a single outlet in a very large room).

It seems like after the reconnect, the z-wave switch is just flipping on for no apparent reason.


(Bill S.) #6

Yeah… Smart Lighting can be flaky sometimes. Especially after the latest firmware update.

Personally, I would just remove the routine in SL and recreate it and see if that helps. Or just create it as a standard Routine. If it’s a standard GE Z-Wave switch and outlets, those should all be running locally (so long as you are using the standard device handlers for those devices). You can verify that by going into the IDE > My locations tab > List Smartapps and see if it is executing locally. If it says cloud, then you’ll want to go into My Devices and check to make sure that the switch and outlets are using local handlers (the column “Execution Location” should say “local”).

image


(Jimmy) #7

Do you happen to have an automation with those lights involving a presence sensor?


(Ryan) #8

Everything is running locally… of course as I’m crawling through all this to try and figure out what happened, I see a Smart Lighting automation that I had forgotten about… specifically, I had set one up to automatically turn the living room lights on if myself or my wife arrive home after dark. Any idea if Smart Things would register the hub reconnecting as a presence change?


(Bill S.) #9

Absolutely. Basically, when the hub is offline, the presence sensors are considered away (stupid implementation if you ask me). When the hub reconnects, the sensors “arrive” again. As for a fix, I’m not entirely certain. I’ve never had an internet outage event as I run a 4G backup if my internet goes out.

@prjct92eh2 SPOT ON.


(Ryan) #10

Yup, very stupid implementation. I feel silly for asking the question now. Seems like considering any “cloud” sensors to be in the last-known state would be far better than considering them as away.

I might have to consider adding a backup ISP into the mix, as much as I don’t want to spend money on that.


(Bill S.) #11

The 4G option isn’t too bad, cost wise. Cradlepoint has some good options for cellular failover and you can use pretty much any provider for a USB stick. Mine is through my AT&T account, but I know that there are other pay-as-you-go options out there (Cricket, TMO, Boost, etc).

However, there is one thing you might be able to do if you use webCoRE. webCoRE has a virtual presence sensor that can be used in addition to your other presence sensors and is based on your phone. You can find more details here: https://community.webcore.co/t/install-instructions-webcore-presence-sensor-on-your-android-beta/1324


(Ryan) #12

Yeah, I use Ting, so I could add one easily enough. If it happened to fail over to it at an inopportune time though (depending on what is happening on my home network) it could really run the bill up on me. Something I’ve meant to look into for a while though.

I’m not familiar with webCoRE. I’ll have to take a look at it. As it is, my current presence sensor is a virtual one that is triggered by Tasker on my phone as I originally found the location based presence sensor to be too inaccurate. I don’t get why Samsung won’t allow a WiFi network based presence sensor :roll_eyes:


#13

Quite a few people do use a Wi-Fi based presence sensor. But it does depend on what router you are using. See the presence FAQ:


#14

Also, webcore is essentially a scripting language for SmartThings. Very powerful. :sunglasses: It also has its own presence sensor option: