Lights stay on after Good Night


(James) #1

Hey all, some recurring trouble with my schedules and hoping someone can help me figure out how to troubleshoot.

I have a number of lights hooked up to linear switches. (WS and WD series.) A few of those devices also have corresponding WT series switches for three way applications. I also have a schedule setup with exterior lights to turn them on at sunset and turn them off when I issue the goodnight command.

I’m having a problem where when I give the good night command, the exterior lights (those turned on by schedule) will shut off but the two lights in the house will almost consistently stay on. I have to manually turn them off with the app or switch.

Any suggestions on where I can look to figure out why these lights are not turning off? They are on the schedule to turn off and the app reports that it is turning them off.

Thanks!


(Keith Croshaw) #2

Personally I would remove them from the HH action and re-add them… I know your frustration. Last night mine worked for the first time as programmed…


(James) #3

I could add, occasionally they work as expected. I recently added switches for the front exterior lights and it was after that when they stopped behaving as normal. I will try removing them and readding them to the goodnight command.

Is there a log or some debug information that might also be useful?

Thanks!


(Kim Andrè Flaten) #4

I have the same problem and i haven’t done anything with the system in the last months. just became really unstable. lights not turning on when i open door sensor, lights not turning on and off when using hello home.


#5

Do the interior lights work when you toggle them from the ST mobile app? Or with any other scheduled action?

Exact model number of the devices?

(I have to go and probably won’t see your response right away. @slagle , @tgauchat , whoever, can someone walk the OP through where the activity logs are and, depending on the model, zwave repair and/or Jasco issues ?)


(James) #6

The devices are WS15Z, WD500Z and WT00Z. In fact right now other than an evolve relay, a ST multi and another tilt sensor every device on my network is a Linear Zwave.

I’ve added the devices one at a time, each time doing all the programming and association to connect the device.

The only devices on a turn-on schedule are the front and rear exterior lights. They come on consistently without fail so far. They turn off consistently without fail. I have a light in the kitchen and a light in the dining area that we operate manually to turn on. They are the ones that are not turning off with the good night schedule.

I have the good morning schedule start automatically at 8am but it does not turn anything on.

All of the lights work consistently with the ST app and with the switches directly. It’s only when I issue the good night that the kitchen and dining lights no longer turn off.


(Tim Slagle) #7

Next steps. when you do this action go to the “My Devices” page in the IDE and select the devices that are failing to turn off. On that page you will see a “List Events” hyperlink… click on that and when you do you will be able to see the commands sent to (and received) to the device. If you do not see a off command under the “all” section the device is not getting the command and it is probably and interference issue.

Report back here with your findings and we can help track down the issue further.


(James) #8

I’ll do some testing. One thing I’m observing right off the bat is all of the events are being logged at the slave device (WT) and not the switches (WS).

Just testing it with one device right now is working as expected but it has been pretty consistent in the evening. Knowing where to look for debug info helps a lot so I will report back with the results. Thanks!


(James) #9

Here’s the follow up. As with the last couple weeks of evenings, the lights failed to turn off when I tested tonight. (Though one of them responded while doing some testing during the day.)

In the logs:
…for the exterior lights (two circuits, two switches) I see the goodnight command issued on both lights, and the commands being followed out.
Good Night! sent off command to Rear Walls
off command was sent to Rear Walls
Rear Walls switch is off

…for the interior lights (two circuits again, four switches total counting two slaves) I see the command get sent to one of the lights but not the other.

I then used the app to shut down the remaining two lights


(Tim Slagle) #10

Theres your problem. Seems like a communication issue.

I’d recommend reading up on this article and seeing if you can help resolve some interference.


(James) #11

The devices that are working are further away from the hub. In fact one of them is only 20 feet from the hub with almost a clear line of sight. Sorry but I think you’re jumping to a conclusion or misread what I said. I appreciate the help but it’s not a range issue.


(James) #12

Oh and to be clear by “one of them” I meant the device that wasn’t being sent the good night command.


(Tim Slagle) #13

Understood. I don’t think it’s a range issue either. I think it is a interference issue. Two totally separate things.

I would recommend a z-wave repair through the IDE.

If that doesn’t work I would read through the article I originally posted and work on optimizing the signal. Signal interference is a fickle beast. You could have a device 5 feet from the hub that is not working but one 20 feet from the hub that is and your Wi-Fi router could be the root cause… or your wall paper… or your microwave… or any number of other things.

The logs show the smoking gun. The devices with the issue aren’t getting the command… Its not able to communicate with the hub reliably. The signal is getting lost somewhere.


(James) #14

I’ll give that a try. However I have to ask - after I issued the good night and they didn’t turn off, I issued the instruction to turn off manually from the app and they did. Also it appears the hub isn’t even sending the instruction to turn off. It’s only sending them to the front and rear walls. I just did the test again and this time pull the events from the hub. Here is what I got. (Note the sensor was reporting the garage as open. Unrelated issue but the garage was not in fact open. :stuck_out_tongue: I hope that issue hasn’t come back again.)


(James) #15

Oh wait, as I read what you said again, are you saying the hub only logs that it sent the command after the device confirms it received the command?


(Tim Slagle) #16

If my recommendations dont work for you definitely reach out to our amazing support team. They can help you troubleshoot further :smile:

support@smartthings.com


#17

It never hurts to run a zwave repair, but I agree, it doesn’t sound like the command is being sent in the first place.

I would definitely talk to support@smartthings.com , they can see exactly what’s happening on the cloud side.


(James) #18

Thanks everyone. I will reach out to support. The zwave repair seemed to make one correct in that now it’s actually sending the command. Tonight it was the same behaviour however. Below is the log. The good night command was sent. Interestingly enough it only sent it to the two slave switches and not the main switches. I didn’t check if those were technically “on” or not before hand however.

So this log shows I issued the command. Two lights didn’t turn off and 10 seconds later I issued the manual instruction to turn them off. (Which worked.)

I’ll reach out to support.


(James) #19

So after a lot of testing and back and forth with support (including moving the ST hub almost directly next to all of the devices in question by aide of a very long ethernet cable I found in a box :stuck_out_tongue: ) I think I have found something relevant and thought I’d update.

It looks like while the WT/WS pairs work physically, the ST app will only toggle the WT devices. When it does so, the paired WS/WD does not change state. I’ve opened a comment on the thread that helped me get those devices paired to see if someone there has seen it.

For reference this is the thread:

Thanks!