Lighting Control Limitations

I am fairly new to this, but it seems like there are some severe limitations in all the different lighting control algorithms I have tried so far… All of these seem like they are easily fixed, but I dont see any good way to do it right now and it is driving my wife crazy.

I just want simple motion controlled lighting. I am using Samsung motions sensors and GE smart switches. Pretty simple. Walk into a room and if it is between certain times, then turn on the lights. If the switch gets turned off, then let the lights stay off for a certain period of time without retriggering the lights again. If the lights are already on, then don’t turn them on again. When the motion stops after so many minutes, turn the lights off. If it is late at night, turn on the light to a dimmed setting, otherwise turn it on to a higher setting.

There is no way to set this to not trigger again if the lights are already on. As a result, several fluorescent bumps will flash when it gets the new command which is quite unnerving. Also, there is no way to tell it to look at the state of the switch. My wife will walk into a room, the light will turn on and she will turn it off at the switch, only to have the light turn back on again because the motion sensor trips again! Also, there is no way to set dimming levels.

Smart lighting
This almost works… At least you can set dimming levels and set up multiple triggers, but I can never get the time restrictions to work at all. Its like the controller has no idea what time it is. It also has the same problem where it will trigger over and over again while motion is detected, even if the lights are already on.

Lighting director
Also, almost works. This will at least look at the physical switch setting, but resets too quickly. At least you can get out of the room without the lights turning on again, but if I walk in 1 minute later, it will turn on again. There is no configuration for how long the mode will stay in the off state when the switch is set after trigger.

Am I missing something with these different control methods? Is there another smartApp I haven’t tried that allows you to control these kinds of settings reliably?

1 Like

Oddly, for a bunch of historical reasons, SmartThings is much better at the complicated than it is at the simple. Which is to say there’s almost always a way to make it do pretty much anything you can think of, but it’s rarely obvious how to get it to do something super simple like just grouping lights to go on and off together. There will probably be three or four different ways to do it, but finding them and getting them set up will feel much more complicated than it seems like it should be. :disappointed_relieved:

In 2016, @ady624 created a new rules engine for SmartThings called core. It took all of those complicated capabilities and wrapped them into one very powerful and sophisticated rules engine. It’s still a lot of work to set up the simple stuff, but at least you’re doing it in one place. And there are many community members who will be glad to help you design and set up your automations.

So at this point, the answer to pretty much any scheduling/rule question is just core. It doesn’t make it feel simple, but it definitely makes it possible.

I’m going to give you a different link than the one that @eric182 gave you just because this one sets up a little more introductory context and gives you a couple of other links that you will probably find helpful as well. So I’m just seconding his suggestion, but with a somewhat easier on-ramp. :sunglasses:

1 Like

awesome… thats exactly what I was looking for. It seems buggy though… For example, every time I try to add time as a factor (time after 5pm for example) It wont let me enter the number.

The developer is working on a web interface called webcore. Hopefully will see it by the end of the year. Or even sooner.

It’s been pretty stable, but there were some platform updates this week which affected it.

For any specific questions or issues with setting up a specific piston, just ask in the core peer assistance thread. That’s where the core experts hang out, and they’ll be glad to help.

yea… that doesnt work for me… I can enter the time and “is between” fields, but when I try to enter the actual time, I get a blank screen with no data input capability.

I also get a lot of “unexpected error” messages when trying to save the pistons and when I try to see the saved pistons on the dashboard, I get a blank screen.

What mobile device and os version?

I have tried both my android phone (s7 edge) and my ipad… both exhibit similar issues.

ok… I had to teach it a new GPS location outside of my time zone and then reteach it my actual location again and now it shows the time zone correctly.

That seems to have fixed the time related problems… it also seems to have fixed the dashboard issue as well and I don’t seem to get the same error messages anymore. I guess that was the problem.


1 Like