How does Away mode work?


(Bill J) #1

I set up a schedule on a CentraLite smart switch (a lamp is connected to this switch) as follows: turn on using a schedule > turn on a sunset > only when mode is Away.

After sunset, when my wife and I are both away (and recognized as away by SmartThings) the switch does not turn on. My wife and I are the only people tracked by our ST hub.

I assumed that Mode would automatically be set to Away when my wife and I were both away, however that doesn’t appear to be the case (unless I misunderstand what “only when mode is Away” means when setting the Turn On schedule for a switch means).

Do I need to do something to configure or define what constitutes or triggers Mode being set to Away?

thanks in advance!


(Keith Croshaw) #2

If you click smart setup -> Presence Sensors -> Sensor or phone -> Top Alerts and Actions you can trigger mode changes there. It doesn’t happen by default :frowning:


(Bill J) #3

I did not know that. So, there’s really no way, at least with the out-of-box ST capabilities, to set things up so that when my wife and I are both away, the Mode automatically switches to Away?

Modes are only set manually? That doesn’t sound “smart” nor “automated” (as in Home Automation).


(Keith Croshaw) #4

Well there is a little configuration required, you can say when these two presence tags are gone change mode to away. I do agree there is a lack of out of the box magic and there’s a lot that could be approved upon with modes, but it should only take 1-2 mins to configure what you’re looking to do in this example.

I had to write myself an entire smartapp for something I found pretty simple. The platform lacks some of the niceties of other platforms but the fact that I could write a SmartApp to fit my odd needs is why I’m using SmartThings. I’m hoping it gets a little user friendly in the near future.


(Dawn Fairbro) #5

@bjindrich I have configured my away mode to begin when both myself and boyfriend leave. Go to hello home mode, look at the bottom for the little wheel/gear press that and you then can configure your actions. Under goodbye I change mode to away. Then under additional Settings, Perform goodbye when Everyone leaves, It works for me. I would never remember to configure manually…


(Bill J) #6

Thanks Dawn! I’m finally seeing how Modes fit into the ST model and how to configure things. I see that all I had to do was set Perform GoodBye when Everyone Leaves (and select me and I wife in the list).

I assumed that I needed to set the converse up, to correspondingly set the mode to Home when my wife or I arrived, so I configured the I’m Home action to to Perform “I’m Back” when Someone Arrives, again selecting both my wife and I from the list. Let me know if that doesn’t sound right.

Thanks again for the jump start. Being a software developer for my whole life, I’m sure I’ll want to look at SmartApps at some point, since the out of box ST functionality is clearly basic and limiting (trying to write good “logic” via rules and configurations is hard).


(Keith Croshaw) #7

This looks promising, I signed up for the beta, who knows when it will be available.
Rule Builder by obycode


(Dawn Fairbro) #8

@bjindrich you are very welcome .sounds like you got it :smile: Best of luck to you on software developing. I am just a simple end user who figures things out by trial and error…


#9

check out Magic Home


#10

I had the expectation that this is happening by default and spent weeks trying to figure out why am I not getting the Door Open/Close messages. Finally got it working as required, thanks for the clarification


#11

This might help: