Leviton Dimmer Switch constantly going offline after recent update

I had leviton dimmers working flawlessly for 3 years. This is extremely bizarre. The only thing that changed recently is smartthings has pushed out an update which has been a nightmare. And i migrated from nest to google finally. I dont think that should matter in this situation. I do use smartthings with google home, but the smartthings app itself is also showing the dimmer going offline at times.

I have one leviton dimmer near by it and its working perfectly. But one keeps going offline all of a sudden, I believe it was after the recent firmware update. Whats also odd is i have a logitech harmony remote thats connected with smartthings and when smartthings reports the dimmer is offline, my harmony remote can still turn it on and off flawlessly…Literally that dimmer is saying offline in the app, and my harmony which integrates with smartthings can still control it fine…I am turning it off and on with the remote as we speak.

I have other leviton on/off switches that seem to be going on and offline as well, sometimes a hub reboot brings them back. And yet again other leviton switches and dimmers near by are still rock solid.

Can anyone help me figure out whats going? This is frustrating and just started after the recent update.

Which Levitown model number is it? Can you call the airgap switch? What does that do.

Thanks for the assistance, is there somewhere i can find the model number? This was from 2018, I guess id have to track down my amazon orders from 3 years ago, i dont see anything in the ide suggesting a model? Im also unsure what “call” the airgrap switch means?

I dont use smartthings for much, it is literally just to integrate a few lights and on/off devices into my harmony remote, thats about it.

I have seen a few historical threads suggesting updating the firmware fixed a similar issue, but it had been working great since 2018. My other switch nearby is on firmware 1.20, this one is on 1.13. But im not sure why after 3 years suddenly it keeps going offline.

Looked at my amazon records, looked like i purchased a few of these models.

Leviton DZ6HD-1BZ

I may have fixed it temporarily.

I noticed in IDE there was a long route for this light if i clicked on the device (I literally have other z wave lights and switches near by it). Although everything in the problematic dimmer lights route was showing online. However I also had another on/off plugin z wave switch near by showing offline.

It was not listed in the route oddly for my problematic dimmer, but i unplugged it and left it unplugged a few minutes so it had no power, and then plugged it back in. It came online and so did the lights…

But according to route, the problematic light was not using this z wave device in the route? Weird.

Nevermind, back offline again…

Frustrating.

So i turned it on manually on the switch itself and it seemed to come back online in the smartthings app again this time.

Then i turned it off in the smartthings app, and it worked, but the app cant turn it back on, keeps getting network error then trying to turn it back on.

Works fine using my harmony remote through smartthings though… and right now its still showing online so i can control it through google home.

This recent ios update and smartthings update has just made a mess for me.

The smartthings app also is reporting the status correctly (its off and it still thinks its on)…

I meant to say pulling the airgap switch. I have the same dimmers that you do. And if you pull out the little dimmer rocker on the right hand side, with a fingernail, and effectively resets the switch. It cuts electricity to the switch. I had to do that with mine other day.

I have a couple of those same dimmers that I purchased at about the same time. I had the same issue with them randomly falling offline.

Updating the firmware on the switch fixed the problem.

Search these forums for the dimmer model number and you’ll find details.