Legacy Z-Wave Devices and Hub Firmware 28.11

Which device handler are you using?
Was it reporting ever before? Have you just added the device before the hotfix was released?

I have a feeling that you might be seeing this and would benefit you to start using @RBoy’s DH, if you are not using it yet.

I have the traditional message started and finish without any problem.

I have tested with multiple device handler like Z-wave door lock with or without code. And Universal Enhanced Z-wave plus. Lock device from RBoy. Always same result for all device handler. Yes I tested before then after the hotfix by exclude/include the door lock.

Does it refresh when you hit a refresh in the App? Or is it still showing incorrectly? I mean when you manually unlock it and check the App, I guess you mean it doesn’t show it was unlocked, but does it show it unlocked if you hit a refresh?

So have you added this device just recently? When was it first? Was it ever reporting it correctly?

Yes last week of November worked 2or 3 days then stop working only for the manual lock/unlock. If I unlock or lock with the app I received the refresh but manually no…

If I hit the refresh nothing happens. If I test my lock with Wink, the lock works great and always refresh when I press button to lock or unlock directly on the door lock and reflect instant in the app. But I pair it with SmartThings then after that no more refresh for manual lock/unlock directly on the door lock.

Can you exclude and re-include the device again and then send hub logs from the IDE?

After you exclude and re-include the lock, navigate to https://graph-na04-useast2.api.smartthings.com/hub/list
Click on “View Utilities”
Under “Hub Commands” you should see “Send Hub Logs”
Click “Send” and let me know so I can check the logs

I sent the log :grinning:


Thank you!

I passed the logs along to our Z-Wave gurus.


Thanks and have a great new year :slightly_smiling_face:

1 Like

Alright, can you check the device is now working when you manually unlock or lock the device?

Same problem

I’m having this problem too. All of my SmartThings motion sensors, water sensors, and outlet plugs are no longer available and do not function. I’m on a SmartThings Hub v2 (2015) and on 28.12 firmware.

I tried restarting and powering my Hub a few times and then foolishly did a hardware reset and tried adding all the devices back. This was before I found this thread. Now all my devices are essentially bricked because they aren’t discoverable :frowning:

Is there an ETA on when a fix will be available? Days, weeks, months??

Can you tell more details what you have done so far, what devices you have and what is working. Your description is not clear, this topic was about a Z-Wave issue, but you are mentioning SmartThings sensors what are Zigbee. And when did all this happen?

any eta on a solution for Z-Wave devices not working via smartthings?

all my z-wave devices are extremely latent/not responding

only devices still working via Smartthings are my Wemo devices

I have Fibaro single switch 2, it is z-wave plus device but also impacted.
Signature cc:5E,86,72,59,73,22,56,32,71,98,7A sec:25,5A,85,70,8E,60,75,5B

I didn’t know about this problem and made reset to factory on my single switch, now I can turn it on but can’t turn off remotely since it always display “off” in both ST app ((

Already updated to latest firmware 28.12. Is there any way to fix it?

Does SmartThings fail to fail to report on/off state changes when you physically turn the switch on or off? If not, it is doubtful that this is the same issue. If you factory reset the device after the release of 28.12 (9 December 2019), you also would not be impacted.

It’s not fail, I can turn on it via ST app, but after refresh it will show state “off”. The same if I change switch status manual, ST app don’t show any errors, it works as usual but always show status “off”. I did it yesterday, at this time version 28.12 already was installed. So yes looks like it is the same problem and 28.12 firmware doesn’t resolve all issues

UPD: Looks like the problem is in Fibaro Single Switch 2 DH provided by ST app

I am having an issue with a few of my z-wave devices that have been online and working for years this week!

Two door locks using Rboy (@RBoy) universal device handler(s). One Kwikset, one Schlage. Both show being offline. Neither respond to commands to lock or unlock, yet both are providing instanteous updates to manual lock changes or code entries. I also have a GE (Jasco) outdoor plug that has worked flawlessly for years just not respond to commands anymore.

Any thoughts or ideas from the group? Is it just sit and wait? That’s crazy. None of my locks are working on any hub command anymore!!!


1 Like