Legacy Z-Wave Devices and Hub Firmware 28.11

UPDATE

A firmware update for Samsung SmartThings Hub 2018 and 2015 models was released to customers on Monday, December 9th. This release version (28.12) is a hotfix that includes a fix for pairing for certain Z-Wave devices.


On Monday, December 2, we released Hub firmware version 28.11 for the Samsung SmartThings Hub 2015 (Hub v2) and Samsung SmartThings Hub 2018 (Hub v3). Following this release we identified an issue where adding some legacy Z-Wave devices would result in these devices failing to report state changes. This could lead to inaccurate device states reported within SmartThings. Z-Wave Plus devices and devices added prior to the 28.11 Hub firmware update are unaffected.

We are working to release a firmware hotfix to address this issue. In the meantime, we encourage users to delay adding legacy Z-Wave devices that are not Z-Wave Plus until after the hotfix is released and to exclude impacted devices.

How do I know if I am impacted?
Starting Monday December 2, if you added a Z-Wave device which is not a Z-Wave Plus device, you may be impacted. Z-Wave Plus devices are newer devices and can usually be identified by a Z-Wave Plus logo on the box or the device itself which looks like:

z-wave-plus-vector-logo-xs

If you believe you recently added one of these devices, you can verify it is impacted by looking at the raw description on the device details page of the SmartThings IDE. Login at https://account.smartthings.com, click My Devices, and click on the device you recently added. Check the Raw Description and look for cc:. If you do not see “5E” listed but do see “85”, your device is impacted. We recommend removing/excluding the device until the hotfix is released.

In the below example, the Raw Description contains cc:20,25,86,80,85,72,71. Note that we do not see 5E but we do see 85 as part of the “cc” section. This is an example of a device that may fail to report state changes and will need to be excluded and re-added after the hub firmware hotfix.

What should I do if I am impacted?
We are actively working to release a hub firmware hotfix to alleviate the issue. We advise that you remove/exclude any impacted devices until the hotfix is released. For assistance in excluding devices, see How to exclude Z-Wave devices.

Regards,

The SmartThings Community Team

7 Likes

@Brad_ST any issues if the device is already paired and you update/change the DTH assigned via the IDE?

No, only if that particular type of Z-Wave device was included/added using 28.11

1 Like

How about a device with this signature?
zw:L type:1003 mfr:001D prod:1A02 model:0334 ver:0.05 zwv:3.52 lib:03 cc:25,27,2B,2C,72,86,91,77,73

Neither has 85 or 5E.

A device with that signature would not be impacted by this issue.

1 Like

I have two older Fibaro Wall plugs that i can no longer control.

zw:L type:1000 mfr:010F prod:0600 model:1000 ver:25.25 zwv:3.52 lib:03 cc:72,86,70,85,8E,25,73,32,31,7A ccOut:25,32,31

And

zw:L type:1000 mfr:010F prod:0600 model:1000 ver:25.25 zwv:3.52 lib:03 cc:72,86,70,85,8E,25,73,32,31,7A ccOut:25,32,31

This expalins why some of my Z-wave devices are only working 30-60 seconds after they are told to turn on or off in the last few days? Zigbee is all good, Z-wave Plus is fine, my locks (Z-wave) are fine but about a dozen of my original (3-5 year old) Z-Wave switches fail to turn on/off without a huge delay.
I await the fix, hopefully this is the answer.

It sounds like if they were paired before the last hub update, then they shouldn’t be affected.

2 Likes

Hopefully this is a side effect of the issue then. Awefully coincidental that it started the same time as the firmware update.
I had this same issue at the beginning of 2019 and it happened twice. It lasted for about 2 weeks each time and has been gone for 8 months. ST didn’t have any reason except to do a “Windows” - format and reinstall. I have over 125 devices so that wasn’t happening!
Fortunately, just before I was fed up with the issue and resigning myself to the prescribed fix, the problem went away and never came back until a few days ago.

Are they running local? It be some back-end cloud issues since you said it happened before and just went away on it’s own.

I also have a handful of legacy Z-wave switches (GE) that have the status stuck in an incorrect state. These have been paired for years but just recently got stuck. They run local, the local rules seem to work fine, and if I tap on/off in the device, it turns on…it’s just the incorrect status.

Are you sure this is only restricted to newly paired devices?

1 Like

Looks like the device actually shows OFFLINE in the IDE - maybe that’s a different issue that causes it to seemingly be unavailable for cloud control but still works locally?

Yeah, all the affected ones seem to be Online - LOCAL. They all use these DTH’s as well Z-Wave Dimmer Switch Generic or Z-Wave Switch.
Maybe I should try a different DTH for a laugh and see if one of the switches smartens up when I get home.

Yes, this only impacts devices that are not Z-Wave Plus and that were paired to a hub with 28.11 firmware. The firmware was released Monday so the device would need to be paired between Monday 12/2 (after your hub v2 or v3 updated to 28.11) and now.

Not sure if this is related, but the timing is suspect:

I’ve had some Schlage BE468 locks drop offline in the past 72 hours that are not wanting to come back online. I was able to fix two of them by excluding and setting up again. This is on the SmartThings WiFi hub to be specific. Normally they come back online after rebooting the hub and power cycling the lock.

With regard to devices showing as OFFLINE, I reported a similar issue elsewhere, before 12/2. I’ve had ST insist zwave devices were offline despite them reporting status and repsonding to controls totally normally. The only option was to exclude and reconnect them which was a real pain as some were quite remote. I suspect but haven’t proven it was because their status didn’t change for a long time, but once they were marked as offline nothing would change them back. I really hope that gets fixed.

Mine has been horrible since the update. I haven’t added anything in a long time and I have devices showing offline HUB_DISCONNECTED in the IDE but they respond to commands, rules, and report status. I have ran a repair that doesn’t help. The devices are also going “offline” randomly. I have noticed this across zigbee and zwave devices. Everything was good before the firmware update. The zigbee (iris) contacts show temperature even with it being “offline” so it seems to be effecting more than just newly paired zwave devices.

Try rebooting your hub from IDE

I fixed my offline issue - and without needing a hard exclude/include! I tried multiple repairs, and the “replace” button would never get past the “Getting device health” screen. So out of desperation, I just popped the air gap switch for about 15 seconds, then put it back in, turned the switch on, and refreshed in the app. Immediately, the issue was fixed. I went and did this for my other 5-6 switches, and they’re all back online now. This seems to have fixed general mesh issues and just about all of my lights now seem a lot snappier turning on via motion.

2 Likes

Worked for me for the couple of switches showing up as offline. Thanks for the solution!

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.