Legacy Z-Wave Devices and Hub Firmware 28.11

The hotfix for this firmware was released (28.12), ST has updated the first post.

However, as @jkp pointed out there’s another pending issue with the platform where unused device handlers can cause the pairing to not complete the device creation through due to a bug in the platform. You can find more details about it here: FAQ: My lock/device does not pair or appears to pair but it won't show up in the mobile app or IDE - stale DTH

This only impacts device handlers which haven’t been used in a while, so generally it’s good practice to remove unused handlers from the IDE and only keep those in use by devices.

4 Likes

My hub have the latest firmware 28.12 but my schlage FE599 wont refresh in the app when manually locked/unlocked. My lock have 85 in the Raw CC. Exclude/include factory reset the door lock… add repeater between hub and door lock… nothing worked.

Have you looked at this?

Yes already a zooz smart plug same like monoprice between hub and door lock. I have another door lock at the same place Schlage BE469 and no problem with this lock…and this lock is at 3 feets of my FE599.

When did you last run a zwave repair utility and what were the results?

Which device handler are you using?
Was it reporting ever before? Have you just added the device before the hotfix was released?

I have a feeling that you might be seeing this and would benefit you to start using @RBoy’s DH, if you are not using it yet.

I have the traditional message started and finish without any problem.

I have tested with multiple device handler like Z-wave door lock with or without code. And Universal Enhanced Z-wave plus. Lock device from RBoy. Always same result for all device handler. Yes I tested before then after the hotfix by exclude/include the door lock.

Does it refresh when you hit a refresh in the App? Or is it still showing incorrectly? I mean when you manually unlock it and check the App, I guess you mean it doesn’t show it was unlocked, but does it show it unlocked if you hit a refresh?

So have you added this device just recently? When was it first? Was it ever reporting it correctly?

Yes last week of November worked 2or 3 days then stop working only for the manual lock/unlock. If I unlock or lock with the app I received the refresh but manually no…

If I hit the refresh nothing happens. If I test my lock with Wink, the lock works great and always refresh when I press button to lock or unlock directly on the door lock and reflect instant in the app. But I pair it with SmartThings then after that no more refresh for manual lock/unlock directly on the door lock.

Can you exclude and re-include the device again and then send hub logs from the IDE?

After you exclude and re-include the lock, navigate to https://graph-na04-useast2.api.smartthings.com/hub/list
Click on “View Utilities”
Under “Hub Commands” you should see “Send Hub Logs”
Click “Send” and let me know so I can check the logs

I sent the log :grinning:

Thanks

Thank you!

I passed the logs along to our Z-Wave gurus.

2 Likes

Thanks and have a great new year :slightly_smiling_face:

1 Like

Alright, can you check the device is now working when you manually unlock or lock the device?

Same problem

I’m having this problem too. All of my SmartThings motion sensors, water sensors, and outlet plugs are no longer available and do not function. I’m on a SmartThings Hub v2 (2015) and on 28.12 firmware.

I tried restarting and powering my Hub a few times and then foolishly did a hardware reset and tried adding all the devices back. This was before I found this thread. Now all my devices are essentially bricked because they aren’t discoverable :frowning:

Is there an ETA on when a fix will be available? Days, weeks, months??

Can you tell more details what you have done so far, what devices you have and what is working. Your description is not clear, this topic was about a Z-Wave issue, but you are mentioning SmartThings sensors what are Zigbee. And when did all this happen?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.