LaMetric Time smart clock + SmartThings integration available


(LaMetric) #1

Hey, guys! We are happy to inform you that LaMetric Time now works with SmartThings.

LaMetric Time (http://lametric.com) is a standalone smart clock that can be used as a smart display for your smart home.

LaMetric team has already developed smart app and device handler for SmartThings. It allows displaying notifications on the device from your home sensor and appliances. The issue is that these apps are currently still under review and not accepted to the SmartThings store because they put on hold the process of new apps accepting. While waiting patiently we decided to publish the source code of the LaMetric Time handler and smart apps to our public GitHub repository.

If you are familiar with developing smart apps for SmartThings you can try LaMetric Time integration today. All you have to do is to create one device handler and two smart apps (LaMetric (Connect) and LaMetric Notifier), then copy/paste the source code. The source code is available here. LaMetric device API reference document is available here. For OAuth2 to work you have to create Notification App at http://developer.lametric.com. This will give you client_id and client_secret required for the device handler to work.

Please note that device handler and smart apps work with LaMetric firmware v1.6.0 or newer. Any feedbacks are appreciated! Thanks!


#2

Just wanted to say, I just got myself a LaMetric Time Clock and got it working as a notifier for smartthings, was easy to setup. I have to be honest unless there is another thread I am missing I thought this would be a big discussion and everyone would be involved and collaborating away. It really is great and makes a lot of sense with smartthings. A good price on Amazon at the moment as well.

Only had it a few days but it seems more reliable than my sonos’s as a notify speaker plus the added benefit of text. is there an app for the LaMetric to trigger a routine via the button or do we have to use iFTTT?

Anyway just wanted to say thanks for the integration with the included handler and smart apps. Its helped integrate the smart home to the family.


(Matthew Valeri) #3

I never knew there was “official” integration… but as I’ve said in another thread, cost is an issue. $199 ($179 sale at the time of this writing) is too much for me to justify for this product.

I like the idea of the product and hope it succeeds.


(John Crighton) #4

I’m trying to get the integration working here, I think I’m probably doing something stupid, or it’s not quite as easy as first appears.

I’ve created the DH and smartapps, published all for myself.

If I then try to run LaMetric (Connect) it says “Something’s wrong - we can’t load your screen right now”

I have created a notification app on the LaMetric end and have a key/secret, but can’t see anywhere on the ST end to put that.

Any pointers would be welcome.

Thanks!

John.


(John Crighton) #5

I get this in the logs when I try to run the smartapp:

java.lang.RuntimeException: Unexpected status code 400 from global /clients/null with status text @ line 403

Line 403:
state.accessToken = createAccessToken()


#6

in the uk at the moment and picked one up on Amazon for £129 which is in my opinion if i take something like a Sonos Play:1 at £199 here it provides just as much (not high end audio though)


#7

Hi John,

I had this, did you enable OAuth for the app? as it doesn’t mention this if I remember.


(John Crighton) #8

Thanks, that helped a little. I now get a logon screen for LaMetric.

However logging on gives me a 404 - app not found. The next step doesn’t appear obvious, so if you can help please let me know. I’ll tinker in the meantime and see if I can make it work.

Thanks again,

John.


#9

that rings a bell too. I think I had forgot to actually hit publish, then had to wait till LaMetric actually published it i.e. received email saying its published


#10

One other issue I had is that when using the connect app, it found the clock but was unselcting it before I hit done. Not sure what was going on behind the scenes as I didn’t investigate but if I was quick enough it selected it


(John Crighton) #11

Hmm… you mean you had to publish the notification app on the LaMetric site?

I can’t find a place to do that. I don’t have any publication e-mail from LaMetric either.

I can only see that the app is active, and I can see the keys (and have the option to reset/revoke).


#12

sorry I may of misled you there, I was setting up the sonos track now playing smart app in smartthings which required a indicator app all at the same time and that needed to be published but youre right indicator apps dont need to be published, I was was doing this all too quickly and not paying too much attention.

The second issue I mentioned above was an issue though, that being the clock was discovered, I would select it and then click next but it had already unselected, the only way round was to do it really quickly.


(John Crighton) #13

Thanks, it sounds like perhaps I need to do both (I have a Sonos so would probably do this anyway).

I’ll give that a go later.


#14

I am pretty sure you don’t as I had the notification working before the Sonos track display.

When using the LaMetric (Connect) app, does it find your clock?

I am pretty sure I had the 404 issue when trying to add my clock int but that is was the issue I was on about where by it wouldnt select the clock. Is it listed as a device in your devices and does it have a network address? (should be serial number plus a few more numbers)


(John Crighton) #15

I’ve not added it as a thing. I did have a look for new things but it wasn’t there. I felt like trying to add it manually probably wasn’t the right direction to head in.

Should I be adding the clock first? Do you need to do anything to initiate contact with ST (e.g. hold a button down or something)?

Thanks for your help so far, much appreciated. I’ll tag in @smartatoms too so they can read this (and respond if they like).

John.


#16

You are right you shouldn’t have to add it manually, I was checking to see if it was already added and if so correctly.

Using the LaMetric connect smart app it should search the local network and discover it providing its on the same subnet, no button needed just discovery protocols at play. Normally takes a minute or so but can take up to 5. Then it should be available for selection. Does it appear when using the connect smart app?


(John Crighton) #17

No, when I run the ‘connect’ app, it mentions I need to scroll to the bottom of the second page and ‘allow’.

If I run the smart app and enter my LaMetric credentials, that’s when I’m given the 404 (app does not exist).


(Dan Shepherd) #18

I’m getting the same 404 error, app doesn’t exist. I put the correct app ID into the groovy file too.


#19

hmmm i honestly don’t remember now. But I did have to enter the client ID and secret of your notify app if I remember from the IDE. I’ll see if I can remove it all and do it again when I get a moment


#20

I have had a look and its rung a few bells. Did you guys both enable and add the client id and client secret in the settings for the connect smart app