Kwikset zwave lock no longer responds to app, stopped logging events

after working fine for months now my Kwiskset zwave lock no longer responds with the app. i can’t lock or unlock with the app and events are not being logged for the lock in the app. however, the lock still unlocks each day with automations for arrival when my wife or I arrive home.

not sure what to try or do any ideas?

i tried doing a Zwave network heal but that didn’t seem to help. Now i have another problem as some of my zwave dimmers for some reason the status light is flashing as if they aren’t connected to the zwave network, but they are connected and still function with smartthings. now i have no idea how to get that light to stop flashing aside from removing the device and adding it again

I’m having similar issues with my Yale lock. Lock still reports lock/unlock events through IFTTT and statuses through the app but no longer responds to in-app or automation instructions.

I am having the same issue with my monoprice lock…

Tried to remove the lock from the app but didn’t work. Ended up removing it from the web but kept having trouble telling the lock to leave the network so couldn’t initiate a re-join either.

Might be related to the recent general outage. Will keep trying.

I ended up solving my problem by changing the batteries. i have no idea how or why but smarthings drains my kwikset lock battery so quickly its completely different from my Vera i previously owned. the batteries were fully charged not even a month ago and as of last week were at 60% - not to mention the battery led on the kwikset was never blinking.

i have no idea how or why but it is back to normal now after changing the batteries.

EDIT - nope still not fixed. now today it is doing the exact same thing except it doesn’t respond to automations either.

if i go and remove the batteries and then put them back in it works. any idea what the problem could be?

i followed your suggestion and replaced my batteries and was able to leave and rejoin the network then reconfigure everything. i also did a master reset of the lock during the network outage when i was unable to leave the network but i’m now thinking the step might not be necessary. Try replacing or re-adding the device without a master reset let us know if it worked. I also had to reboot the hub and repair the network in order to solidify the communication.