Kwikset Deadbolt Problems


(Classic) #1

Anyone else having problems with this? Spent quite a bit of time playing with it last night and talking with Ryan in support. I installed it easy enough, but it doesn’t want to play nice with SmartThings. Right away I couldn’t get it to pair and had to get Ryan to send an exclude command to the lock. This was a brand new lock just out of the package. Once he did that, I got it to pair ok. Most of the time the lock and unlock commands work from the SmartThings app but the status doesn’t change on the app. Can’t tell if its locked or unlocked in the app. Thought I had it working last night. It was working great actually. Now it’s back to not reporting. Sometimes it doesn’t want to lock and unlock from app either. Side note - would be nice if lock and unlock buttons responded when pressed in app (by lighting up temporarily), so you were sure they were pressed. Removed and reinstalled battery pack and daughter card. No luck. Though this seems to help when lock and unlock stops responding. Also, when I paired the lock to app  LED was red… Never turned yellow like in instructions. Another note on app - would be nice if on main menu if you poked tile it would respond with opposite state. So if it showed locked and you poked it, it would unlock instead of having to go into gear area to get functions.

Any and all help would be greatly appreciate!

last note - this forum/site does not seem iPhone friendly…


(Formix) #2

This is a HUGE concern.  Your coffee pot doesn’t start, no big deal.  As soon as you are responsible for somebody’s house being secure, that’s a whole other thing.


(Bradthawley) #3

I had the exact same problems.  It worked, then was sporadic: locked, but then didn’t unlike or visa versa.  Also, the iOS app doesn’t easily or clearly show if its been locked or not (an easy fix, and I assume the smartthings developers are working to fix that with an update soon).

Since it didn’t seem to be working properly, I tried to remove the deadbolt from the smartthings app hoping i could “re-add” it. However, now that I removed it, it is no longer recognizable by smartthings.  To be fair, I got a warning when i deleted the deadbolt from my things that read “warning, this cannot be undone”.  Gues they were right.

I tried resetting the deadbolt via battery removal and hitting the set button three times.  Then went through the same system set-up that worked last time by pressing “button B”, to set it to recognizable mode. Yet it is still not recognizable for some reason.  Anyone have experience with this?  How can i “re-add” this device once it’s been removed?

 


(Classic) #4

I learned the hard way about deleting/unpairing devices. With my moisture sensor especially and my lock. When you delete an item from your SmartThings, you have 15 seconds to push the unpair/exclude button on your device. At least that’s what I was told. In practice, it’s more like you have to push the button immediately, or even hold it down when you hit the ok to delete button on the app tile. If you don’t the item still thinks its paired to SmartThings, and since SmartThings no longer thinks its connected, you are stuck. So, what needs to be done is you have to re-send the exclude signal to the hub/device. If you have access to the IDE you can send the exclude signal yourself. If not, you need to get on CHAT with SmartThings customer support and they can send the signal for you and then you push the button on the device and you are good to re-pair it. Hope this helps. It’s a big pain in the butt. I believe they are going to include something in the app to deal with this in the future.


(Classic) #5

Ps… I contacted Kwikset customer service and they gave me some steps to try so that the Lock was correctly reporting it’s true state (locked or unlocked), but it didn’t make a difference. I am pretty sure it’s on the SmartThings side and not the lock side…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #6

@Classic : Thanks for the hints regarding remove/add of things.

I presume “Support” spends some time browsing these Forums for issues like this; and/or are being active in building the Knowledge Base pages (along with good search / index terms).

 

I just got a replacement Hub and had to add devices back in … and did not know the procedure, but guessed.


(FactoryOptimizr) #7

I find that pressing the “Refresh” button on the detail screen pretty accurately gets the state of the lock if there’s any question. However, I’ve found that the app’s lock state is NOT updated if you manually lock or unlock the deadbolt from the inside knob. Clicking the “Refresh” button correctly updates the state in this case, but that means that in order to really determine the state of the lock you ALWAYS have to press the “Refresh” button first. Ack! Has anyone else seen the same thing? Anyone know if there’s a solution for this?


(Cory S) #8

Dan, I’m not sure if there would be a solution to that. Pressing refresh queries the lock for its state, if it were to be programmed that to do it too often it would run the battery down.

I think the lock should be programmed to automatically announce its state whenever it is manually changed, but that’s on them.


(Classic) #9

Unfortunately this has not been my experience. I can lock and unlock the door fairly consistently but hitting refresh does not cause the status to change on my smartthings app. Always says unlock no matter what states it’s actually in. This is very important to me to get working.


(Bubba) #10

I also have issues with my Kwikset 910CNT Zwave deadbolt. It’s new out the box and after I installed on my door, I tried pairing it with the HUB by pressing the B button on the Kwikset for over 2 minutes. Had no luck after trying about 4-5 times, each time in Searching… Mode on the iOS app. The Hub works with the Multi and Motion units fine.

Any help here is appreciated. A bit frustrated since I got SmartThings to help with the lock/unlock of my deadbolt.

Thanks


(Jay) #11

@Classic how far is the hub from lock? it could be a range issue (remember Z-Wave range is less than Zigbee), can you test with the Hub closer to the lock? Also, I read somewhere that someone had a problem with the lock never reporting “locked state” turns out that the lock part doesn’t go all the way into the hole as it should, so the lock still thinks it’s unlocked (are you sure it goes in all the way?)

@Bubba I suggest contacting support, you may need to unpair the lock first, then pair. The UI doesn’t have unpair functionality yet


(Classic) #12

My Hub is less than twenty feet from my lock. That’s not the issue.

Yes, lock goes all the way. If you follow the instructions when you install the lock, you actually had the door open when you boot it up which sets the lock direction etc… The lock doesn’t know if the door if opened or closed. It’s pretty easy to test with the door open. Status should still change - locked or unlocked… It does not.

I have tried everything, on my own and with support from both quikset and smartthings… Nothing has fixed it yet.


(Coolcatiger) #13

I installed 2 kwiksets. To pair locks I first kept them next to the HUB for setup. Once setup was complete I installed it on door. Hope this helps.


(Marshall Stringfield) #14

I am also having problems pairing my z-wave kwikset lock to the hub.
My process:
Open the app to “add device mode”, Remove battery from deadbolt, push the program button three times, reinstall battery back, push the “b” button in the top left. Light near “b” button turns red for a few seconds (not yellow like instructions say) but nothing else happens.
I have the hub within 10’ with a clear line of sight to the lock.

Any help?


(Coolcatiger) #15

Try to put hub within inches of lock while pairing. It worked for me.
You might need to contact support to send un-enroll command first.


(Jim L) #16

I contacted smartthings about the state issue. It is an issue in that the locks do not report a change in state when they are manually changed. And I don’t know for sure but I believe that the smartthings hub is not issuing the command to lock if it believes the state of the lock is “locked” and vise versa.

I wrote an app that I believe gets around this problem. By default, the lock device class do not have a .refresh() method that you can programmatically call prior to any command execution. However, the locks are instances of the Refresh devices class. Therefore, my app allows you to pick a “Refresh” device and issue the .refresh() prior to running a command. I believe this resolves the issue. Here is my code if anyone is interested.

preferences {
	section("When a presence sensor arrives or departs this location..") {
		input "presence", "capability.presenceSensor", title: "Which sensor?", multiple:true
	}
/*	section("Select locks") {
		input "lock1", "capability.lock", multiple: true
	}*/
    section("Select locks"){
    	input "refresh1","capability.refresh", multiple: true
    }
}

def installed() {
	subscribe(presence, "presence", presenceHandler)
}

def updated() {
	unsubscribe()
	subscribe(presence, "presence", presenceHandler)
}

def presenceHandler(evt) {
	log.debug refresh1?.lock
    refresh1.refresh()
	if (evt.value == "present") {
		log.debug "${presence.label ?: presence.name} has arrived at the ${location}"
    	refresh1.unlock()
	} else if (evt.value == "not present") {
		log.debug "${presence.label ?: presence.name} has left the ${location}"
        refresh1.lock()
	}
    refresh1.refresh()
    log.debug refresh1?.lock
}

(Cory S) #17

I asked this in the other thread you posted this in, but have you noticed if the causes more of a delay in executing the action than the preinstalled app? One of my issues is sometimes it takes about 20 seconds too long to unlock while I’m waiting at the door.


(Jim L) #18

It really depends, I haven’t really noticed a delay but I fully believe it is dependent on how far your hub is from where your presence device is when you show up at home.

For me, I drive into my garage and my hub is maybe 30-40 feet from my presence tag when I pull my car into the garage. I typically grab my work bag out of my car and I walk to the door. I typically hear my deadbolt unlock right when I close my car door when getting my work bag.

So I would say about 15-20 seconds after arriving in my garage. If I rushed, I could absolutely be standing at my door waiting for it to unlock.

However, I would argue that the time it takes to do a refresh isn’t the long poll in the tent. I think it takes maybe 3-4 seconds to do the refresh (I have no data to support this). The biggest delay will be the detection of the presence device. I would be really interested in knowing exactly how the presence device works. I know it is zigbee device but is the hub polling every 10/20/30/X seconds for the device?

I haven’t done much with testing presence with my cell phone because my cell phone is android. I prefer not to make my wife the tester with her iPhone. I just want it to “work” for her so the zigbee presence tags are used on our keychains.


(Cory S) #19

@Jim, Your situation seems to mirror mine for the most part. However, it’s every now and then it will take significantly longer than normal. I think the key is what you mentioned on how the presence sensor works. Sometimes I can be standing at my door testing how long it will take, pull up the app, and notice it still hasn’t detected me, sometimes up to several minutes. That is an exception not the rule, usually it seems me as I pull up into the driveway, but consistency lends towards higher WAFs (Wife Acceptance Factor).

It would be nice though to know what causes the random delays. It could be any number of things like more noise in the air at that moment, or even something like SmartThings servers being backlogged. I have noticed lots of performance variations throughout all my things which lends me to think a lot of changes are being made on the backend. As an example, the Schlage door lock use to take 30 seconds to receive a command, now takes exactly 4. However, the app also started crashing soon after that change happened when locking/unlocking the door.

Anyways, I just installed your app and when my wife left to go to the store the door locked at the exact moment I got the notification she had left, which is about inline with how the default app worked, so lets see how it does when she gets home in a few.


(Jim L) #20

As far as detecting when I leave, it has been pretty consistent for me. I get about 1/2 a mile from my house when all my doors lock. For me, it coincides with a gas station that is on the way to work.

I have yet to experience “minutes” to unlock. My biggest concern is the cloud aspect because I mentioned in another thread that an internet connection is required for the smartthings hub to work at all. For instance, last week, Comcast went down for my entire metro area (Charleston,SC). It was down for over 12 hours. While comcast being down isn’t smartthings fault, having everything execute from the cloud is problematic with the current implementation. When comcast finally got back up and running (12am), my smartthings hub executed every command that had been queueing up for the day. What that ultimately meant was that certain doors unlocked in the middle of the night. I am hoping that they can add a timeout value to commands because there is little value to executing commands 12 hours after they were issued.