Kwikset 914 Deadbolt not reporting battery status correctly after a couple days

Issues with battery reporting on a deadbolt lock.

I have 1 Kwikset 910 and 2 914 zwave plus dead bolts.

They all work fine but one of my 914’s.

One of my 914’s unlocks and locks with no issues.
But it does not report the battery correctly and it causes my kwikset to stop working after 2-4 days.

Things I’ve done to test it out:

I switched batteries with one of the other units. It still eventually reported wrong and the other unit works fine. So I know its not the batteries.

I removed the device and did a factory hard reset on the lock.
I ran it for 4 days without connecting it to the ST device and it worked fine.

I connected it to the ST and after a day the battery went from 70% to 20 than 10 and eventually it quits working.

Also this device is closer to the ST Hub and other zwave repeaters.
And I have ran a Zwave repair with no errors.

So I’m at a loss as to what is happening.
And I have sent in an email to support also.

So I got a response from support…

The asked me to run a z-wave repair and to report any errors…

As I stated in my original message, I already tried the repair.

But I followed the motions and ran it again and again…

No change.
I sent an update to support and we’ll see what else they ask me to try…

Swap the Z-Wave module between the 914’s and see if the problem remains. That will tell if the z-wave module is the issue or the lock itself is the issue.

1 Like

Rboy,

Thanks for the idea. I switched the modules and did a z-wave repair.

But the lock still reported batteries drained after about 12-20 hours… So its not the module…

ST Support has replied back twice… But each time they give me something to do they reference battery draining and that’s not my issue…

And I don’t think kwikset will do anything. Because I reset the lock and let it go for 3-4 days without connecting it to ST. It never reported the battery as drained and locked and unlocked with no problems…

This is a weird one…

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.