June 2019: August Pro Z-Wave commands fail if August app is not in use (previously worked fine)

I woudn’t have to be an August employee to do this?

No we just want this issue to get addressed and reported so that the Development team can assess the situation.

Ok, ticket opened. I gave them my August support ticket reference # as well.

What is the difference between submitting a ticket at Samsung Developer Support and SmartThings Support?

1 Like

The difference between Developer Support and SmartThings support is that SmartThings support gives support to the final user and Developer support trouble shoots the code and issues to find solutions for the final users

So Dev support would be when it’s a platform issue that cannot be resolved for an individual customer without changes made by SmartThings staff or a SmartThings developer partner?

1 Like

Sorry for the delayed response, but, yes you are correct they can escalate a situation if need be to have those changes fixed or looked at.

If a user could @ me/PM me whenever this issue happens, I can take a look at the Radio logs to verify the functionality on our end.

@Kianoosh_Karami I am in a spot where I can help troubleshoot this. I haven’t used my lock in a couple hours, so the issue is occuring right now.


Sent you a dm.

Trying to lock right now and it fails!


Can you see? Unable to lock lock!

I was finally able to reproduce this and sent Kianoosh the logs. Hopefully an update from that soon.

@RBoy, per you recommendation from one of the threads I bough Monoprice zwave switch/repeater hoping it would help but seems that August smart lock talk directly to my smarthings hub and not via the repeater. Do you know how I can check and set the repeater and the lock to work together? Thank you.

I have August firmware 1.59.0-1.13.2, and am seeing this issue exactly as described by others:

  • Used to work reliably, became flaky several months ago…
  • Is temporarily fixed by manually unlocking (via a hand twisting the lock open/closed, or by using the august app), but then reverts to its flaky behavior a few hours later.
  • etc…

I’ve tried all the suggestions here

  • Rebooting the ST hub.
  • Removing the lock from the zwave network and then re-adding it.
  • Adding a repeater
  • etc…

I have not tried replacing the battery (today), but August shows no battery warning, and ST shows 100% (Once this evening it showed 89% but never lower than that)… I think I changed the battery about a month ago when the flakiness began, hoping it would help (It did not).

If there is a way to use my current setup for debugging that would help… please let me know.
I am home, highly motivated to get this fixed, and willing to try just about anything.

So… here is an interesting observation:

I have 2 August Pro smart locks. I purchased them as a pair at the same time. (They’re probably from the same manufacturing lot, I would bet). They both have the same firmware version (1.59.0-1.13.2) and are connected to the same ST hub. One is “Front Door” and one is “Back Door”.

Back Door has this issue right now, Front Door does not.

The only differences I can think of are

  • Back Door is used a lot more via automation. (E.g., ST routines that unlock when someone comes home, etc…). Front Door is much less active in general. We usually only open Front Door manually (hand-twist)… but occasionally via keypad.
  • I changed the batteries in Front Door about 2 weeks ago. Back Door was probably changed a month ago or so.
  • The ST Hub is physically closer to Back Door (about 5 feet) than the Front Door (about 40 feet or so)

Based on some comments I saw on this (and another similar) thread, It might be an issue that only manifests when the battery is almost-full, and does not repro with fresh batteries? Or maybe the act of changing the batteries power-cycles the lock, and it is an issue that only shows up after a while being on?

I’m hesitant to change the Back Door Batteries right now. On the one hand, it might fix my issue for a short time… but on the other hand it might prevent me from gathering useful debug info. :-/


Assuming that you have a Z-Wave stick and utilities to see the routing table for each device, that the only way to confirm for sure that the lock is connecting to the repeater directly. The way most folks do it to simply move the hub away from the lock say 75 to 100 ft, put the repeater closer to the lock say 20ft, reboot the hub and do a Z-Wave repair.

However, after seeing all the comments on this topic and especially given the fact that the lock seems to work just fine after it’s woken up (e.g. manually lock it or activated from the August app), it sounds like it may be a lock firmware issue that has some role to play in it. That is very unusual behavior. You may need more sophisticated Z-Wave tools and sniffers to see what’s going on here.

Out of curiosity, do either of these devices have the connect or keypad paired to them?

Mine does have a Connect paired.

Both devices have a keypad.
Neither device has a connect.

I’m having the same problem. I had been using the lock with smartthings in “I’m Back” routing and it worked pretty well but recently it just stopped working. The routing goes off and the log shows that it unlocked the lock but it actually doesn’t. My lock has a connect that is only a couple of feet from both the lock and the hub. The lock seems to work when I try to lock or unlock it from smartthings manually but the “I’m Back” routine does everything else except actually unlocking the lock.