Trouble with August Z-Wave

I recently bought a second August Smart Lock Pro (without a connect). My first Pro has the connect. I’m trying to connect to my Smartthings hub via Z-wave, but every time I go through the installation process, my app freezes at 80%. The lock says it’s connected to my Smartthings hub, but the hub can’t install the software to make it work. Any suggestions on how to remedy the situation? Thanks!

I had this issue the other day too!

I ended up force removing the z-wave connection from the lock, despite its warnings. Then I pulled out a second phone with the ST newApp and used that to put the hub in learn mode while my original phone set up the lock’s z-wave again. Worked flawlessly, it was just a hassle.


I would also recommend checking if the August Lock has the most up to date firmware. I’ve had trouble with their older versions in the past.

Current August Versions

Updating Lock Firmware

1 Like

also try deleting any custom dth for it if you have one.

That did the trick, thank you!

1 Like

You’re welcome! I’m glad it worked!

I know their support is generally unhelpful. If your doorsense ever stops working but the app thinks that it is, come on back to me haha