June 2019: August Pro Z-Wave commands fail if August app is not in use (previously worked fine)

Within the last month August released a firmware update for their locks. Since then I’ve noticed a strange issue. If I have the August app open on my phone, reboot the lock, or have recently manually unlocked it, for a few minutes after doing so I am able to send commands from the SmartThings app or automations I’ve set up (such as using a zigbee button to send lock or unlock commands) and those commands succeed.

If however, the August locks sit idle for longer than that, and I go to perform a command with SmartThings over ZWave, the commands fail. Either the commands just appear to time out with no feedback, or the app updates and shows the lock in its previous state. For example I click Unlock, the status changes to “unlocking” then pops back to locked.

I’ve looked in the SmartThings live log within the IDE and I’m seeing a token error when this happens. I’m reasonably sure this is an issue with the August lock and I’ve reached out to them. So far they seem stumped. I also think it’s their problem because I have other Schlage ZWave locks and they have continued to perform without issue on the same hub.

For background info I have a V2 hub running 25.x firmware. The August locks have been working without issue for over a year prior to this. As troubleshooting I’ve removed both ZWave locks, powered them and the hub off (locks for a few seconds, hub for 5 minutes), then powered on the hub and paired them again. The locks have been in the same location they’ve always been and I have a few ZWave repeaters to ensure good coverage. No other ZWave device in my system behaves like this.

And one last detail: these locks use S2 security but will revert to S0 for older devices like my hub. I see messages indicating that happens but I’m wondering if the August is properly staying in S0 mode and maybe that’s why it’s rejecting commands. The August app itself always controls the locks fine.


I have firmware 1.59.0-1.13.2 and have not seen this issue. (Just tested unlock and it worked fine from ST; it has been at least 18 hours since i used the August app)

Have you tried replacing batteries? I have noticed issues with z wave when the batteries start to run low (and the z wave battery reporting is not very accurate).

Thanks for mentioning that. I forgot to add that I did replace the batteries a couple times. The first time I did it I went with Energizer lithium batteries and figured that was a problem because August says to use alkaline. So I swapped them with new alkaline batteries, but the issue was not fixed. And I just confirmed I am running the same firmware version you are.

How repeatable is this (is it consistent or intermittent)? Is z wave repair showing any errors?
It could be that one of your repeaters it’s having problems.

I’ve tried a few repair ops before but I’ll try one now. I do sometimes get errors with one repeater when I do repairs. Would a repeater problem also affect status data? I can see changes in state of these locks when I unlock it outside of the smartthings app, it’s only commands to lock or unlock that fail.

There are other community members who have been reporting this problem for about a month, but it’s not all August owners and no one has been able to figure out what’s going on. :scream:

Definitely report it to support. The more people who report having a problem, the more resources they will assign to investigating it.


@rboy , I don’t know if you’re getting many reports of this, but at this point there have been at least four people in the forum reporting that they had an August lock that had been working just fine for some time and now is unreliable. So I don’t think it has anything to do with repeaters or batteries, it appears to be something in the Z wave implementation. Or the August firmware. But since it’s not affecting everyone with an August lock, I’m not sure what’s going on.


Thank you! For some reason this didn’t show up in my search. I’m forwarding this to the support team now. I asked just this morning if other people are hitting it.

In the meantime I did do a removal of the problematic repeater from my system. I’ll see if anything changes, but it’s good to know it’s not just my system.

1 Like

First rule of smartthings: it’s never just you. :wink:


Barring the odd incident and the platform issue/slow mesh two days ago.

There could be a bunch of things to rule out:

  1. With the recent firmware update there may be settings or z-wave firmware updates which may be affecting the way it interacts with the mesh, particularly the wake up internal. If the firmware claims to improve battery life, I suspect they may have changed the default wake up interval (it’s typically every 100ms to 300ms) and reduced it. While this in itself may not be bad, it depends on the chipset and the mesh. If the interval isn’t timed properly or it does doesn’t wake up for long enough it may miss the events.
  2. Coming to the repeater, this may actually be the case where having the repeater helps, since if the lock is delaying the wake up timing, then there needs to be something to hold the messages. If the timing is off or isn’t waking for up long enough then it’s possible the repeater may not help, but the best way to rule it out is to add a reliable repeater close to the lock and do a Z-Wave repair and see if it makes any difference.

I’ve seen a couple of folks report that this issue only happens after the lock does to “sleep”, and when it awoken using the August app it starts responding again. I would suspect that August either has a bug which is turning off the Z-wave chip or it’s playing with the interval timing which may be messing with the mesh communication.

1 Like

August support just emailed me and said that no one else has reached out to them. That either means this one support rep is unaware of it, is hiding that information, or no one has actually contacted them. For anyone here who has not done so, please email august support and let them know that you’re seeing this issue.


Do you have contact info or a case number we can reference? Be glad to do so

1 Like

Their support email is just support@august.com. They do actually have phone support 1 (844) 284-8781.

They haven’t given me a reference number for the bug they have open. I’ll see if I have a support team reference number. What I would do is reference this post. As I’ve used the same link in my correspondence with them.

And thanks!

1 Like

OK, I just emailed the support address with some details and links to these two threads. Let’s get some more folks sending those tickets in!


I submitted a ticket in reference to this post. Between the battery reporting issue (which they told me wasn’t them) and slow to respond through zwave commands it is sad.

I started having the exact same issue recently, so I also submitted a ticket referencing this post. Thanks for detailing this issue so well!


Are those of you that are having problems all using the stock dth, or are you using a custom dth?

I’ve tried the default (Z-Wave Lock). I’ve also tried the z wave lock with codes, z wave lock without codes, and rboy’s custom DTH. All behave the same.

1 Like

I’ve tried both the default DTH and rboy’s DTH and ran into the same issue.

1 Like

I reported the issue to both August support a couple weeks ago and smartthings support last week. August blamed it on ST. ST is giving a bunch of suggestions that don’t do anything to fix the problem

If this issue is still ongoing, I recommend you open a ticket to SmartThings Developer Support so this issue can be reported and fixed or escalated to the proper team.