Jerky fades with dimmers (using "fade to level" in core)


#1

The scenario is:

Porch light defaults at 15% and turns on automatically at dusk.
If someone approaches the porch, the motion sensor fades the light to 100%.
If there’s no motion after 4 minutes (default reset time), the light fades from 100% back to 15%.

It works, but the “fade” is not as expected. Instead of a smooth fade, it does 3 stairstepped levels. Which function in CoRE will do a smooth fade?


[DEPRECATED Thread: visit community.webcore.co for assistance] webCoRE - Piston Design Help (ask your fellow members for assistance)
(Pizzinini) #2

It may be easiest to adjust the parameter for dim speed in the switch itself. I have done this on my GE dimmers with this “hack”. Its not straight forward and takes some tinkering but it works…


#3

Thanks, but I don’t think this addresses what I’m experiencing. In CoRE, automating the “fade to level” doesn’t appear to do any ramping whatsoever. It jumps from level-to-level one second at a time.

For example, in my piston above, it will jump from 15% for second#1 to ~60% for second#2, then 100% for the final jump.


(Robin) #4

Your problem is the short duration (3s)… when fading to a level, CoRE has to send a command for every step. In an ideal world you would want the step size to be smooth (1% steps) but that would require 85 commands to go from 15% to 100%… never going to happen in 3 seconds on a mesh network!

CoRE looks at the duration and calculates the step size based on what is practical, so with your example it’s trying one command a second giving you 3 large steps.

The fade command in CoRE is intended for slow fades, for example fading up over 15 minutes to gently wake you in the morning.

The hardware method noted above is the only realistic way to achieve what you want, unless you increase the duration.


#5

Apparently this is not an issue with an older firmware version (3.0D). That version does indeed ramp when receiving level commands from CoRE. Newer firmware (3.0E) does not ramp, which I assume I have without removing the switch to look on the back.

I’m going to play around with Enhanced Dimmer Switch and see if anything can be done there. Also waiting for sunset to try “Smart Porch Light”, a SmartApp by a user here.

Rumor has it Gen5 (Z+) dimmers do ramping between levels, maybe someone can confirm.


(Robin) #6

Give webCoRE a try as well… I know @ady624 mentioned something about improving the calculation method for step size.

I can’t see device firmware changing what commands CoRE sends… CoRE just sees a dimmer switch and nothing else so wouldn’t change behaviour to suit device manufacturer or firmware.

What specific device are you using?

Like noted above, many devices have parameter settings for step size and interval.

The Fibaro dimmers I use have these settings which are customisable to the millisecond:


(Pizzinini) #7

Just remembered… Try this DTH. It works without tinkering. You only have to use it for configuring the parameters, then you can switch back to your original DTH:


#8

I’m using a GE 12724 Dimmer, and a Monoprice motion sensor. The Fibaro dimmer probably won’t fit in my box, especially behind a paddle. (old house) But wow, Fibaro really got it right there. They must be listening to us.

@pizzinini Enhanced Dimmer Switch can’t quite do it either. I’ve used this in the past to remove the dimming effect, but what I want here is to add it when changing levels. It looks like the ramp effect in my dimmer only engages when turning the switch on or off. It does not ramp when setting a level via software, meaning changing the stepsize and duration will have no effect there.


(Travis Muszynski) #9

Any updates? I struggling with the same thing in my theater room.


(Robin) #10

If your fading over a short period then there’s nothing that be can changed… one command a second is as good as it gets so % divided by seconds is your step size.


(Travis Muszynski) #11

Ok, so is there any advantage to just changing it to “set to level” in core and changing it in the device handler? Would this allow a smooth fading transition?


(Robin) #12

Wouldn’t make a difference… you can still only send one command a second.

If the device has built in fade parameters (hardware) then that is the way to go.


#13

Yes, we are confined to the hardware limitations of the device.


(Travis Muszynski) #14

Ok, so the best option is to increase duration?


(Robin) #15

yes.

Longer duration = less judder


(Travis Muszynski) #16

I’m still having issues with my GE dimmers. Are there any good decora style dimmers that fade properly right out of the box with core?


#17

The Fibaro dimmers can I think. Haven’t tried them myself.


(Travis Muszynski) #18

What about the Leviton DZ6HD-1BZ? Does anyone have any experience trying to create smooth automation transitions with this dimmer?


(Robin) #19

It’s not about fading properly with CoRE… as I’ve said above, CoRE takes the time given divided by % difference required, and that becomes your step size, so a large % change over a short time will be big, juddery steps.

The Fibaros do indeed have a built in fade setting which is very smooth, but it’s part of the parameter settings not a straight command that can be sent.

So if you want it to fade slowly always, Fibaros will work nicely, but if you only want t to fade slowly at certain times and turn on/off quickly at other times, it won’t be ideal.

There is however a way to send parameter settings to a Fibaro via CoRE, so in theory you could do this:

Set parameter to x speed fade
Wait 5 seconds (to allow parameter to take hold)
Set level to x
Wait x minutes (for fade to complete)
Set parameter to Normal speed fade

Clunky and probably unreliable but might work!!


(Travis Muszynski) #20

I’m fine with it always fading at the same rate. I guess I was wondering if there were any other dimmers that allow the fading to be handled on the hardware side so I can just us “set level” in core. I’ll take a look at the Fibaro. Thank you.