GE 12729 Dimmer fade when issued a set level command


(Greg) #1

When you issue an on or off command to these devices they fade on/off. I’m looking for a way to have these dimmers fade to level when issued a set level command - I’m pretty sure I’ve seen on here where someone changed the DTH to allow something like this, but I can’t find it and search isn’t much help.

I’ve tried the fade options in CoRE, but they either don’t work or produce a stepped fade effect instead of a transition. Is anyone doing something like this?


All lights dim dimming and illuminate gradually when powered on and off
(Ben W) #2

I worked on a dimmer DH for the GE. It is how the DE handles the setLevel command, it just jumps to it.

Here is the DH I worked on to change the speed of dimming and number of steps:

I will take another look at it, I was doing some experiments and I think I had something going, but jacked up my work pretty bad.


(Greg) #3

I’m going to try what you have. I’m happy to help test whatever you change.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

Some of the Dimmer DTHs will automatically correctly handle the second parameter to the setLevel( level, rate) command.

Try it from a test SmartApp.


(Ben W) #5

Give it a shot. Just rolled back to this version and I swear on setlevel it is stepping down. It is noticeable with the LEDs I have and the step settings I am testing with.

I have another idea that will use a different zwave command. I has some weird timing behaviors which I will need to work out.


(Greg) #6

set level to 0 for off was a nice fade. But set level to anything on % was instant on to the desired %.


(Ben W) #7

Bummer.

Here is try one:

Using a different zwave command.

Here is try 3:

Basically same as above but adds the additional field for how long (2 seconds). If it works I will clean it up some. This one is a little buggy with repeated commands since it waits the 2 seconds (plus 2 more seconds) to process anything.

Let me know if either works.


Jerky fades with dimmers (using "fade to level" in core)
(Greg) #8

Both were instant on when using set level for the on command. Both faded nicely for set level to 0 for off.


(Ben W) #9

Well, this proves that the GE dimmers just jump to the set point.

What smartApp are you using?


(Greg) #10

CoRE 12345


(Ben W) #11

Ok, give me some time.

While working on the Beddi connect smartApp I stumbled upon the ability to pass commands rapidly so the light switch does not have time to react. I was going to start experimenting to see if I can setLevel behind the scenes.

I will also take a peek at CoRes fade effect. May be able to tweak it some.


(Travis Muszynski) #12

I know this is old but I’m wondering if anyone has any updates.

I’m looking at the settings and It seems that even if you set the “size of steps in percent” to 1, meaning it will step 99 times, then set the step intervals each 10ms to 1, wouldn’t you still only have 1 second of fading going all the way from 0-100 percent? Isn’t that the longest you can set the fade?

Am I looking at this incorrectly? Can anyone that has this working properly share a screen capture with their settings? Here is mine.