Jasco/GE Motion Dimmer-scheduling motion sensor

I have a Jasco/GE dimmer switch with built in motion sensor. Since smartthings moved away from being able to use rule piston, I have been trying to figure out a work around for having the motion sensor that is built into the switch to deactivate at a certain time. (Kids bedtime to wake up time). I had a rule through with rule piston that was capable of doing this but I cannot figure out a way to do it without the rule piston. Any suggestions or help is appreciated.

There are a few ways to do it depending on whether you are using just relative times, just specific times, or a mix of relative and specific times.

In ST Routines, you can use specific start/stop times or relative (sunrise/sunset) start/stop times in the If conditions of a Routine. These will be considered preconditions (bounding conditions) for whatever other triggers you want. So from 11pm to 8am (precondition), when motion is detected, turn on light to 10%, as an example. You can also do the same thing in the Smartlighting ST app (only during these times).

If you want a mix of specific and relative times, there are two options. First, use Smartlighting which allows a mix of relative and specific times as bounding conditions (only during these times). Or, you can create a virtual device to serve as a variable to represent “Kids Bedtime”. You then have Routines to turn on/off “Kids Bedtime” and then use the virtual device as a precondition in a Routine like “If Kids Bedtime is on (precondition) and motion is detected, then turn on light to 10%”.

I use the virtual device method.

1 Like

Has your device transitioned to an Edge driver or is it still on a DTH? The DTH for these devices used custom commands that aren’t compatible with the new app (though webCoRE was able to access them). With webCoRE no longer available, you need to put your device on the driver linked below to be able to control its settings.

With that driver in place, you can schedule operating mode changes between occupancy, vacancy and manual using the routines in the app.


I did find and install this driver you mentioned for my motion switch but it only shows the occupancy vacancy in the “settings” portion and does not show up as something I can use in making a routine or in the smart lighting app. I did have a DTH before the switchover. Could this be interfering some how?

Simply installing the Edge driver doesn’t transition the device from the DTH to the Edge driver. You’ll need to exclude the device, delete the custom DTH from the IDE, and the re-add it to your hub.

1 Like

Check whether your device is now on an Edge driver by seeing if the Driver option shows in the same menu on the device that has Edit/Settings/Information. If there’s no Driver option then you’ll need to do as @h0ckeysk8er suggests.

If your device is on an Edge driver, check whether it’s using the “GE Z-Wave Motion Switch/Dimmer” driver. I have a more generic driver for GE/Jasco devices in that same channel that supports the motion switches but only exposes the configuration parameters in the settings menu. You’ll need the driver specifically for the motion switches to do what you want in routines.


I deleted the DTH from the IDE, excluded each switch and re-added them. I then installed the GE smart dimmer switch driver from the link you’ve provided. This seems to have done the trick to get the additional options for making a routine. I set a routine to be IF time is (precondition) and location mode is home (always is) THEN run scene “Paige and Griffon’s motion off”, which the scene is just turning the two kids’ switches to manual mode and thus stop the motion sensor from turning on the lights and just have the switches turn on by hand. (Manual) I attached images. Unfortunately this scene doesn’t work automatically. It stays in occupancy mode. Only when I go in to edit the scene and press the “test scene” button. Then it works and changes to manual mode. Am I missing something? Or is there any other suggestions on how to better set up this routine? Thank you all very much for your time and input with this. I greatly appreciate it!

ST Routines are event driven. So if “this happens” needs to be an event/state change. Preconditions are bounding conditions “If something in a particular state or some particular time”. The way you have it written it says:

If the Location Mode changes to Home
and it’s during 7:56pm-6:19am on S/M/T/W/T
then run your scene

The trigger is a change in Location mode to Home. If that doesn’t happen, then the Routine doesn’t fire. And in fact, I think you really want the Location mode as a precondition as well. So you’ll need another trigger to fire this Routine (which can’t be a time trigger since you’re using that as a precondition).

Also, the Actions in this Routine are “Turn on the light” and “Set operating mode”. You need to uncheck “Turn on the light” to just change the operating mode.


Ok, that makes sense. So for example, I could add in “living room motion detects motion” into the IF (or something of the sort) to trigger the “kids bedtime motion off” scene?

I noticed that with the THEN setting of the switches you have to have the setting to ‘on’ otherwise the options to change modes and such grey out and you can’t change them. Is there a work around for that?

Yes, some kind of trigger is necessary. For example, you could create a virtual switch and set that device to come on at a certain time and go off at a certain time to represent the state of Nighttime. I use that as a bounding condition for my Motion/Dimmer switches to control button and motion behavior at night. You could use that so that your trigger would be “If Nighttime is on” and conversely “If Nighttime is off”.

You have the general GE/Jasco switches and dimmers driver. You specifically need the GE/Jasco Motion/Dimmer driver from his same channel. It allows you to change settings without any on/off action.

GE Z-Wave Motion Switch/Dimmer 	e120daf2-8000-4a9d-93fa-653214ce70d1 	2022-10-02T20:15:49.147522379 	GE/Jasco Devices - philh30
1 Like

Tap the radio button next to ‘turn on’ to clear it. Different device but below is what you should be able to do. Also, you might want to eliminate the Scene and just put your actions directly in the Routine. Scenes don’t run local yet, but if you put this all in a Routine then it should.


For the trigger of the routine, why not just use their bedtime as a specific time trigger like below? It’ll go every night at that time so long as you don’t put it as a precondition. Then have a separate routine triggered by a time in the morning to turn it back to Occupancy mode.

1 Like

How is a virtual switch created?

Here’s what I have for installed driver on the motion switches. Is there something different?

Actually, @philh30 is right. I started with the original Routine and didn’t really think through what you needed to accomplish. Taking his suggestion, just add the Location Home precondition so that it only happens when you are home.

1 Like

Ignore my suggestion. I overcomplicated things. Check out Phil’s suggestion of simply changing modes at the desired times.

1 Like

Ok I set it up like Phil explained fto change to manual mode at a certain time for “bedtime” and occupancy mode in the morning for “wake up time”. Thinking this should work. Yes, I think I was over thinking this and overlooked the obvious. :sweat_smile: Thanks again for your time and assistance with this, guys!