Issues with Text Scaling on Android


(Jody) #1

Continuing the discussion from Android 2.1.0 - Release Notes - Commentary:


Android 2.1.0 - Release Notes - Commentary
(Jody) #2

It’s not that nobody wants to take time to look into it. Support is just not the appropriate avenue for issues like this. Non-approved community apps are community supported. If you have a published device I was able to track down the issue that causes this particular behavior and engineering is aware of it and will be rolling out a fix. It looks like the fix was supposed to go out in 2.1.0 but did not make it. That said, it’s not every device, it only impacts a subset of Android devices. Should be resolved in the next release.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #3

The distinction varies by circumstance / case-by-case, I’m sure, but, could you help clarify?

While it’s completely understandable that non-approved SmartApps and Device Type Handlers (i.e., those that are only installable via pasting into the IDE and/or updating from GitHub, not via the Marketplace) are not supportable by “Support@SmartThings.com”, what is the official support channel for the API (i.e., the various official methods and metadata structures as defined by the SmartThings Developer Documentation, for the code of SmartApps and DTHs)?

When I’m using a method incorrectly or when the documentation is ambiguous, the Community can be the primary and excellent source of help.

But, hopefully (??), if the API call is correctly based on the “official” Developer Documentation, and the behavior is not as documented (or has inexplicably changed suddenly), then isn’t this a more general case that could or should be routed through a traceable official support channel (not just Community)?


The alternative is to consider the entire API (i.e., “SmartThings as a Development Platform”) to be “officially unsupported”, in which case, I would empathize with @Ron … this would place quite a limit on the attractiveness of the Platform.


(Jody) #4

I would, however, highly recommend reaching out to the community for further help as you have already done. We have developer advocates who are active on the forums and will better be able to assist you in resolving that error and getting your app up and running.

Ping @slagle or myself on issues that you feel are errors with the API and we will direct you on the best course of action.


(Ron) #5

But the device worked since version 1 of the android app and I have not changed it at all. I worked in 2.0.7 and earlier. In various 1.x version the sliders I used broke because off bugs introduced in the app. In those instances I contacted support and they contacted developers and the app was fixed. Now in 2.0.8 and 2.1.0 I am seeing very strange tile display issues that I have demonstrated in this thread in my email to support. The tiles change when you scroll up and down in the app so NONE of my code is being hit at this point. When the tiles first display they are all fine. Scroll up and down and they get messed up. Tell me how that is my custom devices issue ? Months ago I had good support and issues like this were fixed. Now all I ever get is excuses !


(Jody) #6

Not saying that it is your custom code, just saying that support@smartthings.com is not the best avenue for these types of issues. I am investigating this issue myself.


(Ron) #7

Well when this issue started in 2.0.8 I posted it to the Android app thread and participated in conversation with ST staff on that thread and the issue was ignored. So I thought I would try support. What is the “correct avenue” in this case?


(Bob) #8

FWIW, I also had this issue with 2.0.8 at first. I resolved it by adjusting the DPI down on my Nexus phone (for the SmartThings app only). Of course, doing this requires a rooted device.

It’s definitely related to scaling, as is the tiny SECONDARY_CONTROL text for energy readout (i.e., “device.power”).


(Ron) #9

I am not rooted and don’t really plan to for this issue.

I am curious is this the behavior you are seeing ? The issue I see isn’t just text scaling, icons come and go, background colors disappear etc.

In this video all I am doing is scrolling up and down and you can see on each pass the tiles change in very strange ways. Icons lose color, font sizes change, tiles go blank, etc

@jody.albritton you might find this video interesting.


(Jody) #10

@Ron I have reported and documented this with our android development team. It is something they had thought was fixed. It should be addressed in the next sprint.


(Ron) #11

@jody.albritton great to hear. Thanks for letting us know.


(Bob) #12

You can also let them know that the intermittent stalling scroll in the Things view that got introduced with 2.0.8 is still there in 2.1.0. Do you need a video?


(Jody) #13

What kind of phone do you have @Mr_Lucky?


Android 2.1.0 - Release Notes - Commentary
(Bob) #14

Nexus 5 running stock 4.4.4

Also happens on my Nexus 7 running stock 5.1