Issues with sliders after recent changes Android 1.7.2


(Ron) #1

I am happy that sliders now allow a range but after this change other things are now broken.

I have two issues.

  1. You can no longer set the color of the slider.
  2. The Slider is no longer displaying the current value

The only code I changed in my device type was to add the new range option. So my tiles now look like this

controlTile(“heatSliderControl”, “device.heatingSetpoint”, “slider”, height: 1, width: 2, inactiveLabel: false, range:"(67…84)") {
state “setHeatingSetpoint”, action:“thermostat.setHeatingSetpoint”, backgroundColor:"#d04e00"
}
valueTile(“heatingSetpoint”, “device.heatingSetpoint”, inactiveLabel: false, decoration: “flat”) {
state “heatingSetpoint”, label:’${currentValue}° heat’, unit:“F”, backgroundColor:"#ffffff"
}
controlTile(“coolSliderControl”, “device.coolingSetpoint”, “slider”, height: 1, width: 2, inactiveLabel: false, range:"(67…84)") {
state “setCoolingSetpoint”, action:“thermostat.setCoolingSetpoint”, backgroundColor: “#1e9cbb
}
valueTile(“coolingSetpoint”, “device.coolingSetpoint”, inactiveLabel: false, decoration: “flat”) {
state “coolingSetpoint”, label:’${currentValue}° cool’, unit:“F”, backgroundColor:"#ffffff"
}

My sliders now limit their range between 67 and 84 which I really like !
But the background colors no longer work.
In addition every time I open the device the slider is displayed at the extreme right side. It doesn’t place it’s circle at the current setting value.

Seen here you can see that both of my sliders are not blue and they are not displaying the correct values of 78 for heat and 75 for cooling.


(Ron) #2

I wrote this TestSlider Device type which can be added using the ide to demonstrate this issue.
It has four tiles. Two sets of values with one value tile and one slider.
If you tap the value tile it increases the value used by the slider within the valid range 64-84.

The second set value/tile doesn’t have the range setting and it displays it’s value correctly on start up. ( color is still wrong).

The slider updates it’s position when you tap the value but it doesn’t update when you first open the device type detail page.

In addition my selected background colors which are different are not displayed correctly. Both sliders are simply light blue.

Here is the test device code which demonstrates these issues. The Key to seeing the slider issue is to return to the dashboard and then re-open the device details. The range limited slider will not initially display its correct value, the none range limited (0-100) slider does display correctly initially. The background colors are always wrong.


(Ron) #3

Aaron from ST support asked me to flag the attention of @kschaller @juan on this thread.

Neither resolves to a community member but I am doing it anyway.

Hi Ron,

Thanks for flagging this for us... I pushed this internally for discussion and consideration, but no promises on incorporating or a timeline. Can you also mention @kschaller and @juan on your thread to flag their attention?

I appreciate the patience.

Regards,

Aaron

(Kris Schaller) #4

Hey @Ron, sorry my handle is @kris, but I think I gave him the wrong information. I’ll check out your code and get back to you on these issues.


#5

Try @juano2310 and see if that’s the right staff member.


(Ron) #6

@kris, thanks let me know if there is anything I can do to help. Since the 0-100 initialize works I suspect that the initialize happens before the change to limit range. Let me know if my SWAG is close :smile:


(Juan Risso) #7

Hi! This seams to be related to the Android app. I will report it but can’t promise a timeline since this belongs to an other engineering team.


(Ron) #8

Yea title of the thread says Android 1.7.2 :smile:

@kris are you from android team ?


(Kris Schaller) #9

Sorry @Ron I am not :frowning:


(Ron) #10

:frowning: OK back to support then. Don’t know why Aaron suggested the two of you if neither works on Android app.


(Ron) #11

Starting to doubt anyone is working on this now. It’s a bummer that support directed me to two developers and neither had anything to do with the Android app. Seems like a dead end now. I think ST needs a better mechanism to report bugs.


(Kris Schaller) #12

Hey Ron,

Just checked on this again and noticed that the slider is now working correctly (starting from your minimum value instead of 0).

Unfortunately the background color feature is still not working, but I know that our engineering team is working hard to address the issues coming in.


(Ron) #13

Thanks @kris but I don’t see the fix yet. Do you mean in a pending version ? Still doesn’t work in my Android 1.7.2 version.

Two suggestions to improve releases.

  1. Testing…seems like more testing should be done, many issues are very obvious, it seems to me these two issues should have been caught in unit testing by the developer, integration testing by the testing team, release testing if passed these other testing levels…you must at least do unit testing.
  2. Public Beta prior to full release…less annoying to find bugs in a beta since you can easily revert back to non-beta version, you can usually install both beta and non-beta on same device making it even better.

(Kris Schaller) #14

No problem. Nope using the same build (1.7.2) that is available in the Google Play store, just downloaded it on Friday night.

I agree with you on the testing. We are currently starting up a program to get the development community early access to our builds so we can avoid things like this in the future. If you’d like to take part in the program please PM @April and she can vet you for addition to the list. :smile:


(Ron) #15

@kris And you tested my code for the slider (github link above) ? It fails on my device.
If you are testing with a slider that has a range of 1…100 that works. My provided code shows this. I created two sliders, one with narrow range and one with 1…100. The former fails the later works.

I don’t want support to think this has been fixed :slight_smile:


(Kris Schaller) #16

No worries. Yeah I used your code verbatim. I’ll go ahead and check again though.


(Kris Schaller) #17

Just tried it again on both Moto X (2 Gen.) and Samsung Galaxy S5 and it worked on both.


(Ron) #18

Strange…not working on HTC One. Why would mine work for the 0…100 slider but not for the 67…84 slider ?

Just to make sure…you are setting a value, leaving the screen returning to “Things” page. Then when you open you see both sliders set correctly. As you set the value the slider updates, it just doesn’t initialize when first opened.

Mine still looks like this when I first open it. The value is clearly set to 77 but the slider is at extreem right (which is 84)


(Ron) #19

@kris just tested on Samsung Galaxy Tablet and it fails there also. Android 4.2.2

HTC One Android 4.4.3

Just in case that helps…

If any other Android users are willing to test please report back here.
Install my device above in ide.
Open thing on ST, slide both sliders to values somewhere in the middle.
Return to Things
Open thing on ST, report if top slider sets it’s position correctly.

NOTE: tapping on the value tile to the left of the sliders will increment the value and the slider will update correctly on both slider.


(Kris Schaller) #20

Sorry that was my mistake. I thought you meant that it wasn’t starting/ending correctly when first set-up. Definitely still seeing this slider issue as well.