Sliders range not working with iOS and Android


(www.rboyapps.com - Make your home your butler!) #1

@slagle @jody.albritton per the documentation one should be able to set a range for the sliders:

controlTile(“levelSliderControl”, “device.level”, “slider”, height: 1, width: 2, inactiveLabel: false, range:"(1…10)")
{
state “level”, action:“level.setLevel”
}

This doesn’t work, it still always shows 0 to 100. Am I doing this wrong? @Ron has reported this earlier as well. I think it was fixed in between but appears to be broken now (on both iOS and Android).

@Jim I know you’re looking into another part of it, according to the documentation the action is

{
state “level”, action:“switch level.setLevel”
}

Any update on that part?


OSRAM Lightify Not Changing Color
[SUSPENDED] Blink Camera Device Handler with Motion Sensor, Live Video Streaming, Integration with SmartThings/SHM, Temperature, Signals and Push Notifications
Addressable Led's
Temp Color adjust not working on my bulbs. Please help
#2

@RBoy,

I can validate your findings. This was working for me, and when I saw your post, sure enough it’s not anymore. Here what I have that was working last time I checked:

controlTile(“heatSliderControl”, “device.heatingSetpoint”, “slider”, height: 1, width: 3, inactiveLabel: false, range:"(60…80)"


(www.rboyapps.com - Make your home your butler!) #3

Can you please report to support with a link to this thread so they prioritize it. (can’t talk about their QA anymore, frustration beyond measure; how they break something every time)


(Ron) #4

@RBoy thanks for reporting this. When I read this I couldn’t believe my eyes. I had to grab my phone and test it. OMG, they broke this AGAIN ! They have re-introduced this bug several times ! That’s right, they have already fixed this, it came back and they fixed it again a few times. What a bunch of clowns.

I even had to write this test device type just to prove to the inept development team that it was broken Again and Again and Again.

I completely give up on this platform. The only way I can see that they can keep breaking the same issues over and over is that they don’t understand how to use source code control and someone is pushing out code they worked on outside of source code control. I have had this happen to teams I have managed in the past and it was always some developer that had no clue how source code control worked. They would copy code someplace outside of the source control, often as a “backup” and then pull changes from other developers and overwrite them with their “backup” because they made some mistake. I am sure there are other ways that inept developers can cause these issues over and over but seriously I can no longer defend this as a management issue.

Anyway, I don’t know if I will even contact support about this. It’s irritates me to much to have to do it again and again. Then support replies asking all kinds of stupid questions it is taking too much time from my life to deal with this platform.

I completely understand why @bravenel has withdrawn Rule Machine now. It’s just too painful to deal with the same issues over and over.

If SmartThings wasn’t the only game in town they would be done ! I can’t wait for another product to come out with similar capabilities.

I don’t know is it becoming obvious that this is upsetting me :angry: ?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #5

I don’t believe in ghosts :ghost: as reported in a couple other threads, but I’m very afraid of clowns.

I agree… The various new or resurrected problems this week are pushing me over the edge.

W.T.F.


(Ron) #6

Why Those Fools…right ? I think the only hope for this platform is if they open source the code and let the devs in this community fix it. Of course that will never happen.


(Tim Slagle) #7

@RBoy send me an email so I can make a ticket for this.


(Kevin) #8

I don’t remember reading anything about UI changes in their announcements, but they seem to have broken a lot things. So much for transparency.

I’m pretty sure there is no hope for this platform and as soon as a viable alternative becomes available, a lot of the active users on this forum will jump ship.


(Ron) #9

I know I have already started funding Animus in indiegogo and considering funding a few others for this very reason. Someone needs to take these guys OUT.

I am pretty sure this issue is on server side because I just reverted to version 2.0.7 and that version doesn’t work either. This also explains why iOS and Android both broke at same time. I would have seen this issue between 2.0.7 and 2.1.0 (I am ignoring 2.1.1 so far, is it OK to install ?)

I actually noticed this yesterday but it didn’t click. I was wondering why my sliders on my ZXT-120 devices were so hard to use. They are supposed to range from 68-84, when 0-100 trying to select a specific number like 79 in that range is VERY hard. I had this issue yesterday and was wondering why I was having so much trouble and didn’t even realize that the range had reverted to 0-100.

@slagle you can’t create tickets based on so many people confirming an issue in this forum ? That’s a little sad. If you share your email address I would be happy to open a ticket as well as long as I don’t have to convince someone that the issue really exists. My test device above should be included in the ticket because it is a very simple way for the developer to test the issue. When they last fixed this issue for me they broke the update that is issued from the slider so that sliders ranging from 0-100 worked fine but sliders with any other range stopped sending updates. Just pointing that out so that bug isn’t also re-introduced when this one is fixed.


(Tim Slagle) #10

I sure can, but I’m out to breakfast with some friends right now, can’t do it while mobile and email is easier to track :slight_smile:


(Ron) #11

OK good to hear. Both that you can open tickets on our behalf and that you are out having breakfast with Friends :slight_smile:


(Kevin) #12

Edit: Animus in indiegogo is a project related to a movie, but Animus Home is a SmartHome project.


(Ron) #13

My real hope is that Amazon realizes ST’s issues and decided to put zwave into Echo !!! That would be Amazing ! I hate to say it but an Apple Smart Home Hub would probably work without bugs every release also.


(Kevin) #14

[quote=“Ron, post:9, topic:45436”]
Animus in indiegogo
[/quote]The only downside I saw was no zigbee support, but that’s a small price to pay in order to have everything run locally. It looks like developers can get access in July 2016 so hopefully it will be available in the fall. (assuming the project doesn’t die)


(Ron) #15

@krlaframboise

Yea, I bought a developers perk because I want to get in early and help shape the direction. They have a SDK planned but it’s not web based you just use IntelliJ or your favorite ide, that gives me hope that they have a clue what they are doing.

I plan to keep my two presence sensors on SmartThings (zigbee) and let them notify ifttt so the Animus Home Heart can detect presence, I assumed delayed but can’t be worse then ST issues. Assuming Animus gets it right. I have low expectations but high hopes (does that make any sense ?) :wink:

I also suggested on their community board that they implement ZigBee so more ST users can make the transition. They could get a nice user based if they implement both. They have a usb connection in the device and say they planned on adding zigbee with a usb add on in the future.


(www.rboyapps.com - Make your home your butler!) #16

I’ve already sent an email to support.


(Kevin) #17

I hate the ST IDE so I’ve been using notepad++ to write things, lol.

I’m going to sign up for the developer package too so I can get it sooner. I plan on creating my device handlers for the Aeon Siren and Aeon Doorbell.

I wish we could see sample code for a DH equivalent and a happ ahead of time.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #18

I can’t believe anyone is so naive to believe estimated Reward/Perk delivery estimates anymore! They are completely imaginary made up dates selected for the sole purpose of enticing as many “pre-purchases” as possible. Complete fraud.

Lookup OOmi Home’s campaign for just one example of dozens. I told them in no minced words that their optimistic dates were unethical, and I was 100% right. Didn’t take a crystal ball. Major hardware build delays, fractional shipments of flaky product, and they haven’t even begun to move beyond the Alpha stages of the software.

WigWag is currently being all smug that they have a better architecture than Revolv and SmartThings, but that’s easy to say when, after a 2.5 year delay, they’ve only shipped a handful of a subset of products… That aren’t functioning as specified.


(Ron) #19

I just watched their demo video and it looks amazing. They even demo unplugging the network.

I have had success so I am still optimistic. If it’s late fine as long as it doesn’t work like ST.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #20

I’ll bet it doesn’t work, (comma), like ST (doesn’t work). ::stuck_out_tongue_closed_eyes:

There’s no reason for optimism, unfortunately, except, I guess, that it’s hard to imagine anything worse than the current situation.

OK… This is way too depressing for a Saturday. Time to sign off before I go through “[withdrawal]” symptoms. :speak_no_evil: